OpenWrt 18.06.1 Build for TP-Link TL-WR841N(D) All Versions

This build does not work. Use this build instead: OpenWrt 18.06.2 Build TL-WR841N(D).


Thank you very much @patchez.

Will try tomorrow on my routers.
I tell you if something goes wrong.

Just a doubt: Do you replaced SQM for QoS because there's not enough space in the router?


@julianocs Yes, SQM needs an additional 15KB. I would have to remove other features in order to make space for SQM, so I decided not to include a build with SQM.

You could try removing DDNS and check if thats allows SQM installation. You could also disable IPv6 if you really need all the features plus SQM.

Hi @patchez...

I will try to build my own build too...
Can you help-me? I´m newbie in linux...

In line 24 of build script, there´s a function named " dl_and_update_config() " .
This function gets the archive from ,
that contains all targets and packages do make the build.

Where this file is generated? How to customize?


No no... This build is perfect for me...
I really need DDNS (my DVR is old, it´s the only way to use it is with help of DDNS) and IPV6...
I preffer SQM rather QoS, but QoS does the job. I asked just out of curiosity.


It is generated with the make menuconfig command. To customize your own build, remove the # in the make menuconfig near the end of the script. That will open customization menu.

Ok, i think that i understood.
I´m going to install virtual box and linux next week on my computer and try.
If i had any doubt i can send you an email?


Sure, just send me PM.

Also, you don't need VirtualBox if you have Windows 10. Just install Linux Bash Shell for Windows

All my builds have been compiled in Windows using the Ubuntu 18.04 from the Microsoft Store.

1 Like


I have Windows 7 !
But the process using with virtual machine is similar, correct?


You can free some RAM by running make kernel_menuconfig and setting CONFIG_SQUASHFS_FRAGMENT_CACHE_SIZE = 1.

1 Like

v13 supported?

Hello @patchez.

Installed now on all my routers... Everything ok.
Thank you very much again.

No, isn´t supported.
V13 have a Mediatek MT7628 chip...
I have a router with this chipset too (WR-840 v4).
Mediatek opensource driver still needs a work... Very unstable.


Hello @patchez.

I had a problem configuring DDNS...

Failed to execute cbi dispatcher target for entry '/admin/services/ddns'. The called action terminated with an exception: /usr/lib/lua/luci/controller/ddns.lua:57: attempt to index field '?' (a nil value) stack traceback: /usr/lib/lua/luci/controller/ddns.lua:57: in function 'service_version' /usr/lib/lua/luci/controller/ddns.lua:60: in function 'service_ok' /usr/lib/lua/luci/model/cbi/ddns/overview.lua:11: in function 'v3' /usr/lib/lua/luci/cbi.lua:17: in function 'load' /usr/lib/lua/luci/dispatcher.lua:298: in function </usr/lib/lua/luci/dispatcher.lua:296>

Do you know what can be the problem?



I tried to configure DDNS using command line and discovered another thing.
No-ip module (wich i use) wasn´t included ...

Take a look:

" # CONFIG_PACKAGE_ddns-scripts_no-ip_com is not set "
" # CONFIG_PACKAGE_luci-i18n-ddns-pt-br is not set "

(I´m from Brazil)

When you have a spare time can take a look too?

Thanks and sorry for my bad english.

That seems like a bug, but it could also be a configuration issue of DDNS with the new version. You could try reflashing the firmware without preserving the old configuration settings and see if that fixes the issue.

If that does not work, use previous version.

From what I see you are already starting to compile your own custom builds, I just finished compiling OpenWrt 18.06 for my WR741ND making use of the script published by @patchez I removed some packages I did not use and I managed to add SQM scripts extras instead of QoS, keep everything else.
Modifies the. config file and executes the script; I use Linux Mint but you can do it on Windows using Linux on a virtual machine.

Hello @xhaka.

What packages did you removed?
Do you keep ipv6?
If you keep ddns, could you ser if it works?


I tried to reflash from scratch. No success. Do you have another sugestion?


Not sure what is causing the issue. Similar bug was reported on 18.06.0 RC2. It may be an issue with the lua source code of the DDNS package that was not patched on the release version.

For the moment, I suggest you to go back to my 17.01.5 build.

Sorry its a bit out of topic.

I failed to safe keep my "art" partition after following this instruction

The signal range is greatly improved and yet still maintain its stability too. However, nobody mention that the wifi bandwith will be reduced to max 40Mbps (maybe only for my case). Its great for wifi repeater/range extender etc, but now I want to regain its max bandwith.

Can anyone here share the original art partition of TL-WR841N_v11

I promise to re-use my own MAC address :v:


Ok, thank you, i will try.
It have no-IP support or it's the same as yours 18.06 build?