Onhub TP-LINK TGR1900 future support?

here you go:

root@OpenWrt:~# lsblk
loop0       7:0    0  3.4G  0 loop /overlay
sda         8:0    1 58.6G  0 disk 
├─sda1      8:1    1  128M  0 part 
└─sda2      8:2    1  3.4G  0 part /rom
mtdblock0  31:0    0    8M  0 disk

That's not what I get.

loop0          7:0    0  3.4G  0 loop /overlay
mtdblock0     31:0    0    8M  0 disk 
mmcblk0      179:0    0  3.6G  0 disk 
├─mmcblk0p1  179:1    0  128M  0 part 
└─mmcblk0p2  179:2    0  3.4G  0 part /rom
mmcblk0boot0 179:16   0    2M  1 disk 
mmcblk0boot1 179:32   0    2M  1 disk 

Idk why but I can't write into mmcblk0

The output from @dadogroove is what I would expect. mmcblk0 is the writeable flash module. Not sure why it is not visible for you. Could you flash back to the stock firmware from google and try to install openwrt again? The instructions for factory reset are there in the wiki too.

Maybe do a factory reset as described on the hardware page and try again.

Hi I have tried the non-ct one from the link. Pretty much same result, poor wifi throughput performance and random reboot

Thank you

Poor throughput will not get better until both cpus are working. It is mentioned above that 1 of the cpus is disabled. This is still very much a work in progress.

I fixed the multi-CPU issue a while back, so I've pushed my latest to Github again. It also improves compatibility with the non-ct driver (note: driver, not firmware), since the calibration data only worked with the CT driver before. As far as I know, this is what will eventually be committed to the official tree.

I'm less sure about mesh issues, although I do believe I've had better luck with the non-ct driver and firmware. At least, my mesh (ASUS OnHub + Google WiFi) gets the same Internet throughput as my non-Openwrt mesh does.

1 Like

Thanks. Making a new build now to try. When I've upgraded using the generated sysupgrade file, the configurations are not saved even if I select them to be saved. Once I upload my saved configuration file it all comes back. Is this just how it is for now? Thanks for all the work on this.

I've had trouble too, so I updated the setup to use a 3-partition layout in the latest, where the 3rd partition stores the configuration data (and other writable storage). Hopefully this approach is less susceptible to sysupgrade loss/corruption. It also should obviate the need for the resize2fs instructions that somebody else wrote up.

The 2-partition setup should be able to work too, but I haven't spent much time learning/debugging the openwrt sysupgrade process, and it feels like its block (i.e., not raw NAND flash) storage support is a bit weak.

Ok. No joy then. Will stick with a wired AP. Thank you

Looks like my nand is corrupted due to previous failure during stock firmware update. How to fix it idk. Reflashing stock didn't working.

Marked by you chip content is bootloader. I think it's working well. You can try load openwrt via usb-flash with openwrt. To the right to be emmc which corrupted

It's not working. Recovery stuck after one minute.

When I've done it it take 5-10 minutes to complete. I used the balena etcher program mentioned above to create the recovery USB using the file link in the wiki. I use a flash drive with a light so as to see the activity. It seems if you can get Openwrt to load the recovery should load too.

I can load openwrt only from USB. When I try lsblk in terminal I can't see mmcblk0 device so I can't dd it. That's why I think recovery stuck always. Maybe it's bootloader chip corrupted, which can be simply reflashed from working dump. For now IDK

It would be great if we can load openwrt even from USB but without pressing dev button it's not working for now.

I assume you've tried different USB sticks for recovery. From the wiki:

Note that Recovery mode does not appear to work with all USB drives (for example, some newer USB 3.0 flash drives). If the device appears not to be accepting your USB drive, try swapping for a different one.

Sorry, that's all I got.

Just out of curiosity, what does it do when just plugged in without the USB stick. Does it boot?

It's just blinking red and nothing else. Wan&lan not working. Wifi too. According to Google onhub support explanation this mean that device corrupted.

Tp link support and Google support will not help. I tried several times( Blinking red is death for Onhub. Problem in 8 mb flash on nand memory chip Micron. I can not find this flash.