Onhub TP-LINK TGR1900 future support?

It is not necessary to use a keyboard and press ctrl+d. My understanding is that it just avoids having to wait for the beep, but I think hassle of connecting a keyboard is not worth it. I've tried both methods and they work.

Thank you!. WIll be trying it out today

Does it work on Asus variant?

I used Balena Etcher to flash the pre-compiled experimental firmware to a USB stick, followed the instructions, and so far, so good.

I did run into a weird issue when attempting to expand the storage as outlined here: https://openwrt.org/inbox/toh/google/onhub_tp-link_tgr1900#expanding_storage_optional

Step 6: resize2fs /dev/loop0

resulted in

resize2fs: Bad magic number in super-block while trying to open /dev/loop0

Any thoughts on how to resolve this?

The instructions there would work for ext4, but since this is squashfs partition with hidden f2fs, you can follow this guide to do it: https://openwrt.org/docs/guide-user/installation/installation_methods/sd_card
Essentially, you would need 2 commands:
opkg install f2fs-tools
resize.f2fs /dev/loop0

Got it working. Thanks a ton! Your instructions were spot on

Do you have image for the Asus model? Thanks.

Any love for ASUS SRT-AC1900? Thanks guys.

Here's a link to the asus build. I don't have this variant, so haven't tested it yet: https://mega.nz/file/m4dFEIiJ#4xftsjkyxK2Bj-QKlTXkyWHiznF8U0SotVk0zCqzhBs

Thanks for the image! It works pretty well.

Any way to easily upgrade the kernel? Also, would it be advisable to use some of the packages from generic subsystem?

Thank you again!

Somebody please make flash dump of this Micron chip

could you please point me to the link for the ath10k-firmware-qca988x firmware? I tried updating using the luci interface but it says the pkg I used is not compatible with the architecture. I would like to get the mesh running


I found it the from the link below

However it has issues

  1. Mesh performance is really poor
  2. AP is rebooted randomly.

So it is not pratical to use these firmwares

Hopefully someone will come up with better solutions to create mesh

Thank you


Thank you for your response. I found another file at https://openwrt.org/docs/techref/instructionset/arm_cortex-a7_neon-vfpv4

However, I have 2 onhubs and the specs are exactly the same. This firmware worked on one by upload through luci and mesh was enabled. I did not remove the ath10k-firmware-qca988x-ct However, on the other onhub, on upload it gives the error "ath10k-firmware-qca988x-ct already present on root". If I remove the latter, the ath10k-board-qca988x which is already installed also gets removed and then I cannot install ath10k-firmware-qca988x . Still playing around with these to see if I can get it installed. Would you like to try the firmware from the above link and see if it improves your mesh performance?

were you able to get the boot process video together? also i just had an aneurism trying to read your code on github so if anyone knows where i can find a link to an iso i can just flash to disk utility and get this router up and running again that would be much appreciated

jkjkjk im meming about aneurysm oop tsym

stonics has given an image above and the complete process. There is a boot video ealier which can be followed for the first 3.5 minutes or so

Could somebody help with TP-Link Onhub (TGR1900)?

When I try to:

ssh root@ -C "dd if=/dev/zero bs=512 seek=7552991 of=/dev/mmcblk0 count=33 && \
dd if=/root/openwrt-ipq806x-chromium-tplink_onhub-squashfs-factory.bin of=/dev/mmcblk0"

I always get:

33+0 records in
33+0 records out
dd: error writing '/dev/mmcblk0': No space left on device
1025+0 records in
1024+0 records out

Please help

I was having trouble with that in a different way. I used WinSCP to transfer the file (openwrt-ipq806x-chromium-tplink_onhub-squashfs-factory.bin) to the /tmp folder on the device and then in ssh (using putty) just sent the command:

dd if=/dev/zero bs=512 seek=7552991 of=/dev/mmcblk0 count=33 &&
dd if=/tmp/openwrt-ipq806x-chromium-tplink_onhub-squashfs-factory.bin of=/dev/mmcblk0

and it worked for me. If I remember correctly the last two in and outs are 256 or so not 1024,1025.

I do the same from Linux terminal, but output the same on two different TP-Link onhub.

Could you install and run lsblk and send me the output from it? This will list the storage devices and the amount of space that it has. There are 2 flash chips in the onhub, one of which is used by the bootloader and not writeable normally.

ssh into the onhub as root

opkg update
opkg install lsblk