Onhub TP-LINK TGR1900 future support?

My first question is, did the wan port work before OpenWRT was installed? The snapshot build should work fine right out of the box. Have you tried doing a recovery back to stock and then flash OpenWRT again?

It's already hooked up and working. You just need to install an audio server or some basic set of tools. I tested out mpg123 (available in the packages feed) and it worked just fine.

I know less about this one, but those links seem promising. I can see about hooking that up, now that it's committed to openwr.git, although I don't have 802.15.4 stuff to test it with.

When I recover back to stock, everything works- with ethernet from my laptop to the Onhub LAN port, and ethernet from the Onhub WAN port to a LAN port on my regular router, I get network on my laptop. I've recovered to stock and flashed the snapshot image a few times. Anything I can do to diagnose the problem? Anything in the logread output I should be looking for?

I had issues with the network not working after re-installing OpenWrt a few times. I fixed it by wiping the whole emmc before writing the image. Maybe give that a try and see if it helps?

Thanks! Hate to ask for handholding, but is the way to do that:

dd if=/dev/zero of=/dev/mmcblock0


Start with ssh-ing into the the router and wiping the partition info. Then wipe the whole mmcblk0.

ssh root@
dd if=/dev/zero bs=512 seek=7552991 of=/dev/mmcblk0 count=33
dd if=/dev/zero bs=1M of=/dev/mmcblk0

This will end with an error / warning when there is no space left to write to.

Then copy the factory image from your pc or laptop to /tmp on the router.

scp -O openwrt-ipq806x-chromium-tplink_onhub-squashfs-factory.bin root@

Then write the factory image to emmc and reboot with the USB drive removed

ssh root@
cd /tmp
dd if=/tmp/openwrt-ipq806x-chromium-tplink_onhub-squashfs-factory.bin bs=1M of=/dev/mmcblk0

Hi @dadogroove, Just want to double check with you about the following.

Assuming I have flashed my asus on hub using the last factory.bin (before NSS support, OpenWrt SNAPSHOT r21765+149-d7a9724ca8 / LuCI Master git-23.013.73089-9634086). I can upgrade the using the luci using the openwrt-ipq806x-chromium-asus_onhub-squashfs-sysupgrade.bin.

Is that true? Will i lose the current setting by doing this?


Network configuration between swconfig, NSS and (pending-) DSA aproaches is different, don't retain configurations when switching between them.

can I still use the sysupgrade image or do i need to reflash from the factory image?

You can use the sysupgrade but just reconfigure your setup afterwards. I have found with this device the sysupgrades don't seem to fully take when I have it save the configuration. I always just apply a saved config (restore backup) after upgrading without saving my configuration. Once you're on the NSS builds, if you upgrade to another NSS build just restore a back up after a clean sysupgrade flash.

Sorry in my being a little dense. So does this mean that I can restore from a backup even when I sysupgrade from a non NSS build to a NSS build or do I have to re-configure?

I think that depends on how elaborate your setup is. If it is pretty basic, I think you should be ok.

Thanks for your immediate response. yes its pretty basic, so should not be a problem

Just don't forget to add the NSS commands into the local startup. You will need to reboot afterwards for them to take effect.

wiil do. Thanks again!

1 Like

Is there a summary of what we need to add back in? I updated to the NSS build and restored a backup from one of the original builds before I realized there was anything I needed to preserve in the startup.

Add this to the local startup file (rc.local) adjusting (870/25) to the speeds you have to enable the NSS cores.

modprobe act_nssmirred

# Shape ingress traffic with chained NSSFQ_CODEL
tc qdisc add dev eth1 root handle 1: nsstbl rate 870Mbit burst 1Mb
tc qdisc add dev eth1 parent 1: handle 10: nssfq_codel limit 10240 flows 1024 quantum 1514 target 5ms interval 100ms set_default

# Shape egress traffic with chained NSSFQ_CODEL
tc qdisc add dev eth0 root handle 1: nsstbl rate 25Mbit burst 1Mb
tc qdisc add dev eth0 parent 1: handle 10: nssfq_codel limit 10240 flows 1024 quantum 1514 target 5ms interval 100ms set_default

Then reboot for it to take effect.

Just asking out of curiosity, is it impossible to use the OnHub as a Bluetooth speaker using the built-in Bluetooth module and speaker?

i don't see why not. oh yeah. good luck setting up bluez.

I got the Onhub as a BT speaker working just now. I kind of didn't take good notes, so I'll have to go back through everything later to make proper directions, but here's all the packages you'll need to install. If you're using OpenWRT official builds, you can install all the packages and kernel modules listed below and try it out that way. If you're using dadogroove's build, you'll need to follow his build directions and add them to the diffconfig, due to the added kernel modules.


It is especially important that you install pulseaudio-daemon-avahi and not regular pulseaudio-daemon, even if you are not using avahi/zeroconf. It only says it in the package description, but this is the one compiled with support for bluez. I lost a couple hours to troubleshooting this, not proud to admit.
After that you can start to follow directions on how to link up BT to the speaker, from here:

Or other guides online for how to configure a Linux PC as a BT speaker.