Onhub TP-LINK TGR1900 future support?

Okay so for me, the first time worked. I was able to restart it several times, move it to the desired location, and all was good. I only discovered this issue after I lost access and didn't have the time to open it (still haven't) to get to the serial interface and reset it that way, but instead restored and repeated the original process.

Oh yeah, I lost access because I was stupid and applied settings in the wrong order.... so nothing to do with openwrt :smiley:

When I install my USB drive and try to recover image to factory reset my Onhub, but I think Onhub doesn't recognize my USB.
My USB is USB 3.0 with 16GB, does the USB 3.0 matters on Onhub?

My factory reset USB drive was also a USB3.0 16GB drive and it worked fine. Just takes a long time in general.

When I connect USB to Onhub, it just showed blinking red LED light and doing nothing.
Also USB didn't blinking that was not busy.

See msg 116 above by dadogroove "Note that Recovery mode does not appear to work with all USB drives (for example, some newer USB 3.0 flash drives). If the device appears not to be accepting your USB drive, try swapping for a different one."

OK I managed to reflash mine successfully after being locked out and resetting a few times. What I ended up doing is as follows:

  • Factory reset using the google chrome created 'special' USB stick
  • Boot OpenWrt from a USB stick
  • SSH into OpenWrt and dd the whole /dev/mmcblock0 with zeros (this will take a while)
  • SCP the factory image to /tmp on the Onhub
  • write the factory image to /dev/mmcblock0 using blocksize of 1M (bs=1M)
  • reboot with the USB stick removed

Now my OnHub boots OK and gives me a connection on the lan port as expected. I'm not sure why I had issues before but I guess there could be some leftover data on emmc when we write the image. Hope this helps others who are locked out after messing up their config.

Thanks to the developers for all their effort. This is still a great piece of hardware and now even better with OpenWrt.


I think also devloper mode is same. I tried to install OpenWrt in developer mode with same USB, but it seems to not boot with USB and goes to only breathing purple light.

Are you experiencing intermittent internet on the mesh? My onhub also seems to be heating up more than usual after I installed the latest snapshot

The device page doesn't make it clear but it does take some time after the RGB ring lights up before the network is active. I never timed it but it seems like it takes around 20-30 seconds. Not sure if this helps anyone. Also not sure if a static IP is required but I always set it manually anyway.

Thanks for the info! I kindof figured it was something like a partition left over... Ill give that a try over the weekend and see if it works for me.

Are you still having issues with a single core maxxed out when pulling around 200mbps over wifi when booted to internal storage? I'd love to have the hardware offloading (is that what it is?) working properly if possible. The OnHub seems like a great device to actually be capable of some sort of mesh networking as well as running openwrt, at least at first glance with the way the wireless interfaces appear. Too bad it can't do 160mhz channels though, I mistakenly thought it could until I looked up the specs the other day :confused:

Is there no way to configure over wifi? Should I connect Onhub with my computer and go to webui and turn on wifi function to use wifi?

edit: I found out myself on here; https://openwrt.org/docs/guide-user/installation/flashing_openwrt_with_wifi_enabled_on_first_boot

edit 2: oh, it's so hard for me... I saw the factory bin file and I don't know where to put codes. This is my first time to try using OpenWrt, so I think I have to study to edit codes...

just a few things I have noticed
none of the 2 buttons seem to be mapped to reset
I think this would help people reconnecting when there is a fault as seen in this thread
knowing that pausing the button on the back would factory default the settings would be good

also as the device is left in developer mode this won't allow you to leave a storage device
plugged in while boot due to it trying to boot off it
I guess you could put openwrt on that device but just makes it more complicated

I did test leaving developer mode it with an early version
but just left the led's in the red/orange brick mode
is there a way for us to get out of debug mode to usb will work etc

also trying to boot back off the USB to gain control due to not being able to factory default
seems to use the bad partition in the unit rather then the one from the USB
so the only way to recover is to use the onhub recover usb to over right the flash
so the openwrt USB will boot correctly

1 Like

Oh my, is the red/orange moving color means it's bricked?
I first did recovery with onhub recovery firmware contained USB and it did great, and I tried to install OpenWrt with the OpenWrt factory firmware which is on the wiki. I followed correctly what in the wiki says but it shows red/orange colors moving led. Does it means bricked/fatal error?

red/orange moving colour is when it can't find something to boot
like a PC that has no bootable partition
yes you can fix it
I have seen it do this when usb is not bootable & plugged in
or can't boot from flash
it also did this when I left development mode with openwrt in flash
I have to go back to development mode for it to boot again

Ah... okay I'll try more
And which program you used to flash OpenWrt factory firmware to USB? Did you used Balena Etcher?

I used w32Imagewriter that a have for raspberry pi's
need to clean disk with windrows diskimage 1st tho

1 Like

An update on the 'only booting from USB' situation... Thanks to @konus for the suggestion my device is back to running on internal storage!

Now if only I could pull more than 200mbps over wifi...
Oh well, I'm probably the only one in the house who will notice :smiley:

1 Like

Is there anyone who can enable WiFi enabled on first OpenWrt boot?

While that isn't really difficult to accomplish for a personal build, it's not going to happen for official images. Do yourself a favour and get yourself ethernet connectivity, and be a crappy sub-10 buck usb2ethernet card and a 1m patch cable, it's worth it and is a hard requirement (in the sense of some kind of ethernet) for using OpenWrt. You won't need it often, it doesn't need to be fast or great, but it needs to be there, when push comes to shove.

Great answer! I'll gonna buy cheap USB to ethernet converter right now haha