NTP Stratum 1 documentation is invalid

So before investing in a "good" time source, I bought a cheap usb one and tried to use the instructions here to complete the config.

The problem is, the version of NTPD included with openWRT does not pay attention to the config file mentioned in the documentation ( /etc/ntpd.conf ). Instead it refers to /var/etc/ntpd.conf which by appearance is generated on ntpd start from /etc/config/system

Please consider adding a warning to that page.


wiki is basically open to anyone - just apply for an account here Applying for OpenWrt wiki account and edit it yourself !


I have updated the instructions https://openwrt.org/docs/guide-user/services/ntp/gps#vk-172_usb_gps according LEDE as Stratum 1 NTP server using USB GPS - #22 by artioni81
Confirmed working on 21.02.0.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

Thank you tmomas! Yes this worked to correct the issue.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.