New 3DS - BootNTR and LuCi Firmware

Hi again Forum, it's been a while...

My problem is as follow. I got a Nintendo 3DS ( "New" version - Not the Old ) and I'm trying to use BootNTR.

If I use it on my Main Router ( Non-LuCi ) it works perfectly - as It should be - but when I try to use it on my LuCi Switch ( Technically is a Router without DHCP server ) it connect, sends spikes of FPS and then disconnects.

BootNTR uses port 8001, but Router has UPnP, so it shouldn't be a problem... and other programs that Stream, like the Playstation Remote - To play on my PC ( Tried it Once ) works perfectly. So my best bet is that there's something not properly configured on it.

Can anyone lend me a helping hand here?

Firmware Version : OpenWrt 18.06.5 r7897-9d401013fc / LuCI openwrt-18.06 branch (git-19.309.48729-bc17ef6)
Router ( on Switch Mode ) : ADB P.DG A4001N1 - Main explanation as how it's setted, from previous assistence I required.

Thanks in advance.

If I attempt to connect while connected to the Switch ( Router with LuCi Firmware ) and doing pings to it, packet loss and packet delay start to happen.

Just to give more info.

Re Bumped after 5 Days.

Really need help here guys.

Bumping doesn't do much, as we can all see your posts. Can you explain what is BootNTR; and how does it relate to OpenWrt?

Seems like CPU/memory at first.

Well, first: bumping sends the thread to the first place for everyone to see it when they arrive.

Second: BootNTR is a Streaming APP ( Homebrew ) for the N3DS to stream directly to the PC ( it need another program in the PC to gather the information.

The one on the PC, connects to BootNTR to get the N3DS images. As said on my first post, it connects to port 8001.

PC is connected to the Switch ( Router ADB P.DG A4001N1 ). If I connect the 3DS to the Main Router ( Default Firmware from Movistar Spain ) Streaming works perfectly, but if I connect to the Switch it does not ( Sometimes it gives a few FPS and then disconnects, other times it just doesn't connect ).

I tested to ping the N3DS from the PC on both sides, and when It's on the Switch, it just start losing packages.

Since I stream from PC to Twitch ( Sometimes ) and know for a Fact the it's not CPU or Memory from the Switch ( Neither is on the N3DS since it does a good job when connecting to the main Router ) or PC.

I believe LuCi is blocking some packages or not placing the packages on good track.

( For more information about how my LuCi Firmware is configured, please read the Main explanation on first post ).

I can't give you any more information about BootNTR since I don't know it, but I can search it, if you tell me what you need.

N3DS stands for New 3DS ( Not Nintendo 3DS, which is the old Version of 3DS ). The "newer" version of 3DS has more CPU, more Ram and move VRAM.

Link to post, didn't help; this did:

It also has a 320 MHz processor...

Definitely. To be clear, are you saying that you're running BootNTR on the OpenWrt device?

If so, that's the issue.

That's because I specify to be the one on the main Post

This one. ( That's how mine is setted )


The Switch ( Router ADB with LuCi in switch mode ) itself just serves its purpose... Interconnect Devices and handle Data transfers ( Like a Normal Switch ) nothing more, nothing less.

Note: Switch is completely Clean ( No extra Software installed on it ) so Space/Memory should be perfectly fine. I even disabled the Firewall since the one in charge is the main router.

So all of this got nothing to do with it. Since and I quote myself one more time:

If it was something about the router not handling the data transfer... I wouldn't even be able to Stream to Twitch, Play online, have almost 4 devices connected through WiFi at the same time on that exact same switch plus my PC. ( True, it's going at a top speed of 100 Mbps - which is not much this days -, but it works ).

The problem, and I repeat myself, is When I launch BootNTR ( ON MY N3DS - on Port 8001 to specify which port it's using ) the switch will start to loose packages ON THE N3DS, but not on the PC ( PC Works fine, N3DS won't surf the inet ). 100% it's something not configured correctly on the Router, or a protection against something which will go through from them main router, but not from inside.

I will explain this just in case you miss it:
Switch - Connected by ETH -> Main Router
PC - Connected by ETH -> Switch
N3DS - Connected by WiFi -> Switch
Wifi A - Main Router - SSID X - Channel X
Wifi B - Switch - SSID Z - Channel Z
( X and Z are just representations, meaning they are different so I know When I'm connecting to one or another, and also channels are different so they don't collide and decrease stability )

IF N3DS = Switch -> Packet loss appear.
Else Flawless connection.
I'll try to test if another PC Connected to the Main Router By ETH, can connect to the N3DS without problem.

Just keep asking if you didn't understand anything... I'll try to give it a better explanation, but please, read, and don't skip posts or phrases.

Damm, quotes here are tough :rofl:
I like better the ones on Steam or any other Forum xD

I'm not missing anything. I just don't know why you are insisting an OpenWrt problem.

If your OpenWrt is merely a switch with no software; and you insist it's configured properly, then I'm not sure how the OpenWrt is involved.

Do you want to share configs now?


When and where did I say It's configured properly? xD That's Why I'm asking here...

config interface 'loopback'
		option ifname 'lo'
		option proto 'static'
		option ipaddr ''
		option netmask ''

config globals 'globals'

config interface 'lan'
		option type 'bridge'
		option proto 'static'
		option netmask ''
		option ipaddr ''
		option gateway ''
		option broadcast ''
		option delegate '0'
		option _orig_ifname 'eth0.1 wlan0'
		option _orig_bridge 'true'
		option ifname 'eth0 eth0.1'
		option dns ''
		option igmp_snooping '1'

config switch
		option name 'switch0'
		option reset '1'
		option enable_vlan '1'

config switch_vlan
		option device 'switch0'
		option vlan '1'
		option ports '0 1 2 3 8t'

ETH Port 1 is used to connect to the Main Router... The other ETH ports are for lan purpose.

P.S.: ETH from Switch to Main Router is a normal ETH cable ( I guess... can't remember if I change it or not )

So? Did you find anything?

Not really, it's a switch and not running BootNTR. I think we're intercommunicating here. There's nothing to look at. If your device is having bandwidth issues, I'd advise purchasing another switch.

I do see one thing.

  • Did you add eth0 to this interface?
  • If so, why?

I don't recall doing that, but even If I did that... It was a long time ago to remember why.

What does it do? :sweat_smile: ( Really can't remember xD )

Just to clarify:

Main Router

  1. Emits WiFi
  2. Got Things connected. ( 1 PC, a SmartTV and the LuCi Router )

LuCi Router - Without DHCP ( Switch Mode )

  1. Emits Wifi
  2. Is connected to Main Router through ETH cable ( Connected on first port - Since this Router doesn't have WAN port ).
  3. Got things connected. ( 1 PC, and Many Mobile devices - Including the 3DS )

Probably I tried to link the LAN Port 1 and Port 2 in order to have iNet access in case all went wrong... just guessing.

It could be breaking your setup by looping packets back thru the switch! That would explain your issues plugged into a simple managed switch!

What does this mean?

I thought everything was plugged up via Ethernet cables.

Ummm...OK...I'm not sure why you're providing all this information anyways...can you just check that eth0 setting?

It seems like you don't want to check/fix anything once it's been identified.

If you're having issues or don't want to, just reset the router to defaults and setup the switch again.

How exactly would it be breaking my setup? I mean, In which way?

You are definitely not reading. ( Thanks me, That I Knew you were not following up )


Emits WiFi means exactly that. Devices can connect to it through wifi. LuCi Router ( Switch Mode ) is not connected to Main Router through WiFi, but through ETH.

Main Router: SmartTV is connected through WiFi, PC through ETH.
LuCi Router : PC through ETH, PS4 through ETH ( But not important at all ), Many Mobile devices through WiFi.
Some of those Mobile Devices switch places with the Main Router when they are out for the LuCi Router's Range.

Since you are not reading, I want to make clear that I'm providing every bit of information I can, in the most clean way possible, or repeat it in another way, or, at least, give it to you, so no one can say I'm not cooperating.

It just seems that I want confirmation about what I'm going to touch, before touching anything at all. Since it's a pain in the ass having to bother my whole family for something It only bothers me. ( They will get mad at me if the WiFi for the whole house is not working ).

Last time I checked my English wasn't that bad so people couldn't follow up with what I was talking about. I don't know, Do you want a sketch of how my Setup is? Just ask... but don't assume anything, because you are assuming in the wrong direction and that's why I won't touch a thing until I'm sure about what I'm going to change.

Take you time before answering, make your own sketches if you need to.

So have you changed/tested the eth0 yet, or not?

Since you feel I'm not reading, I should perhaps let someone else assist.

FYI, a switch implies wired Ethernet, not WiFi. I was reading. It's slightly confusing when you made sure many times that I knew the OpenWrt is a switch, then later mention WiFi.

But I mean, I haven't experienced anything about that since I configure it ( And It was a long time ago ), how exactly ( Symptoms ) would I expect.

But I mention like... ALL THE TIME, that it's a ROUTER, configured as Switch ( Switch Mode - No DHCP ).



Here... Implied.

Here... Implied AGAIN.



If I count correctly... there are 6 times I told you it's a Router in Switch mode ( Without DHCP ). +1 more time right in this post.

BTW, if you set a Router without DHCP is basically a Switch. ( Well, and Without Nat and Firewall... and I don't have them on my LuCi Switch ( Technically Router - One more time )

And, once again, I'm explaining something I already did... more than one time... and that's why I'm not changing anything yet.

P.S.: I just posted here for someone a bit professionally to replay... Guess it's not the case.

There it's a perfect example of you not reading. It was after your second message, just to clarify you a few things. Because, of course, you didn't read my first post... or it's link.

On my First post I said that 3DS was connected to LuCi Switch ( Router ADB ). 3DS only has WiFi [ So it's implied. So there's nothing to agree... just pointing out, AGAIN, that you don't read. Neither search or ask for things you don't know or understand. ( This isn't the first time I'm saying it ) and nevertheless, you accuse me of not trying something, from someone that didn't even understand what I was saying. Do you see the dilemma here? Wait to understand and confirm that your answer is ok ( or even so, teach myself again to understand if that's the real solution - Yes, without testing. ) or trust you blindly, without any other confirmation, spend time reloading my previous settings, with my parents bothering me to hell about it. ( Keeping it simple for you to understand - And probably it would be too difficult to follow : Keep working - Since It doesn't bother me at all, except for the streaming 3DS thing - or Stop my world for someone else that doesn't even understand what I'm asking ) ].

Since you are not cooperating, just ordering, I'll come back whenever I found the exact answer and post it here ( Or probably not ) with detailed explanation of what was happening. ( Since Packet lost from time to time, it's not a problem of looping - Since PC connected to LuCi should be affected as well, since it will be collapsing the switch itself with information, but it does not.


If you are confused with something that is written down, please leave. Since it only takes about 5 minutes ( And I'm being kind - Edit: Just measured it, it took me 8 [ 7:53 min to be precise ]. Every single Word on it, including this whole text. ) to read it all to refresh it a little bit ( And English is not my mother tongue - So If it's not mine and I'm able to do it, you should be able to do it too, if you "ASSIST" so many other people. )

Make like a tree and leave. For people like you, society is downgrading.

Edit - There's nothing to edit since I'm not breaking any guideline of the community.
Plus : I mark this as an answer, since there's no point of keeping this post alive, I would rather let the people ask the community so the would know what they are facing than keep posting here. Thank you very much for your attention, have a very good day.

Words of Advice : Have Luck in here or learn by yourself, Fix It yourself. This is the Forums Moto.

Please let us know if you want to test. Let us know your results. For the record, I tested the loop with a stream. Also, it's inconsequential if it's WiFi or not, that was my point; and I'm wondering why you care so much.

Lastly, you purposely altered the context of my response about returning after days. The context clearly meant that you refuse to test the only thing that I identified in attempts to help you (it makes me think you're not reading, actually). This is an open forum, so others are free to reply too.

You prefer to nitpick my words and troll on the context instead.

I hope you identify the packet issues to your satisfaction.


(I hope the :globe_with_meridians: gets much better with a person willing to remain kind to you, despite your lack of reciprocity in return.)

You wish.
I didn't altered the context... Testing or not, is not the point of saying "Reappearing many days later" since I'll say it or not. There's nothing confusing of not receiving a response.

I don't need the world to be kind with me, whenever I got truth by my side. That's the difference between Science and religion. ( Stick to the later, since I'll stick with science. ).

So you tested removing eth0?

Was that the solution?

Please respond and mark the post that explains so others can clearly see.

Are you OK?

We are on testing. I tested, did you?

OH, I get it. Your parents are hurrying you to fix this ----.