[Solved] ADB P.DG A4001N1 Switch mode not working properly

Hello Forum:

I have just installed LEDE Reboot 17.01.4 on my ADB P.DG A4001N1 Router (4 Lan ports - None for Wan).

I've follow the instructions to configure it following (So you visualize what I want to do)

Nat: single
Usage variant: LEDE as switch (connected by wire or access point or as wifi repeater)
Visualization: clients (Wireless and/or Wired) :left_right_arrow: LEDE as switch (no NAT) :left_right_arrow: ISP router (with NAT - More clients here) :left_right_arrow: Internet

Simple way to explain : LEDE as a wire-to-wire switch

But adding the AP functionality (Correct me if I am wrong, that would be "LEDE as wireless access point (wifi<->wire switch)" but allowing the downstream, right?).

In the past, I made it work with OpenWrt, but I found myself with this "WALL" when I tried to create a server, but outsiders were not able to connect (NAT not going through?).

What have I accomplish so far:
Wifi works flawless ( Don't know and don't care about Ports at this point ). IP is being given by main router.
Wired devices don't get proper IP (Not even the getaway or netmask - I configured it through SSH and also tried by Web - Still getting as submask). If I manually set it's IP, Gateway, Netmask, It works perfect (Still, not trying ports for servers :rofl: ).

I have disable: Firewall and odhcpd.(Should I keep them disable? Should I disable dnsmasq too? )

Also the word "hostapd" appears many time, but all I found was an empty file (I think it was in /tmp or it was /etc/conf? Can't remember - Some help here would be much appreciated :sweat_smile: also with where can I find "hostapd-phy.conf" which it happens to be nowhere - Not very familiar with Unix commands )

One last thing ( I should probably use the search engine inside this forum for this one but got many answers that didn't worked for me ), Date and Time are not set correctly (I have modify system.conf and set it to 'Europe/Madrid' - 'CET-1CEST,M3.5.0,M10.5.0/3' - Which should be ' CET-1CEST-2,M3.5.0/02:00:00,M10.5.0/03:00:00', but, heeey, I'm not the doc., DOC. :joy:)

Well, that's all for now. You would probably ask for a log or something, but, as you have already guest for what I said before, don't know how to :sweat_smile: (If those logs you would be asking for, are not the ones from System or Kernel shown by the LuCi).

P.S.: I can remember something about adding Route tables... Could that be the trick? But I shouldn't be that way.
Also, ETH from Main Router (R1 form now on) to R2 it's a standard one. Crossed ones are used for PC <-> PC, If I can remember correctly some of my network teacher words.

Sorry for my not so good english, long time since I wrote this long :joy::joy:.

Thanks in advance.

With a wired connection to the main router, this is called a "dumb AP".

  • Crossover wiring is not required with modern hardware. Modern hardware will detect the situation and automatically swap TX/RX on one end to link up over a straight-through cable.
  • Disable DHCP v4 and v6. Clients will (must) receive DHCP assignment from the main router.
  • All interfaces wired and wifi in lan. wan network is not used. Firewall is irrelevant, since everything is now in one network bridge.
  • Give router an IP on the network, also tell it the gateway and DNS are the main router. This allows it to connect to Internet for example to set clock with NTP.

Wireless connection to the main router is more complicated. Either use WDS (requires WDS capability on main router) or relayd.

1 Like

Thanks for replying @mk24 :

That's right, "Dumb AP" - I thought that was the name for only being AP. Thanks.

  1. That's what I thought (I made it work before, but I wanted to be sure what I was doing was right from the start.)
  2. Didn't said it, but got it disabled form config files. :rofl: Just checked it from LuCi, DHCPv6 was still on. Shouldn't be an option in "General Setup" to disable both IPv4 and v6? It would be much simple that way.
  3. Got it already.
  4. Main router is an VG-8050, so yeah, I can handle that.

As I said: I made a workaround before for OpenWrt, but ports (Digital ports, not the ones phisical) were not going through (My bet? My workaround was just that... avoiding mines :smile: )
Note: This router got no WAN port. So basically I got 1 Eth ports for I/O data to main router and 3 Eth ports to connect PCs. Vlan functionality disabled (Just not interested in it - Should it be on?)

Tested :
Same results. (Mask and IPv6 in assigned mode with a random Non-assigned IP).
I would thought it was because Wifi is in radio mode, but the value was autodetect, so I guess it's right?

Change made:

  • Router Advertisement-Service - Disabled
  • DHCPv6-Service - Disabled
  • NDP-Proxy - Disabled

If I got odhcpd disabled, Wouldn't that work as DHCP disabled? If not, why?

Just in case it's required and getting it all in one page: ADB P.DG A4001N1 - Techdata - Image is nothing like the I've got but I can asure you it's this model... :laughing:

Thanks for the fast reply.

As for today ,18 of Dec, I decided to start over and do it by web interface instead of editing configuration through SSH (I'm using PuTTy).

For my surprise It worked flawlessly (Still not testing Ports, but should be OK). I double checked configurations with the ones I wrote by hand - Apparently not much differences were found. Web interface places another useful information that I didn't wrote and vice versa. But still network configuration was the same, even LuCi display the same Information that was shown before.

Could it be something to do with PuTTy inputs? (Best chances are that it WON'T affect it anyway. This used to happen to me back in my school days when we were programming in bash for simple tasks... I used to work at home with Windows and for some reason I can't remember (Character Coding?), made my script fail.)

I hate to bother other with questions like the ones I asked for in the first place, but want to understand what could have happend to make it go wrong.

Gonna set NTP back to Span + Europe Pool, and try to adjust date/time manually ( Backing up configuration first :joy: )

Thank you again @mk24 for lighting up my bulb ( :bulb: EUREKA! ). Even though you didn't mention it :smile:.

Some more info that I've just checked:

"Use custom DNS servers" Shouldn't get dns from main router automatically? Because setting them manually is like punching yourself in the face :rofl:. (Wasn't able to ping from inside R2. I placed R1 IP, instead of public DNS form ISP :sweat: Which didn't made the trick.)

DHCP 4 and 6 servers are run by different programs (dnsmasq and odhcpd respectively). The configuration of a dumb AP needs to disable them separately. This is done in /etc/config/dhcp with option ignore '1' and option ra 'disabled' option dhcpv6 'disabled' respectively.

When you set LAN to a static address you have to specify a DNS server for the router to use for NTP etc. The most direct way is to set it to your main router. You can also go straight to an external IP.

But, like I said, I pointed DNS Server to R1 ( inside "Interface -> Network -> Lan", but still it wasn't working.
Should I set something on R1 to point it to R2? (I set a Static route, just in case... but still happening)

R1 : VG-8050 - Movistar-ES (OEM Firmware) -
R2 : ADB P.DG A4001N1 (LEDE Firmware) -

R1 MUST BE wired to R2. (I'm not an expert, just an above average technician starting in this scene, be patience :pensive:. )
As far as I can get, I should be following this guide.

I should "JOIN" R1 AP by using "Scan", and check if Client (WDS) is active. Right?

Also, I would like to note that Ports won't get open (Can Wake-On-Lan from inside lan, but not from outside). Double checked if there it was something to do with Firewall or VLAN (Which I disable both).

Are you using a wired or wireless link between the routers? Definitely start with wired. In the LAN on R2, both gateway and DNS should be R1's IP address on the LAN. The gateway option sets up a route so any requests for IP's outside the LAN range (i.e. sites on the Internet) will be referred to R1.

It should be noted that your clients connected to R2's wifi will get their IP DHCP assigned by R1. To them, they don't even know there is a R2 at They use R1 through a bridge in R2 at the MAC address level.

Any forwarding of ports from the Internet needs to be set up in R1. R2 is "dumb", it is just another thing on the LAN.

I'm using Wired, and I DO NOT WANT to use Wireless communication between R1 and R2. (Obviously because ETH is much more efficient and faster than Wireless).

As I said before: If I set R2 DNS to R1 IP, PC's behind R2 don't get DNS. (So I set it manually, will try it again when all my main problems are solved).

R2 Wireless connection info (SSID and Encryption+Password) it's like R1. But, correct me if I'm wrong, if I set it like that, should it stay connected? (Watching Live Streams won't get disconnected or stopped, for example).

As for the Forwarding ports, I got all ports I need in R1, but, like I said, they are not getting passed by R2, if they come from outside. (Still haven't tested if they got pass from devices from R1, which is not much important for me, but I should still need to checked them to give you a more accurate response).

P.S.: I set the Multicast Forwarding value as instructed in Dumb AP recipe.
Added echo "0" > /sys/devices/virtual/net/br-lan/bridge/multicast_snooping to rc.local. Tried to find that specific file, but none was found on the location.
And yes, I double checked that it was br-lan from LuCi and using ifconfig in ssh command line.

Thanks for the replay.

GOoooOD NEEeeeWS, EVEeeRYyyONE!!!!! (With Profesor Hubert Farnsworth voice / Billy West)

I found my problem, I hope you could specify it for people that think (like me) that didn't realice it at first ( I believe that it wasn't obvious, if you have a part for DHCP IPv6 settings which you could disable from there ).that IPv6 ULA-Prefix got "text" on it (Can't remember which IPv6 prefix, neither it matter for this ^^).

That also fixed my problem with the DNS (Now I'm using R1 IP. So yeah, that did the trick.

Not quite sure if the Multicast Forwarding was meant for my ports not getting through or it was fixed by the IPv6 ULA-Prefix thing or what, but now ports are going through.

So, yeah... my problems got solved by that.

Thanks for replying and helping me get it to work without problems :joy:.
(You already answered my other problem with mixing R1 Wifi with R2 Wifi into one big Wifi signal. So, yeah, thank you very much)

Just tried it again today... ports are not going through without any modification.

Don't know why it was working the other day, but today it's not. :angry::angry:
P.S.: Tried to WakeOnLan from my Android Mobile Device (As I always do):
Connected to R2 to my PC (Wired) = Flawless
Inside R1 Wifi to my PC = Flawless
From outside to my PC = Magic Packet not working.

Yes, I got my ports open on R1. (UDP 7 and 9 - Both just in case)

Could it be because of Switch Mode (VLAN)?? Currently set as default (ETH - All untagged, CPU - Tagged).
Going to test it anyway. but shouldn't be the problem.

Multicast Forwarding was my problem. I started over and stopped before that step.
As said: Everything is working great now, and ports are being forwarded.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.