Linksys WRT1900ACS: Upgrade 19.07.8 to 21.02.1

Dear Community,

since i switched to OpenWrt on my linksys router i added some packagesa and upgrades were performed as described here:

Now change to DSA is coming up and keeping settings is not recommended.

I have some questions in advance before facing bigger problems and ending up in annoying reconfiguration.

  1. Can i still use the above-mentioned instruction or do i run into the same problems as with keeping settings in the "normal" upgrade option?

  2. what is lost by upgrading without keeping settings?
    a) Changing IP from default to
    b) Static leases
    c) USB support
    d) mount points
    e) networkshares
    f) Configuration of Dynamic DNS
    g) Configuration of wireguard: keys, etc

Can you recommend a way to avoid re-configuring? Even better, is there a step by step instruction you could share.

Thanks in advance

WRT1900ACS --> mvebu, which in turn means the swconfig --> DSA migration happens between 19.07.x and 21.02.x for this device.

Follow the advice and reconfigure from scratch (only using your old configuration as loose reference), the networking syntax and semantics will be completely different, keeping settings (or restoring old backups) would result in a guaranteed (soft-)brick.

1 Like


You need to start the config from scratch.
For the packages you need, and default ip adress, you may build your own image with
Image Builder.
This looks scary, but you'll get it done, it's easy to rebuild your own image for each upgrade without to have to reinstall the specific packages. Config can also be preserved, excepted for this transition from 19 to 21.x version.

example of build parameters

make image PROFILE=linksys_wrt1900acs PACKAGES="luci-ssl wifischedule luci-app-wifischedule luci-app-advanced-reboot luci-app-wireguard nano luci-app-sqm block-mount e2fsprogs kmod-usb-core kmod-usb-storage-uas kmod-fs-ext4 kmod-fs-exfat kmod-fs-vfat kmod-usb-storage kmod-usb2 kmod-usb3 hdparm luci-app-hd-idle -ppp --ppp-mod-pppoe" EXTRA_IMAGE_NAME="myownbuild" FILES="files/"

In the image builder folder, you'll have to create the following file to change the default network

uci -q batch << EOI
set network.lan.ipaddr=''
commit network
1 Like

Thanks for your reply. Unfortunately it seems to be some amount of work and at least some risk for transient loss of function... I will order a second (backup) router, to avoid trouble with my family ;-).

Best Stephan

Regarding image builder. When i have Managed to setting Up the first router with 21.02. my intention is to Clone everything and Set Up the second (Back Up) Router exactly the Same way. Is There an Option to "Clone" everything (package config etc) build an Image and transfere it to the second Router. Aim is to have two identical router for Back Up purpose.

21.02.1 stable now for this router? any known issues with wireguard?

Hope i find some time to do the Upgrade this weekend. I will Share my experience asap. Best Stephan

1 Like

Nope, wireguard works flawlessly here 24/7 ...

After the config from scratch, which took a while here (because of banip, wireguard, firewall rules, stubby, static dhcp leases), 21.02.1 runs very stable ...


Did spend/waste some time yesterday evening, now wireguard and ddns run without errors. Did Have some trouble with USB support which ist not solved yet.

1 Like

cheers did the upgrade from 19.07.2 to 21.02.1 configured everything and all is running smoothly :slight_smile:

what kind of usb problems? i have a 16gb usb stick attached with no problems at all ...

I lost the access to Services in LuCI web interface. However using a different howto with less USB packages now everything works

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.