Linksys EA8300 and MR8300 fail to boot after latest git pull

I have been running OpenWRT 22.03 on Linksys EA8300 and MR8300 for more than a year without issues. I build my own images and the latest working image was:

OpenWrt 22.03-SNAPSHOT r20065-7b05a8d05d / LuCI openwrt-22.03 branch git-23.039.29681-007c243

Today I git pulled the latest:

OpenWrt 22.03-SNAPSHOT r20119-50d707e344 / LuCI openwrt-22.03 branch git-23.093.57104-ce20b4a

I built images for all my routers that include Linksys EA8500 and a Netgear R7800. These routers (based on ipq806x) work perfectly as usual after the upgrade. The images for EA8300 and MR8300 build without errors, but after the upgrade both devices (based on ipq40xx) fail to respond and I have to revert to the previous image using the 3 power cycles procedure to get control back.

Is anyone else having this problem?

Yes, the issue is known and already discussed for several weeks. I have posted serial logs of boot showing a partition detection issue, apparently related to a kernel change.

Thank you! Good to know I am not the only one and it is already being looked at.

1 Like

22.03.4 files are beginning to be released. I strongly discourage you to upgrade. I will test as soon as available, but I think I already know the result :frowning:

Just tested, as expected it doesn't boot and fails with the very same error noticed a few weeks ago.
So don't install/upgrade to 22.03.4.

Unless the developers roll-out the changes introduced following kernels 5.4.234, 5.10.172, 5.15.99, 6.1.17, or 6.2.4, the change breaks MTD operation due to the error as noted in the report. There are a few option to restore operation for at least the EA8300 and MR8300 devices:

  • Roll back kernel master from 5.10.176 to 5.10.172 for affected devices, not likely though.
  • Roll in the modifications to master as outlined in the posting, needs to be tested to ensure expected behaviour.
  • Roll back/backport the changes to linux master 'build.c' as in the previous working revision 5.10.172 as a dependency patch for the affected targets, should ensure the same behaviour as observed in the 22.03.3 release.

The last option is the easiest, since the developers apply patches to the master branches on a platform basis until migrated to the mainline linux sources. The PR to incorporate the change suggested in the posting has not materialized nor rolled in for a month now.

The remaining option is to wait for the kernel mainline to incorporate the correction in the future and deploy corrected snapshot releases since version 22.03.3 will no longer ever be operational with the existing faulty code. I do believe that release 22.03.4 is being released in haste knowing that a severity 1 issue persists for several known devices, and potentially others that use the same MTD code. Checking other ipq40xx devices using the same snapshot code or the newest release needs to be investigated.

Lastly, not all targets have been migrated to the 5.15.x kernel, bcm53xx for example, so the rush to release another cut is questionable.

1 Like

bcm53xx, migrated and defaulted.; referring to things as a rush to release is debatable.

Someone has already backportd the fix and tested as per issue post, but no patch provided to OpenWrt...

Just observed that bcm53xx has migrated to 5.15.106 in snapshot, testing to begin. The interim cut for 22.03.4 is still based on 5.10.176, so it may migrate to the later kernel on subsequent builds. The concern on the rush stemmed from the matters that are still pending and platforms that have not migrated to 5.15.x but had a PR indicating that it would happen for the next cut, may that be for 22.03.4 or perhaps the intentions were for 23.x.y.

Verified that the bcm53xx is operating as previously with kernel 5.15.106. Will the expected stable release for 23.03.4 be also integrating the snapshot kernel with another build? On a related note, the current snapshot build for the MR8300 is still not completing its boot as previously reported. Looking to see if the patch rolls out the change introduced in 5.10.173+ or the suggested patch from is being deployed.

it works with

Did you compile your self, or did you get the latest snapshot ?

  • I can compile, but did I get the patch automatically after refreshing source ?
  • latest snapshot seem to date from yesterday, so unlikely got the patch

OpenWrt 22.03-SNAPSHOT r20127-074db57936 / LuCI openwrt-22.03 branch git-23.093.57104-ce20b4a

1 Like

These images have timestamp from yesterday, so unlike have the patch.
I'm monitoring since this morning :wink:

I tested, it works it is added

Just tested the 22.03 snapshot you mentioned. It works! But I had some shivering for a minute, the time to understand that there was no Luci :wink:
I was talking about your master snapshot link: there are still images from yesterday.
I'm compiling a master for MR8300.

kernel: backport fix for recently introduced UBI bug

How does yesterdays build incorporate todays commit unless it was done out-of-band, I am stumped. Does that mean the stable releases also function even though they are several days old?

@roblad tested an unofficial 22.03 snapshot version which already includes the patch.
Official 22.03.4 releases don't work.
That being said, official 22.03 and master snapshots will likely to work as soon as they would be released. I'm still expecting those of today. On the other hand, I have compiled a master for MR8300 using official git repo, and it works!

I confirm @badulesia mentioned :slight_smile: