OpenWrt SNAPSHOT r22302 on MR8300

I'm trying to flash OpenWrt SNAPSHOT r22302 (2023-03-18) on a Linksys MR8300 but it simply wont boot and I have to switch back to a previous working snapshot. Anybody else experimenting the same problem?

1 Like

Try an older release, then upgrade yourself back to 22.03.

As I said, I switched back to a previous working snapshot. I only want to know if others are able to boot this version on a MR8300.

Yeah, sorry.

Misunderstood, thought you were installing it, not upgrading.

I wonder if the new kernel breaks the kernel size of 5M? How can I check this?

Serial would probably be the only way.

Presumably exceeding size limit would fail to build an image. Could try 5.15 if testing kernel is an option.

1 Like

How old is your previous snapshot ?

I have tested/debuged kernel 5.15 snapshots (5MB) for the MR8300 back in december. Every snapshots since jan 1st NEED a bootloader tweak to load a 5MB kernel partition.
Also you can't upgrade since the device will need a complete new setup (DSA is used). You must use a factory image for the first flash. After you can simply upgrade.
All infos are on the wiki.

1 Like

My build from 2023-02-16 runs fine (SNAPSHOT r22068-f584fb2f7e, kernel 5.15.93). The boot loader tweak for the kernel partition is applied. I'm only having problems with the builds of yesterday and today (2023-03-18 and 2023-03-19).

1 Like

Time to bisect?

That's beyond my abilities I guess :worried:

google git bisect, it's just some builds. Although as a quick start you might try a build at the commit just prior to the 5.15.100 push.

I'm not compiling from source: I'm using the Image Builder...

OK, didn't know you could force the testing kernel with IB.

Ok. So the issue is clearly related to recent snapshots.
I don't have the device presently to try myself, it's in a relative's home. I may be able to try in several days, hoping that in the meantime the issue will be solved.

Did you noticed any file size change between the builds? Something important, not a few kB.
Anyone know about an important change recently?
Have you tried to reset the device? Or flash a factory (so without keeping data)?

Sizes: 18219264 bytes vs 18481408 bytes so not a big difference.

I have openwrt on both partition and flash a factory image to the other partition. So far it was working fine. I haven't found a way to keep the data other than push a firmware with a backup of my config.

I also tried a vanilla snapshot image from the build service with no success.

I've checked recent change but I don't see anything significant:;a=shortlog


260 kB difference, something has changed.
BTW the builds I use are only 10 MB. Why are yours so big? A lot of extra packages? Try a basic list.

I'm restoring the data after a flash. Same result.

That was important to try.

I have just build a snapshot. I has the exact same size than my previous kept (from 2/22).
Here is the packages list. Try to create such a build.

ath10k-board-qca4019 ath10k-firmware-qca4019 ath10k-firmware-qca9888 base-files busybox ca-bundle dnsmasq dropbear firewall4 fstools kmod-ath10k kmod-gpio-button-hotplug kmod-leds-gpio kmod-nft-offload kmod-usb-dwc3 kmod-usb-dwc3-qcom kmod-usb-ledtrig-usbport kmod-usb3 libc libgcc libustream-mbedtls logd mtd netifd nftables odhcp6c odhcpd-ipv6only opkg procd procd-seccomp procd-ujail uboot-envtools uci uclient-fetch urandom-seed urngd wpad-basic-mbedtls luci luci-app-advanced-reboot -luci-proto-ppp

I just downloaded today's snapshot (03-21) with only luci luci-app-advanced-reboot added and I still have the problem (no boot after flash). Just to be sure, I flashed my older working version to the other partition and it boots fine (now I have Openwrt snapshot 02-15 working on both partitions).

Edit. I also was able to load a snapshot image built on 03-07.

1 Like

Same here. Previous snapshots worked fine. Current snapshot fails to load. I used the standard snapshot, not a custom build. I do not save the config on sysupgrade.
I don’t have a serial port connection, is git bisect the only other option?

Issue 12232 opened