Linksys E900 does not enter failsafe mode

Hi all! I installed OpenWrt on my device like two days ago and was having a good time. Sadly I tried running a script and it made the router run out of memory every time (8/32 device), so I searched online what could be done to improve OpenWrt on low-mem devices.

I stumbled upon this article about saving some space by removing some packages, therefore improving RAM a bit. Unfortunately while removing some of those I forced the removal of dependencies instead of just force-remove the package itself.

I was then not able to reach LuCI and I thought rebooting the router would help, but now the router will not boot as the status light will blink just twice and then will stay lit indefinitely. I am able to get ttl=100 ping responses from the router when it's turning on but TFTP flash won't work even though it says firmware was upgraded successfully (it doesn't reboot itself).

Digging for some more information I learned about failsafe mode and I do see my router sends a message saying to press a button to enter it (using Wireshark and tcpdump), but when I do it doesn't do anything.

I have tried both the reset button and the WPS button to no avail, also pressing a button several times won't do much help. It seems the recovery info on this device is unknown and I'm wondering if now my router is just another paperweight :frowning:

Thanks for reading and I hope someone can give any advice or help!

Even if you do successfully recover, you're likely to have issues.

Also note that the last supported version of OpenWRT for this device is 19.07.

Yeah I knew about these warnings but still wanted to give it a try with a cheap router.

Usually I was able to get into management mode (a firmware upgrade mode from Linksys) with any sort of failure while using DD-WRT or Tomato, but with OpenWrt that doesn't seem to be the case :confused:

Thanks for replying and for the information.

You could try a serial recovery.

1 Like

Yup, that worked. OpenWrt is really tricky on this device lol

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Please first check if Linux detects your device model: grep machine /proc/cpuinfo.

Then please use mini tutorial

to find out what GPIO is reset button connected to and kindly report it back here.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.