Bricked Linksys E900

Hi! Yesterday I installed OpenWRT on my Linksys E900 router. The installation worked fine but I wanted to try out other alternative firmware's. So I decided to reflash the stock firmware of Linksys E900 version 1.
After flashing nothing worked anymore.
I tried flashing the stock firmware with TFTP and the transfer was successful. But still I can't connect to the WebGui.
In this thread Linksys E900 does not enter failsafe mode (which describes pretty much exactly my problem) I read that serial recovery could solve my problem, but I have no idea how to do that.
I have a usb to serial adapter and already know the pinout, but what do I have to do then?
Thanks in advance :slight_smile:

The E900 is a Broadcom device and TBH, OpenWrt support for Broadcom devices is very poor due to lack of drivers etc.

Your best bet to unbricking the 2011 era E900 is to look on the dd-wrt forum. I could only find one thread for the E900.

I've bricked specific similar age Belkins when flashing Tomato firmware to them. The NVRAM becomes corrupted, and the solution was to use a serial TTL adapter to issue a 'nvram erase' command at the CFE bootloader prompt. It may be the same issue for your E900 ?

You will need a serial-TTL USB adapter and to solder wires from the adapter to the E900's circuit board.

Only the RX, TX and Gnd wires should be used. For Windows, I use PuTTY.exe. Ensure Windows has drivers for your serial TTL USB adapter.

Tomato (Shibby, FreshTomato etc) or dd-wrt are better suited to the E900 btw.

Hi! :slight_smile:

When you say "nothing worked anymore", do you mean the router does not boot properly? Like the light on it stays lit forever?

Or do you see the LAN port establish a link with your PC, meaning it starts blinking and stuff?

Honestly it's really hard to brick this router. If you have to go through the serial recovery, you can serve yourself with the website bill888 provided, where it tells you the correct pinout on the board.

I am not experienced in soldering at all but I still managed to attach the required pins, just be sure it makes proper contact with the PCB and you're good to go. Watch soldering tutorials on YouTube beforehand.

Also, I recommend you use Tomato by Shibby on this router, it's by far the most optimized firmware I used on it. It's honestly great!

As of 7/7/2021, Shibby is now recommending FreshTomato going forward...

Supported devices for FreshTomato -


Thanks for the answers.
I soldered a pin header on the board and the CFE console now appears in Putty.
When I type "nvram erase" the output is:

CFE> nvram erase
CMD: [nvram erase]
*** command status = 0 ***

So was the erase successful?

If you type 'help', a list of commands is displayed.



Have you tried restarting the E900?

eg. try typing the command ifconfig

and see if you get the same *** command status = 0 *** response too.

I restarted the router and entered CFE again. When typing ifconfig I get the following output:

Device eth0:  hwaddr 58-EF-68-56-D4-3F, ipaddr, mask
        gateway not set, nameserver not set
*** command status = 0

I'm not familiar with the E900, I can only suggest you follow the instructions in the dd-wrt guide to see if it resolves the problem after clearing the nvram:

Thank you so much. Flashing the firmware worked after clearing the nvmram.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.