Linksys E7350 OpenWrt install

I just replaced my old linksys ea6350v3 router with this one. I was told not to download any newer fimware. So i left it alone. Its on 1.1.00 build 15 june 11, 2021. I have the openwrt file. How can i flash this if i can't install using the linksys UI?

I'm sure it has an actual model name/ number as well, not just a (vendor exaggerated) speed rating, once you know that, you can check the wiki for installation instructions on its device page or check the git history for the commit adding support for it, there it should have installation instructions.

Its the e7350.;a=commitdiff;h=f4eef5f2a18400bc7f548d629e1d5825a2b26e5a

Once it hit 39% it said it was installed successfully. But it reboots back into linksys ui, so now what i do?

You installed from partition 1 (Linksys) to partition 2 (Openwrt). But only partition 1 can boot OpenWrt. As partition 2 has been declared invalid, bootloader switched back to partition 1, hence Linksys OEM.

You must first flash Linksys OEM over itself, so it will install and boot from partition 2. Than flash OpenWrt, it will install and boot from partition 1.

The commit shown by @slh states

* This device has a dual-boot partition scheme, but this firmware works
  only on boot partition 1.
1 Like

So you saying i have to flash another linksys firmware through the ui? Okay, whats a viable download for it? And the same procedure right? Flash through the linksys ui?

That said, don't follow download links given by strange blokes on the internet (aka, me), confirm it yourself - it's not hard to find from Linksys' main company page.

It shows up 2 versions for 2022. Unsigned and signed. I saw through another openwrt forum that somebody flashed the signed version but couldnt downgrade back. So im guessing flash the unsigned version?

If that's the case, go with the oldest you can find (ideally the same one you're currently running). Sadly, in this case there aren't many options, but the unsigned one would be preferred (not only because it's older, but also because of the fact of it being unsigned - signed firmwares rarely imply anything good, if you care about device access and/or running 3rd party firmwares).

I installed the latest unsigned firmware. So now when i tried to flash the openwrt factory.bin, itll stop at 36% with the error failed install message. Then it reboots.

@neheb might have an idea, personally I have no experience with this device (or other semi-recent ones from that vendor/ SOC).

I have no idea if i messed up by installing the new unsigned firmware.


Oh man had me scared for a second, let's see what your buddy say.

I'm jumping on the bandwagon. This device went on sale here, and I needed a good modern router that looks nice, isn't overly expensive and has more than 16MB flash storage. This device covers it all basically and is even available for purchase here, so I'll also try flashing OpenWRT and will see how it goes. I hope that the instructions by the snapshot dev are made a little more clear in the future, because I assume I need to first flash unsigned firmware, from which I then need to flash OpenWRT after.

How did you flash openwrt after you flash the latest unsigned firmware? When i kept trying to do it, again it goes to 36% then itll say an failed error and then reboots.

I haven't started yet since my Router arrives tomorrow, but I've done plenty of research. I'd recommend you to read the entire thread found here (read everything first): Linksys E7350 Serial Port Problem or downgrade method - #46 by stevewaffler

Ive read everything but it doesnt definitely show me how to flash through the linksys ui. I downloaded the factory.bin, the kernal.bin and the sysupgrade.bin. But they didnt really explain how besides having to flash through tftp

This device is known in Britain as the Belkin RT1800, out of two devices I got Openwrt working on, one of them had to be a serial connection booting the initramfs, the other worked with the latest RT1800 firmware.

Belkin RT1800 firmware is here

It's 16 revisions behind the E7350 version