Linksys E2500 V3 fails with new 22.03.0 OpenWrt firmware

I had an unused (never used, never installed) Linksys E2500 V3 in my closet, and I had a new potential use for it, if I could get a suitable open source firmware loaded on it. I decided to give OpenWrt a try ... I've been using Shibby Tomato and now Fresh Tomato until now, on other WiFi routers. This new purpose has no need for WiFi ... I'll end up buying a little 4 port smart switch in the end, if this experiment with OpenWrt and my Linksys E2500 V3 fails.

Well ... it's failing.

After loading the 22.03.0 OpenWrt firmware release that just came out within the last day, my Linksys E2500 no longer works. The blinking LAN and WAN port lights blink when packets come their way, but I see no sign of life from nmap or arp-scan scans of any IP address the Linksys might be at, including an arp-scan of 192.168.0.0/16. That arp-scan had shown the Linksys at 192.168.1.1 just fine, as expected, when the Linksys was still running whatever firmware the factory put in it, but no 192.168.0.0/16 address responds now.

Before trying this new 22.03.0 firmware release, I noticed two confusing, but concerning items on this forum (so I was not entirely surprised that I "soft" bricked my Linksys). These two items were:

===

  1. The following very concerning warning:

WARNING! Wifi and ethernet LAN ports not working at this time with OpenWrt! Forum Link

which appears now (as I write this, 7 Sep 2022) on the OpenWrt web page:

===

  1. Where the above warning links to, which is mostly an old thread from 2019 entitled " Semi-Bricked Linksys E2500 V3", but which thread had a few posts added some 16 days ago, asking to have the above concerning warning applied to the "device page", which request was honored, with this mostly old thread then closed 10 days later, 6 days ago now.

===

There was no way that I could see for sure whether that warning still applied to yesterday's new 22.03.0 firmware version or not ... and the strange 3 year gap in the history of the above "Semi-Bricked" thread suggested to me that perhaps the warning no longer applied.

Apparently, that was an incorrect bit of hopium on my part. The warning still seems to apply.

===

I would suggest three things:

(1) Don't even list Linksys E2500 V3 in OpenWrt.org's hardware list at:
https://openwrt.org/toh/views/toh_fwdownload?dataflt[Model*~]=e2500

If all of the LAN and WiFi ports are dead for some version of OpenWrt on some model, then that version of OpenWRT is a total non-starter on that model.

(2) Update the above now closed "Semi-Bricked" forum post to indicate that the breakage still applies, as of the 6 Sep 2022 release 22.03.0.

(3) Date the "at this time" Warning on the above linked "https://openwrt.org/toh/linksys/e2500_v3" page ... We are NOT mind readers. We cannot tell when someone wrote something unless they say so. Also add to that Warning, that as of the 6 Sep 2022 release 22.03.0 release, OpenWrt should NOT be used on E2500 V3, period.

===

That, or I screwed something up on my end ... definitely a possibility.

If I were going to try to recover my now "soft" bricked Linksys E2500, I'd probably try pushing the Linksys factory firmware back on to it, using tftp. I probably won't bother however, and instead get a little 4 port smart switch, such as the Netgear GS305E, which happens to have builtin just what I need for my current purpose (and not much else).

This above mentioned arp-scan was from my Linux desktop box into the LAN4 port of the Linksys E2500.

Just now I tried another arp-scan of the E2500 over the IP addresses 192.168.0.0/16, while plugged into the E2500's WAN port. That too showed no IP reply. When I connected that E2500 WAN port to an unused RJ45 port on my Linux desktop, my Linux kernel immediately noticed the physical connection and logged that it had brought up the interface and was managing it. But so far neither my kernel, nor that arp-scan, has reported seeing any IP or ARP packets from the E2500 WAN port.

P.S. -- Having already run the above test to the LAN4, then to WAN port on the E2500, I repeated it going to LAN1 on the E2500. Same results. The physical link seems to work fine - port lights blink and my kernel sees the "cable come alive" ... but no ARP or IP packets ever seem to leave the E2500, even after powering up the E2500 while holding down the Reset button on its bottom for perhaps 15 or 20 seconds first.

See here: Need help reading the bootlog for Linksys E2500v3 to solve - #6 by account4538

It's just a VLAN configuration

The VLAN configuration link you provide seems to involve administering and configuring the Linksys E2500v3.

I don't see how I could possibly ever do that, since my E2500v3 never sent out any discernible useful data on its network connections.

The low level physical and link layers apparently worked, but nothing from the network, transport, session or up layers showed up.

Anyway, I already threw it out.

I had to do it over serial connection which brought the LAN back up first - then SSH, LuCI, routing, etc work as expected.

WAN port was fine.

I had to do it over serial connection

aha - that could be the key - I did not try serial.