I've bricked my Archer C7 V5

Hi,
I know there's already at least 2 threads about this router being bricked and fixes, but one of them leads me to an unclear solution (someone solved it but didn't explain it well), and the other thread leads down to a bunch of gibberish that I can't understand (Oh, just use Mx4320942 and install using ubuntu v.3.0.1 and voila, that sort of thing.)
Can someone please explain to me, a mildly autistic man that has no network troubleshooting experience past unplugging and replugging my router, how to de-brick my router? I've only gotten as far as downloading Tftpd64, and getting all the settings set up. I have no idea how to start a TFTP server.
Please help.
Thanks,
-Jarod

Works for several TP-Link devices...

Recover using the TFTP server method. Written for Windows users...but the concepts are the same for other OS.

Download the stock firmware...you may need to try more than one version.

The OpenWRT "factory" firmware can also be used if you don't want to go back to stock.

Download TFTP64.

Rename the downloaded firmware file to ArcherC7v5_tp_recovery.bin, and place it in the same folder as TFTPD64.

Open your network settings in Windows, and select the wired adapter (don't try this on a wireless connection).

Note: It's a good idea to use an unmanaged switch between the router and the computer. It avoids the link-down event, and link training.

Right-click and select Properties.

Select Internet Protocol Version 4 (TCP/IPv4) and click on the Properties button.

In the General tab, select the radio button for Use the Following IP Address.

Enter 192.168.0.66 for the IP address.

Should default to 255.255.255.0 for the Subnet Mask.

Turn the router off.

Make sure nothing else is connected to the router, it should be just the router and your computer.

Open TFTPD64. You may be asked to allow it through the firewall. Select Public.

Note: You may need to temporarily disable the firewall.

Go to Settings > Global, and uncheck everything except TFTP Server.

Go to Settings > TFTP. Select None for TFTP security. Uncheck Option negotiation, and enter 192.168.0.66 in the Bind to this IP address drop down.

Go back to the main window, and make sure the Current Directory dropdown is showing the path to the TFTPD64 folder, which should also contain your recovery firmware file ArcherC7v5_tp_recovery.bin

The IP address 192.168.0.66 should be displayed in the Server Interface dropdown. If not, select it.

Go to the router and press the power button and the reset button at the same time.

Release the power button...but continue to hold the reset button for about 4 or 5 seconds, then release.

You should see a progress bar going across the TFTPD64 screen (although it should only take a very short time).

View the log. It should show 100% transferred.

Go back to your wired network adapter, and change the radio button back to Obtain an IP Address Automatically.

Try to access the router GUI. The stock firmware IP address is 192.168.0.1 and admin/admin for the User Id and Password.

If you can see that you have Internet access in the Network icon, but can't access the GUI, open a Command prompt and run ipconfig /release and then ipconfig /renew.

Try to access the GUI again.

1 Like

Thank you very much for your reply.
I did these steps above, with the OpenWRT factory firmware file, and at first I was able to at least access the OpenWRT GUI. However, I still had no network connection, both the connection light and Wi-Fi lights were both off.
I tried doing the same steps with the factory firmware, and I wasn't able to access GUI. Then I tried to do it again with the OpenWRT factory firmware twice, and now not able to access GUI any more.
Do you think I possibly bricked my router beyond repair?

WiFi is turned off by default.

You also need to reconfigure your device from scratch, since all configurations were wiped.

However, if you happened to save the configs (good practice whenever you change something), they can be restored through LuCI.

Confirm that you set your network adapter back to its original settings.

You may just need to run ipconfig /release and then ipconfig /renew in a Command prompt.

I'll start from the beginning what I did.
I got the new router in the mail, hooked it up and named the network and everything. Once I finished doing that I followed a YouTube video on how to install OpenWRT (disconnect it from the modem, disconnect all wifi-connected devices, disable Wifi on computer). I installed the factory Openwrt, and it worked fine. Then I flashed the OpenWRT sysupdate firmware version, and that worked fine too. When I went to do a speed test, I was getting about 300mbps, where my modem was getting 700mbps. So I thought maybe the router was glitched or something, so I turned the router off and back on.
That's when the WiFi lights went out and I couldn't connect over WiFi, only Ethernet.
So I went online searching, and found a post from Nov 2019 saying they fixed it by installing the latest firmware, and a link to that firmware update from 2019. So I stupidly went ahead and tried to flash that firmware from 2019. It kept cycling around and around for like 10 minutes and was taking way too long. So then I stupidly decided to just turn off the router, even though the message says not to on the screen.
Now I can't even connect to the internet over Ethernet.
I was able to get the GUI open after doing TFTP the first time (using openWrt firmware) but no connection to the internet. However, I'm not 100% sure if I had my modem even hooked up to the router to test the connection after I was able to debrick it using TFTP. So that might have been another stupid of me.

I'm going to keep trying to use TFTP to flash OpenWRT factory firmware over and over. That way if I end up getting the GUI open I can hook up the modem to the router to eliminate that as a possible issue.

Thank you for taking time out of your day to help me out.

I wouldn't do that.

Sounds like you have an ISP modem connected in front of the OpenWrt router...

As mentioned, you need to configure the router from scratch, since any packages you installed, or configurations you did, are gone.

Ok I was able to finally get my router connected to my computer via Ethernet. Seems I did forget to connect my ethernet cable from my modem to my router after debricking it. Thanks so much for your help. For now I'm using my Xfinity rental modem+router -in-one, with my C7 router hooked up to that. My C7 not giving off Wifi signal is separate issue now.

Thanks so much for your time. You've been a great help sir. Much appreciated!!!

In LuCI, navigate to Network > Wireless.

Click Edit to configure the wireless settings.

Then, click the Enable button.

Aand this fixed it!! Thank you sir. Wifi works now.
Many thanks.
-Jarod

EDIT: I was able to hook up my Archer C7 to my regular modem (Netgear CM700), and currently using SQM QoS. I went from +80ms bufferbloat (down) on my Xfinity ISP's router, and +130ms down on a CM500 + Archer 3200 combo, to +5ms bufferbloat down, +0 up (on my Archer C7). This fixed lag issues completely (gaming, zoom calls).
Thanks to Jim (OldNavyGuy) for helping me.

-Jarod

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.