Archer C7 v5 - TFTP upload not working

Hi All,

I have a TP-Link Archer C7 that had DDWRT installed. I used the TFTP recovery process to get the latest OEM firmware installed. Now I'm wanting to install OpenWrt, but I have not had any luck.

  1. I have tried the GUI, but it complains about wrong image format.
    I changed the file named to firmware.bin
  2. Have tried the TFTP recovery and still have the OEM firmware.
    Disabled my Windows FW, all 3 parts.
    I changed the file name to ArcherC7v5_tp_recovery.bin
    Here is the log file from the TFTP server:
    Connection received from on port 2772 [05/05 17:52:28.451]
    Read request for file <ArcherC7v5_tp_recovery.bin>. Mode octet [05/05 17:52:28.451]
    OACK: <timeout=5,blksize=1468,> [05/05 17:52:28.451]
    Using local port 59764 [05/05 17:52:28.451]
    <ArcherC7v5_tp_recovery.bin>: sent 3857 blks, 5660903 bytes in 1 s. 0 blk resent [05/05 17:52:29.644]

I have followed the information from this post, which still resulted in have no OpenWrt installed, (I've bricked my Archer C7 V5).

Please let me know how to fix this problem.


It should be

Hi OldNavyGuy,

I thought it was a typo, so I tried again making very sure of the x.x.x.66. I tried again and I received the same log message from the router, with the same NO GO results.

Any more suggestions?

Go Navy!!

Just to're using the OpenWrt squashfs-factory.bin file to TFTP over.

I'll redownload the.bin file and rename it according. I'll do this tomorrow. I've been at this for over 8 hours. It is beer 30.


I went through the steps again, this time very slowly to make sure I didn’t have any typos and that I was using the right files. It worked this time. I guess I was too tired when doing the typing of the IPn adrtess or renaming the default file. In any case, it is not working. Thanks for asking if I was using the correct file in the flashing process. This is the only thing I can think of I was doing wrong.

Go Navy beat Army!!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.