It does not allow me to install the original firmware on TL-WA850RE V2

Hi, I have installed an openwrt firmware on my TL-WA850RE V2, but I want to go back to the manufacturer's original firmware and it just tells me this: "The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform."

Captura%20de%20pantalla%20(25)

there is some way to reinstall the original firmware, help please I am very new in this I just did it out of curiosity.

I followed this topic: Techdata: TP-Link TL-WA850RE v2

According to TL-WA850RE you may need to strip the firmware first. Some OEM firmwares include special Headers which are not supported in Openwrt and thats why you cant just reflash them and expect it to work. You need to edit and then use that stripped firmware to reflash to stock.

[Edit] Which firmware are you using to go to stock? I suggest you use this one for your WA850RE-V2 but if it still doesn't work then you need a stripped one. Also I updated the above WiKi page, you can find the new instructions there.

I tried to install the original firmware, but something went wrong now all the lights turn on and off infinitely.

what happened?

I think that's a bricked router situation. You can fix it with serial connection. You'll have to open the router case and then identify TX,RX,GND and use a USB To Serial TTL adapter to upload original stock firmware, download the stock firmware from OEM's website. Visit wiki for your router page to read the details.

Apparently you can unbrick using TFTP: https://www.trishtech.com/2015/06/unbrick-tplink-wr740n-wifi-router/

I have the same problem - the only firmware I can flash is a sysupgrade format of the one I already have installed. Otherwise I get the same error.

The reason I want to revert to stock is that the OpenWRT firmware installed doesn't keep settings through a reboot (uses a ramdisk for it's overlay) and I haven't been able to work out why.

Edit: I tried the TFTP recovery, and I can't get the device to go into this mode. I checked with Wireshark to see if there were TFTP packets, but saw none.

1 Like

Thanks @tmomas, that explains it not being able to save settings, but it doesn't explain why it won't install a stock firmware.

Also, there is no 17.x binary anywhere to be found for this hardware.

Using imagebuilder, I ripped out everything to do with IPv6, PPP and USB, which enabled room for luci. I built an image that uses 220k, so it lets me save config changes.

So at least I can use it for the time being. But I'd like to be able to revert to stock at some point. I have a few ideas:

  1. debug the code to find out why it's rejecting the stripped stock firmware, and I'm guessing I'll need to delve into sysupgrade
  2. work out how to extract the firmware parts myself, and flash them using mtd

I don't feel confident enough to do #2, especially given that I can't get a u-boot TFTP recovery procedure to work, so:

  1. Install a third-party u-boot, such as Pepe2k's u-boot_mod which has its own recovery; but replacing u-boot will be risky

It is possible that Openwrt thinks that the stripped stock firmware is not for the same hardware/router so it doesnt flash it from the LuCI. You can always try the sysupgrade with force option. It will just flash the firmware anyway.

@ahmar16 yes you may be right, but I'm not going to risk forcing a flash. There's no recovery TFTP (or similar) that I know of, and the case is apparently plastic-welded shut, making serial console access impossible.

Openwrt kinda changed device names starting from 18.06.0 and even the users upgrading from 17.01 version or going back to 17.01 needed to use the force option for sysupgrade including myself. Because LuCI would say that the image is not a suitable one. I think you have the same issue. You might be flashing the correct stock firmware but because the names have changed, it's possible LuCI still wants to accept only the firmware with that specific name. That's why, believe it or not, your only option to flash stock is through force option. Otherwise you are stuck with Openwrt for now.

[Edit] Secondly, "plastic-welded shut" doesn't mean you cant open it. It will be hard to do so but these days OEMs use this packaging because not wanting to use the screws I guess. It will have some tightly locked latches that can get broken if tried to open too forcefully (had a device like this myself). But you will need serial access some day so I'd recommend getting access now.

Interesting. Why would they do this, I wonder?

Yep, fair enough. I'm still concerned that there could be some other reason that sysupgrade is failing (like a bogus image that has bad headers). It would be nice of sysupgrade would say, "Everything looks fine, but I was expecting name XXX and found name YYY, use 'force' option if you know what you're doing."

Yes that would be interesting if it gets implemented. Maybe head over to Developers section and ask them.

I have the same problem, can anyone provide a solution ? Maybe an image without ipv6 in order to at least save the configuration!
Thanks!

Anyone, help!

You will need to compile an image yourself, head over to documentation and search for saving space and only include essential packages in the firmwarw build process. You may be able to do so through an online image builder system which is also available, just search google. If you know what packages you need you can edit the list in online builder and download the appropriate firmware. I would suggest to use v17. 01 for your use case.

hello, i were using tp-link wifi reapeator model TL-WA850RE, its working fine but for new option to hide ssid i search new firm and updated. after installing the new firm now the device not working even it cant configurature by any means nor it throws wifi signal. can u guys suggest what should I do now

Your issue seems other than what is the topic stands for. Please create a new topic so we can better help you.

1 Like

Can you send me your built image and tell me how to install it?
The firmware doesn't save my changes after reboot and I have no idea how to get back to original firmware.

Thanks

https://openwrt.org/toh/tp-link/tl-wa850re
check it out
and you can find a stripped firmware here


just get it and prepare your router and TFTP to downgrade to The stock firmware
It's simple pal