Report Devices Here With 18.06.0 Provided Image too big to save overlay

no any version of 18.06 doesn't even boot on netgear wnr612v2.
I had no success to connect via serial port like on photos here
So I cannot attach any log file.
It's just booting
Currently default build of 17.01.5 for wnr612v2 is booting but overlay not saving.
Used package builder for making minimal 17.01.5 image with LuCI:

make image PROFILE=REALWNR612V2 PACKAGES="luci -ppp -ppp-mod-pppoe -kmod-usb-core -kmod-usb-ohci -kmod-usb2 -kmod-usb-ledtrig-usbport"

works great. 18.06 could be better to have.
looks like tiny builds for wnr612v2 are all faulty, tried all versions.

One more thing, factory image is flashed only to 14.04 then sysupgrade from LuCI. Any newer version fails to boot after being flashed from netgear's firmware webinterface.

Seems like TL-WA855RE v1 is also affected by this.

If anyone can help me how to solve this I would appreciate it. My knowledge of openwrt is limited, I am still learning.

As written above:

1 Like

For those not very familiar with the various OpenWRT image-building tools, perhaps the simplest is the "Image Builder" that assembles pre-compiled packages into an image for your device.

It typically requires a Linux-based OS, either on a stand-alone machine or in a Virtual Machine (VM), such as the "free" VirtualBox application.

To reduce image size you will have to remove packages from the "stock" distribution. LuCI is a big one, but removing unneeded kernel modules (such as PPP, PPPoE, ...) may provide enough space. There is no "magic answer" to "How much is enough?"

The other option is the full build chain, which is not much more complicated.

Seems like TL-WA850RE v2 is also affected by this.

I too have had the issue described by @ginn13 with the N150R (tiny) for v18.06.1 (from 17.01.4). (same hardware as netgear wnr612v2).

@ginn13 - Did you manage to use TFTP to recover this?

I haven't yet been able to recover from the reboot cycle it is now experiencing to try 17.01.5 or pack a smaller image.

Next one with this issue: WNR2000v4

Sorry for late answer. I used tftp tool from this article which only recover to any firmware version provided by netgear. Note, that it can fail to upload image by tftp. So I used Wireshark to monitor if there is any traffic and made 2-3 attempts until succeed to flash original firmware. Then only 14.04 is installed from web interface. And then I upgraded to image made with package builder with parameters from my post. If you want, I can send you my image, or build for you, I have a ready linux system to build a new one

You don't need to tell me, I already know.
Maybe you didn't get the intention of this topic: Collect information about which devices are affected by too little space to save configs.

Sorry, I thought I was answering to guy you cited. Anyway image builder with 18.06 doesn't help in my case. It just falls to cyclic rebooting with same singnals on led. router answers the pings on lan port
about 5 sec then reboots. If somebody could help me connect serial port on the device, I could provide log. I used pl-2303 chip.

Thanks for the info - I didn't want to reply in the forum but it turns out you can't send personal messages on this forum.

I haven't tried your method just yet (will do in a minute!), but wanted to say thank you!

Will let you know how it goes...

Also reporting DLink DIR-300 B5 with 18.06.1 r7258-5eb055306, flashed through emergency

At least the setting do not survive reboot and there's no overlay mounted

The LUCI System->Software says: Free space: 0% ( 0.00 B )

root@OpenWrt:~# cat /etc/fstab
# <file system> <mount point> <type> <options> <dump> <pass>
root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
tmpfs                    13.8M    568.0K     13.2M   4% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev
root@OpenWrt:~# ls -lisa /overlay
    419      0 drwxr-xr-x    2 root     root             0 Aug 16 07:51 .
      1      0 drwxr-xr-x   16 root     root             0 Jan  1  1970 ..
root@OpenWrt:~# logread|grep overlay

Packages list:

root@OpenWrt:~# echo $(opkg list_installed | awk '{ print $1 }')
base-files busybox dnsmasq dropbear firewall fstools fwtool hostapd-common ip6tables iptables iw iwinfo jshn jsonfilter kernel kmod-cfg80211 kmod-eeprom-93cx6 kmod-gpio-button-hotplug kmod-ip6tables kmod-ipt-conntrack kmod-ipt-core kmod-ipt-nat kmod-ipt-offload kmod-leds-gpio kmod-lib-crc-ccitt kmod-lib-crc-itu-t kmod-mac80211 kmod-nf-conntrack kmod-nf-conntrack6 kmod-nf-flow kmod-nf-ipt kmod-nf-ipt6 kmod-nf-nat kmod-nf-reject kmod-nf-reject6 kmod-ppp kmod-pppoe kmod-pppox kmod-rt2800-lib kmod-rt2800-mmio kmod-rt2800-soc kmod-rt2x00-lib kmod-rt2x00-mmio kmod-slhc libblobmsg-json libc libgcc libip4tc libip6tc libiwinfo libiwinfo-lua libjson-c libjson-script liblua liblucihttp liblucihttp-lua libnl-tiny libpthread libubox libubus libubus-lua libuci libuclient libxtables logd lua luci luci-app-firewall luci-base luci-lib-ip luci-lib-jsonc luci-lib-nixio luci-mod-admin-full luci-proto-ipv6 luci-proto-ppp luci-theme-bootstrap mtd netifd odhcp6c odhcpd-ipv6only openwrt-keyring opkg ppp ppp-mod-pppoe procd rpcd rpcd-mod-rrdns swconfig ubox ubus ubusd uci uclient-fetch uhttpd usign wireless-regdb wpad-mini

Not sure what can I omit from here using the image builder )

The history: (just for whining)

A friend flashed it for me (can't remember the version, but he did it like 1-3 months ago, seems like it was 17), then I've found out that it doesn't save the config and boots into default config including passwordless root login on all interfaces.

So, I've flashed 15.05.1, since it was on the OpenWRT wiki for the device a month ago (I was lost in architectures and download links and didn't want to risk bricking the router). The config survived reboot, but I've just installed a fresh xubuntu 18.04.1 onto my laptop and it was working ok for half an hour and then started losing connection once per minute both through wifi and ethernet, also lost the connection on eth so it couldn't even get an ip. I thought it could be because of an old firmware. (Seems like it was not the firmware, because it still doesn't connect and the windows box works ok, so did the ipad and iphone/androids)

I've watched the logs on the router and detected that it was sending dhcp handshakes to the laptop. Nevertheless I decided to upgrade the firmware and flashed the new 18.06.1 (the new link is in the wiki today).

The list was getting rather long, so I have made a separate wiki page for all the tips about how to shrink the firmware and save RAM:

1 Like

It happens also on Buffalo WZR-HP-G300NH (32M flash, 64M RAM) with 18.06.1 downloaded image

You might have similar symptoms, but at 32 MB flash it's impossible that the release images would be too large - so that would need debugging (and a different thread).

thank you
I've opened a new thread:

D-Link dir-645
seems to be affected, see my post D-Link dir-645: Cannot save any configuration changes in LUCI

My Sitecom WL-351 version v1.002 seems to have the same issue. LEDE 17.01.5 works fine.

Should not be affected, your device is 8 MB. See your post.