Issues with transmission after upgrading (part 2)

I had an existing post here: Issues with transmission after upgrading

At the bottom of the post is an init.d script that successfully launches Transmission
its been working for me through out a few of @davidc502 upgrades

but now after the latest Im having the problems again

init.d Transmission script:

#!/bin/sh /etc/rc.common
# Copyright (C) 2010-2015 OpenWrt.org

START=99
USE_PROCD=1
PROG="/usr/bin/transmission-daemon"

LIST_SEP="
"

append_params() {
	local p; local v; local s="$1"; shift
	IFS="$LIST_SEP"
	for p in "$@"; do
		config_get v "$s" "$p"
		for v in $v; do
			[ -n "$v" ] && echo "\"$p\": $v," | sed -e 's|_|-|g'
		done
	done
	unset IFS
}

append_params_quotes() {
	local p; local v; local s="$1"; shift
	IFS="$LIST_SEP"
	for p in "$@"; do
		config_get v "$s" "$p"
		for v in $v; do
			[ -n "$v" ] && {
				printf "\"%s" "$p" | sed -e 's|/|\\/|g;s|_|-|g'; \
				echo "\": \"$v\","
			}
		done
	done
	unset IFS
}

transmission() {
	local cfg="$1"

	local enabled
	config_get_bool enabled "$cfg" enabled 0
	[ "$enabled" -gt 0 ] || return 1

	local config_dir
	config_get config_dir "$cfg" 'config_dir' '/mnt/usb1/torrent/transmission'

	local MEM
	MEM=$(sed -ne 's!^MemTotal:[[:space:]]*\([0-9]*\) kB$!\1!p' /proc/meminfo)
	local USE
	[ "$MEM" -gt 1 ] && USE=$((MEM * mem_percentage * 10))

	config_file="$config_dir/settings.json"
	[ -d "$config_dir" ] || {
		mkdir -p "$config_dir"
		chmod 0755 "$config_dir"
		touch "$config_file" 
		[ -e "$config_dir/stats.json" ] || touch "$config_dir/stats.json"
		[ -z "$user" ] || chown -R "$user:$group" "$config_dir"
	}
  

	procd_open_instance
	procd_set_param command "$PROG"
	procd_append_param command -f -g "$config_dir" -e /mnt/usb1/torrent/transmission/log
	procd_set_param stderr 1
	procd_set_param respawn

	

	[ -d "$web_home" ] && procd_set_param env TRANSMISSION_WEB_HOME="$web_home"

 
	procd_close_instance
}

start_service() {
	config_load 'transmission'
	config_foreach transmission 'transmission'
}

reload_service() {
	procd_send_signal "$PROG"
}

service_triggers() {
	procd_add_reload_trigger "transmission"
}

sys log output

Tue May 12 09:52:51 2020 daemon.info procd: Instance transmission::instance1 s in a crash loop 6 crashes, 0 seconds since last crash

FYI i have tried USE_PROCD=0 but outcome was the same

Have you tried to get ahold of the person who supports Transmission? Or the transmission developer?

1 Like

I meant to tag them, i believe its @neheb

Usually when there is an issue with an app the developer usually already knows about it and are working for to a fix. Who knows, it may already be fixed, but we won't know until the next build is ready.

i dont think there is an app problem here, just the init.d script which i realize is coupled together but its still a separate thing (dont need a new build of the app to fix)
and it kinda seems to revolve around procd and your builds. Issues with transmission after upgrading

im not trying to point any fingers, i respect and thank you for all your work; and love your builds
im just trying to get this script working again

No idea. @dangowrt has been adding seccomp stuff which has been breaking constantly.

is a way i can manually start transmission? without the init.d script?

I tried

transmission-daemonroot@Skittles:~# transmission-daemon
-ash: transmission-daemon: not found
root@Skittles:~# transmission
-ash: transmission: not found

just wanted to add that i installed davidc's latest build but issue persist
even tried to factory reset, install transmission, enable it and run it
but even then i still get the crash loop error message from procd

I went back to just openwrt (not using davidc build) and its working now

errrrrrrrrrrrrrrrrrrrrrrrrrrrr
now my transfers speeds (samba) are all out of wack
5mb/s for wifi
25mb/s over ethernet

use to be 25 for wifi 100+ for ethernet

guess im gonna go back to davidc build and not use transmission for the time being
soooo frustrating

re-installed davidc build, network/samba transfer speeds are back to where they should be

but of course issue persist with transmission
:frowning:

@davidc502 there are 2 replies from back in 2018 that i had some further questions on

reply 1

Sorry bati, Transmission is not included in the build. You can download it from the daily lede snapshot repo if you want it

reply 2.

mariano.silva says:

can you include in the list of packages you build and leave in the packages folder, the transmission-daemon-openssl? Each build bump I make, I need to manually change the repos to the LEDE ones, then install transmission from there ... yeah, I'm lazy


Sooooo am i suppose to be getting transmission from some other repo? Other then the default repo included in the build?
what is the lede daily builds repo address?

ksmbd will give better performance.

1 Like

is this the difference between stock openwrt and davidc builds that make the transfers speeds faster?

No real idea.

wow thanks, this does get the transfer speeds where they should be on stock openwrt for me
unfortunately transfers r getting stuck at 99%
i posted a question on the ksmbd support page, hopefully they have some suggestions. after alot of troubleshooting this i feel im close to having it fully resolved; just this last issue

update:
now its randomly rebooting
looking at my previous post WRT1900AC - Random reboots
it was davidc build that fixed this
ahhh this is like an infinite loop of problems

I ended up using an older davidc build
https://dc502wrt.org/snapshots/r12230/targets/mvebu/cortexa9/openwrt-mvebu-cortexa9-linksys_wrt1900ac-squashfs-sysupgrade.bin

now everything is as it should be (using the init.d script we had from my other post referenced above)
guess ill stop upgrading for a bit

Hi Owengerig,
I managed to get Transmission working in the last version of Davidc502 firmware (on a WRT32x) following these steps:

  1. Remove all the packages previously installed of Transmission in the router

  2. Download the ipkg packages from the Openwrt repositories into the router. I used wget: https://downloads.openwrt.org/snapshots/packages/arm_cortex-a9_vfpv3-d16/packages/

  3. Install the downloaded packages:
    opkg install transmission-daemon-openssl_3.00-2_arm_cortex-a9_vfpv3-d16.ipk, etc...

  4. Edit /etc/init.d/transmission and delete the following lines:

if [ -f "$seccomp_path" ]; then
procd_set_param seccomp "$seccomp_path"
fi

  1. Enable Transmission in the settings.json/luci

  2. Restart the Transmission service: service transmission restart

I tried reusing the transmission config I backed up from /etc/config and that broke it again, so I'd just use the default config and change the values from scratch.

One of your past posts got my Transmission working the first time I installed David's firmware so I thought I'd try and give a bit back to you.

Good luck!

3 Likes

thank you very much Blaise!
glad my other post helped you!
im going to stay back dated on the build for now, ive spent too much time already
but ill keep this in mind, im sure eventually i will upgrade again

tried all this today and it worked for me, thanks again!

1 Like