Issue installing on Netgear WNR1000V2

I am trying to install to the router above by selecting Router Upgrade from accessing the router thru a web browser with my computer connected by a LAN cable and no internet to the router. Each time I try to upgrade the router, the router says that the image is the wrong firmware. How can I install the firmware? What do I need to do to get the

Did you use the factory image

I did. This is the error messages I get when I try to upgrade with this image!Issue%20downloading%20openwrt

Here is another pic after I pressed yes on the picture shownCannot%20install%20wrt%202

Are you sure about the model number and version, because the OEM latest firmware is

Firmware Version

And your screenshot shows a higher number.

Try to downgrade the official firmware to and try again with the openwrt factory image.
Also verify the image integrity with sha256sum.

1 Like

I am not super technical with networking gear so would you please either define or direct me to where I can learn what sha256sum technically is? And here is a pic of my router.

In the download page, next to the filename you'll see a string of alphanumerics. This is the hash sum of the file, calculated in order to verify its integrity.
You can google and install a sha256sum utility, then download the file, and pass it to the utility. It will generate an alphanumeric sum, which should match the one on the openwrt page.
This way you can be sure that the file you downloaded was not tampered or corrupted.

1 Like

If using windows you can use Get-FileHash

Was unablee to downgrade. I put that issue in the Netgear support. How can I figure out if this is a wnr1000v2 vs a wnr1000 v2-vc?


Hi friends,

I'm here to revive this thread

I have been spending my free time these past 2 weeks figuring this out using a friend's router

I have discovered many details that need to be known, not only about this router but for the whole ar71xx/tiny branch, most notably:

  • The public releases for this model, and possibly all of ar71xx/tiny, cause a kernel panic and boot loop. I know this would cause some to suggest dropping support for 4/32 models, but it can be solved with a few changes. I had to make my own builds to get it to work, and the board still does run OpenWRT VERY WELL if done properly (despite low ram)...Bug report coming soon...

As for flashing:

  • The OEM firmware is rejecting foreign software from the web interface
    and there is no way to get around it.

  • The only way you can flash this model with that firmware version is TFTP Recovery Mode through U-boot

Some reading before anyone tries this:
SaltwaterC's old guide

I wrote up a guide in similar fashion with a lot more details here:(

Feel free to message me

I've created updated builds for 18.06.02 and 17.01.06.

1 Like


I'd be happy to help you with this. You can also see my flashing instructions on WNR1000V2 Builds for NETGEAR

1 Like

I haven't looked at this in months and need to re-assess but I would still like to get mine working

1 Like

Great, I'd be happy to help. I looked at your earlier posts in this thread and think we can get this sorted out pretty easily. First, what specific version of firmware is your router WNR1000v2 currently running?

Is it


Hey there, its nice to see someone else working to keep 4/32 devices alive. I have a lot of ideas to help out all u-boot/atheros/4/32 devices but not a lot of time and low experience with C/C++. As we all know, for today its 4/32 devices that are running out of memory for todays software, but someday it will be the 8/64 devices that are at risk of losing support. Any help is appreciated. I also hate to throw away boards, that's why I figured out how to replace the flash on mine.

For my WNR1000v2, I never had any luck using the GUI to upgrade, TFTP was the only thing that worked, and I found it particularly easy and reliable compared to other routers, even compared to newer u-boot/atheros devices. Did you read my detailed description on the LED timings for TFTP on this model? What issues did you have with TFTP? If you have any issues, I would assume it is with the TFTP software you are using on the sending side. I'm curious about your setup nonetheless.

IMO, its a waste of time to evaluate what firmware or type of model of WNR1000v2 it is (Retail vs VC). I believe mine was originally VC, but I had replaced it with the U-boot image designed for Retail, which had a few more commands available (which is pretty much the only difference, other than the firmware protection) If you can get TFTP to work as I described, you're good to go, and can try as many images as you please, as TFTP Recovery mode on this model is much safer than using u-boot erase and copy commands directly on the flash. I've bricked this model in as many ways as someone can...and therefore TFTP through the reset button the only method I would recommend, especially to anyone with little or no experience in router software.

1 Like

If can be useful and save your time, this is my experienche with WNR1000v2:

  1. you need to download the Older Builds of 19.07.4, 18.06.8, 17.01.7 from this page:
    Builds for NETGEAR WNR1000V2, WNR1000V2-VC, WNR612v2, WPN824N, WNR2000v3, EX2700
    Because the latest 19.07.10 doesn't let you save settings and the router will boot always as factory settings. Sigh, I've lost two hours before I decide to flash 18.06.8 and solve it!

  2. I had an old FW, I coudn't load from it OpenWRT, so I needed to upgrade before to the latest factory FW (I used WNR1000v2-V1.1.2.60NA), then flash 18.06.8