IPv6 connection fails

Not the same as ifstatus wan6 (without the space between wan and 6).

1 Like

yes you're right it brought up the virtual one i suppose instead of the real interface

In the WAN6 interface in LuCI, is the wan6 added to the WAN firewall zone?

Yes:

There is a slight issue here, you are running 2 wan6 interfaces. One is the wan6 configured in the /etc/config/network, the other is automatically created when pppoe comes up because you have in the wan configuration the option ipv6 'auto'
You can either delete wan6 interface and keep the automatically created wan_6, or change option ipv6 '1' in wan interface. In any case, make sure the interface you keep exists in wan firewall zone.
Also in DHCP settings, disable NDP for lan interface and delete all the relay settings you have in wan6. You are being delegated a prefix so relay is not needed.

İf i disable the wan_6 i lose connection to ipv6:

cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd0:40f3:540b::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config device
        option name 'eth0.1'
        option macaddr '88:c3:97:85:e0:88'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        list dns '1.1.1.1'
        list dns '1.0.0.1'
        option ip6assign '60'

config interface 'wan'
        option device 'eth0.2'
        option proto 'pppoe'
        option username '5340649477adsl@turk.net'
        option password '7cf5546b03'
        option peerdns '0'
        list dns '1.1.1.1'
        list dns '1.0.0.1'
        list dns '2606:4700:4700::1111'
        option ipv6 '1'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'
        option reqprefix '56'
        option peerdns '0'
        list dns '2606:4700:4700::1111'
        list dns '2606:4700:4700::1001'
        option reqaddress 'force'
        option defaultroute '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 0t'
cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        list dns '2606:4700:4700::1111'
        list dns '2606:4700:4700::1001'
        option ra 'server'
        option dhcpv6 'server'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'
        list ra_flags 'none'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'wan6'
        option interface 'wan6'
        option ignore '1'
        list ra_flags 'none'
ifstatus lan
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 238,
        "l3_device": "br-lan",
        "proto": "static",
        "device": "br-lan",
        "updated": [
                "addresses"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [
                {
                        "address": "192.168.1.1",
                        "mask": 24
                }
        ],
        "ipv6-address": [

        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [
                {
                        "address": "fdd0:40f3:540b::",
                        "mask": 60,
                        "local-address": {
                                "address": "fdd0:40f3:540b::1",
                                "mask": 60
                        }
                }
        ],
        "route": [

        ],
        "dns-server": [
                "1.1.1.1",
                "1.0.0.1"
        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {

        }
}
ifstatus wan6
{
        "up": false,
        "pending": true,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "proto": "dhcpv6",
        "device": "eth0.2",
        "data": {

        }
}
 ifstatus wan 6
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 297,
        "l3_device": "pppoe-wan",
        "proto": "pppoe",
        "device": "eth0.2",
        "updated": [
                "addresses"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [
                {
                        "address": "100.96.10.61",
                        "mask": 32,
                        "ptpaddress": "172.17.1.222"
                }
        ],
        "ipv6-address": [
                {
                        "address": "fe80::f89e:b1b1:1749:4aaf",
                        "mask": 128
                }
        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "0.0.0.0",
                        "mask": 0,
                        "nexthop": "172.17.1.222",
                        "source": "0.0.0.0/0"
                }
        ],
        "dns-server": [
                "1.1.1.1",
                "1.0.0.1",
                "2606:4700:4700::1111"
        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [
                        "193.192.98.8",
                        "212.154.100.18"
                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {

        }
}

if i delete the WAN6 though it shows OK:

These are very aggresive settings. Leave reqprefix to auto, you can get the dns servers from the ISP (this was not your problem btw), reqaddress leave it to try, and finally you need to enable the default route!

network.wan6.device='@wan'; uci commit network; ifup wan6

Should i enable back the Wan6?

If it works with wan_6, better leave it like this.

i think i messed up big at some point:

none of the interfaces have DHCP setup as Lu-CI shows but im connected to network.

Going to reset and start from scratch.

Just change the wan interface to pppoe protocol. The rest should work by default.

Ok i resetted and configured "option ipv6 '1' and enabled dhcp for WAN6. i haven't touched anything other than this


config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc4:2d17:29e0::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config device
        option name 'eth0.1'
        option macaddr '88:c3:97:85:e0:88'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'eth0.2'
        option proto 'pppoe'
        option username '5340649477adsl@turk.net'
        option password '7cf5546b03'
        option ipv6 '1'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 0t'
cat  /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'
        list ra_flags 'none'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'wan6'
        option interface 'wan6'
        option ignore '1'
        list ra_flags 'none'
 ifstatus wan6
{
        "up": false,
        "pending": true,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "proto": "dhcpv6",
        "device": "eth0.2",
        "data": {

        }
}
ifstatus wan 6
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 112,
        "l3_device": "pppoe-wan",
        "proto": "pppoe",
        "device": "eth0.2",
        "updated": [
                "addresses"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [
                {
                        "address": "100.96.10.208",
                        "mask": 32,
                        "ptpaddress": "172.17.1.222"
                }
        ],
        "ipv6-address": [
                {
                        "address": "fe80::6cc4:6c2f:c70e:e655",
                        "mask": 128
                }
        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "0.0.0.0",
                        "mask": 0,
                        "nexthop": "172.17.1.222",
                        "source": "0.0.0.0/0"
                }
        ],
        "dns-server": [
                "193.192.98.8",
                "212.154.100.18"
        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {

        }
}

This is not even active how does it show up like that? :arrow_up:

network.wan6.device='@wan'; uci commit network; ifup wan6

This
returns this: -ash: network.wan6.device=@wan: not found

so when trying out different settings i noticed if i change the wan6 device:

i get ipv6 adress again over wan6:

still at this point though:

opkg update; opkg install tcpdump; tcpdump -evni pppoe-wan icmp6
Then start again the ping.

So in the last 24 hours i tried two additional different modems: ZYXEL VMG3312-B10B and TP-LINK TD-W9970 you probably don't know any of these modems but they are custom Turk Telekom owned modems which is made for Turk Telekom on behalf of their request from these manufacturers and then they install their custom firmware which disables the most of the features that a router/modem can have (Ipv6 support, DNS change, firmware upgrade, QOS...) so after this point you can try to downgrade them using developers tools and seeking for a software deficit and if you're lucky you can downgrade some models to some certain firmware versions. Unfortunately TP-LINK one had past that point and there's no workaround for that modem. With the Zyxel one i had some luck and managed to downgrade it to a version which had more settings like Ipv6/Ipv4 dual stack but nonetheless i still couldn't managed to get an Ipv6 connection. Even on the diagnostic section of the modem all the i got %100 packet loss from ping tests.

So for now i will end my pursuit about this issue and try to buy a new modem/router from a brand like Keenetic and try to avoid any ISS given/recommended models

Thanks everyone who did a comment on this topic and tried to guide me around this and sorry @trendy for not being able to test your last suggestion but this thing really got into something i obsessed with right now so it gotta end.

Does this device use offloading? It is broken for ipv6 without a kernel patch.

Hardware flow offloading with IPv6 causes unstable connections.

The OP can't connect to IPv6 at all.

so after a day off, i realized that this won't get out of my head until someone tells me or i find out that "there's a problem at this point or section so i / you can't make the connection". so right now i still got the old Air-Ties Air 5650 modem which doesn't get any Ipv6 adresses while using it as an PPPoE device. all my configs and settings are the stock factory settings on OpenWrt AC-2350 device i only changed WAN interface to PPPoE and Obtain Ipv6 Adress Manual:

so testing trendy's last suggestion just brought up nothing. After that i tried to ping6 some adressess but stuck at this:

tcpdump: listening on pppoe-wan, link-type LINUX_SLL (Linux cooked v1), capture size 262144 bytes
ping6 2606:4700:4700::1111

I've enabled Hardware flow offloading but i don't affected anything:

Did you run the ping under tcpdump or in a new terminal?