IPv6 connection fails

I'm trying to secure a Ipv6 connection to my router but for some reason whatever configuration i try i always fail to even get pass the ipv6 ping test at Luci interface. I use Airties Air5650 in bridge mode and Xiaomi AC - 2350 as my router. Here is my config:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd0:40f3:540b::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config device
        option name 'eth0.1'
        option macaddr '88:c3:97:85:e0:88'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'eth0.2'
        option proto 'pppoe'
        option username '*****'
        option password '*******'
        option ipv6 'auto'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix '56'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 0t'
config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option ndp 'hybrid'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'
        list ra_flags 'none'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'wan6'
        option interface 'wan6'
        option ignore '1'
        option ra 'relay'
        option dhcpv6 'relay'
        option ndp 'relay'
        list ra_flags 'none'
Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . : lan
   Description . . . . . . . . . . . : Realtek RTL8822CE 802.11ac PCIe Adapter
   Physical Address. . . . . . . . . : 28-CD-C4-**-A1-5D
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2a02:ff0:***:dc9a::e05(Preferred)
   Lease Obtained. . . . . . . . . . : Tuesday, 10 May 2022 02:25:53
   Lease Expires . . . . . . . . . . : Tuesday, 10 May 2022 14:25:53
   IPv6 Address. . . . . . . . . . . : 2a02:ff0:***:dc9a:45ff:1e49:7ea1:cd93(Preferred)
   IPv6 Address. . . . . . . . . . . : fdd0:40f3:****::e05(Preferred)
   Lease Obtained. . . . . . . . . . : Tuesday, 10 May 2022 02:25:54
   Lease Expires . . . . . . . . . . : Tuesday, 10 May 2022 14:25:53
   IPv6 Address. . . . . . . . . . . : fdd0:****:540b:0:45ff:1e49:7ea1:cd93(Preferred)
   Link-local IPv6 Address . . . . . : fe80::****:1e49:7ea1:cd93%5(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.208(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Monday, 9 May 2022 18:07:51
   Lease Expires . . . . . . . . . . : Tuesday, 10 May 2022 14:25:52
   Default Gateway . . . . . . . . . : fe80::8ac3:97ff:fe85:e088%5
                                       192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 69782980
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-28-7E-D0-1A-F8-0D-AC-1A-07-4A
   DNS Servers . . . . . . . . . . . : fdd0:****:540b::1
                                       192.168.1.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

image

Try ping6

C:\Users\****>ping -6 ipv6.google.com

Pinging ipv6.l.google.com [2a00:1450:4017:806::200e] with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 2a00:1450:4017:806::200e:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

Is this what you mean?

ping6 on the OpenWrt router, which is what you posted the screenshot of.

root@OpenWrt:~# ping6 ipv6.google.com
PING ipv6.google.com (2a00:1450:4017:806::200e): 56 data bytes

it's stuck at this point.

CTRL-C to stop it.

Use the same endpoint in the screenshot (openwrt.org).

PING openwrt.org (2a03:b0c0:3:d0::1af1:1): 56 data bytes
^C
--- openwrt.org ping statistics ---
15 packets transmitted, 0 packets received, 100% packet loss

i prematurely ended it.

OK...

So run -

ping6 2a03:b0c0:3:d0::1af1:1

PING 2a03:b0c0:3:d0::1af1:1 (2a03:b0c0:3:d0::1af1:1): 56 data bytes
^C
--- 2a03:b0c0:3:d0::1af1:1 ping statistics ---
26 packets transmitted, 0 packets received, 100% packet loss

btw sorry if i'm being a burden to you with my ignorance here.

Your running ping ...instead of ping6 on OpenWrt.

Copy and paste this line -

ping6 2a03:b0c0:3:d0::1af1:1

Run it in OpenWrt.

In Windows, it's ping -6, so -

ping -6 2a03:b0c0:3:d0::1af1:1

ping -6 2a03:b0c0:3:d0::1af1:1

Pinging 2a03:b0c0:3:d0::1af1:1 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 2a03:b0c0:3:d0::1af1:1:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

Run it with ping6 on OpenWrt...as shown above.

I suspect that DNS is wrong for the WAN6 interface.

root@OpenWrt:~# ping6 2a03:b0c0:3:d0::1af1:1
PING 2a03:b0c0:3:d0::1af1:1 (2a03:b0c0:3:d0::1af1:1): 56 data bytes
^C
--- 2a03:b0c0:3:d0::1af1:1 ping statistics ---
9 packets transmitted, 0 packets received, 100% packet loss

i really type in "ping6" but it translates into "PING" while pinging

Run the following in SSH -

ubus call system board

and

ls -l /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0

ls -l /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/*

Post results.

root@OpenWrt:~# ubus call system board
{
        "kernel": "5.4.188",
        "hostname": "OpenWrt",
        "system": "Qualcomm Atheros QCA956X ver 1 rev 0",
        "model": "Xiaomi AIoT AC2350",
        "board_name": "xiaomi,aiot-ac2350",
        "release": {
                "distribution": "OpenWrt",
                "version": "21.02.3",
                "revision": "r16554-1d4dea6d4f",
                "target": "ath79/generic",
                "description": "OpenWrt 21.02.3 r16554-1d4dea6d4f"
        }
}
root@OpenWrt:~# ls -l /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0
lrwxrwxrwx    1 root     root            16 Apr 16 12:59 /etc/resolv.conf -> /tmp/resolv.conf
-rw-r--r--    1 root     root            47 May  9 23:28 /tmp/resolv.conf
-rw-r--r--    1 root     root           164 May  9 23:22 /tmp/resolv.conf.d/resolv.conf.auto
-rw-r--r--    1 root     root            50 May  9 23:22 /tmp/resolv.conf.ppp

/tmp/resolv.conf.d:
-rw-r--r--    1 root     root           164 May  9 23:22 resolv.conf.auto

My bad.

This...

ls -l /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/*

root@OpenWrt:~# ls -l /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/*
lrwxrwxrwx    1 root     root            16 Apr 16 12:59 /etc/resolv.conf -> /tmp/resolv.conf
-rw-r--r--    1 root     root            47 May  9 23:28 /tmp/resolv.conf
-rw-r--r--    1 root     root           164 May  9 23:22 /tmp/resolv.conf.d/resolv.conf.auto
-rw-r--r--    1 root     root            50 May  9 23:22 /tmp/resolv.conf.ppp

/tmp/resolv.conf.d:
-rw-r--r--    1 root     root           164 May  9 23:22 resolv.conf.auto
==> /etc/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf.d <==
head: /tmp/resolv.conf.d: I/O error

==> /tmp/resolv.conf.ppp <==
nameserver 193.192.98.8
nameserver 212.154.100.18

==> /tmp/resolv.conf.d/resolv.conf.auto <==
# Interface wan
nameserver 193.192.98.8
nameserver 212.154.100.18
# Interface wan_6
nameserver 2a02:ff0:2:327:193:192:98:8
nameserver 2a02:ff0:4:327:212:154:100:18

Where did you get the nameservers?

#Interface wan_6
nameserver 2a02:ff0:2:327:193:192:98:8
nameserver 2a02:ff0:4:327:212:154:100:18

What do you mean by "where" ? Aren't they ISP given? I didn't do anything specifically about them.

Are you on turk.net?