Installing OpenWRT in a X86 System in a partition, having both WIN11 and OpenWRT

First Google result for "mount" "invalid argument":

You might need to specify a filesystem with the -t parameter. Do you know which filesystem exists on /dev/sdc1 ?

1 Like

I have other tasks I must accomplish this evening, so I'll be shutting this computer down now. Good luck with your endeavours.

I'll fish out a spare USB stick when the new toy arrives and see how much damage I can do to it. I'll document my findings and update this thread accordingly.

If you don't care about the content of /dev/sdc1 do a mkfs.ext4 /dev/sdc1 1st.

Thanks for your replies sirs, i will still trying something meanwhile like buying a 5€ repeater with rj45, repeating signal from my phone to this repeater, and then connecting it to the x86 and try, for example

In sdc i have the .img to write the nvme with dd

If you booted from the flash drive, copy it to /tmp instead, then from openwrt do dd if=/tmp/squashfs-combined.img of=/dev/sdc
If the file is in the gz format, do zcat /tmp/squashfs-combined.gz > /dev/sdc instead.

Good morning, i did the command that @frollic said transferring the custom .img to /tmp vía WinSCP and then did dd if=/tmp/imagename.img of=/dev/sda and worked properly. I dont have to boot the x86 from flash usb anymore but the problem of no LuCI still existing, what could be happening guys?

I mean… generic .img with no additional packages works fine, but custom .img not… what are we forgeting….?

Seems the online image builder doesn't add luci to the default image, add luci to the package list.

package is named luci?

But anyways, it doesnt let me to access it via ssh or SCP...

cant find it in

what doesn't ?

can't find what ?

the x86 doesnt let me access via LuCI and SCP/Putty neither

LuCI package, whats name it has?

tried both ports ?

it's luci.

Bingo! eth0 let me connect via SCP.

it been a while since im searching for it but i cant found it...

just add it to the image builder package list, it has a bunch of dependencies.

adding luci to the builder package will add dependencies automatically?

yes, it will.

then just transfer the new img to the routers /tmp folder, and via ssh run sysupgrade /tmp/imagename.img

Done, i have now LuCI and connection via SCP, but still not have internet access.
Tethering packages are not shown in LuCI...

none of the packages on the tether page are luci-* packages.
what are you missing / expecting to see ?

Looks like Amazon intends to deliver my new toy today, despite picking the free "deliver it whenever you want" option rather than paying extra for guaranteed delivery today.

So that's nice.

Looking forward to tinkering with it this evening.

yeah i know, but one of the replies above i think @iplaywithtoys told me that i could install tether packages to have internet access via a phone hotspot, so i built an image with all of this:

base-files busybox ca-bundle dnsmasq dropbear e2fsprogs firewall4 fstools kmod-amazon-ena kmod-amd-xgbe kmod-bnx2 kmod-button-hotplug kmod-e1000 kmod-e1000e kmod-forcedeth kmod-fs-vfat kmod-igb kmod-igc kmod-ixgbe kmod-nft-offload kmod-r8169 kmod-tg3 libc libgcc libustream-wolfssl logd mkf2fs mtd netifd nftables odhcp6c odhcpd-ipv6only opkg partx-utils ppp ppp-mod-pppoe procd procd-seccomp procd-ujail uci uclient-fetch urandom-seed urngd kmod-usb-net-ipheth usbmuxd libimobiledevice usbutils kmod-nls-base kmod-usb-core kmod-usb-net kmod-usb-net-cdc-ether kmod-usb2 kmod-usb-net-cdc-eem kmod-usb-net-cdc-ether kmod-usb-net-cdc-subset kmod-usb-net-huawei-cdc-ncm kmod-usb-net-rndis lsblk libc libblkid1 libmount1 libsmartcols1 luci