Installing OpenWRT in a X86 System in a partition, having both WIN11 and OpenWRT

So the nvme comes up as sda

If you install a ready-made x86 build onto the internal disk - see https://openwrt.org/docs/guide-user/installation/openwrt_x86 - then you'll have a Web interface ready and waiting for you.

From that photograph and the displayed partition sizes, it looks as if the internal disk is possibly /dev/sda.

You still haven't posted the logread part I asked about.

sorry but cant post all the log, its too large even to take a picture of it, and i cant access via ssh neither...
If you explain to me how to do it...

Logread -f wouldn't be a lot, just what happened since you started it.

So, in summary:

  • You have one ACEMAGICIAN T8 PLUS 8GB 256GB which you want to install OpenWRT on.

  • You have prepared a USB stick with OpenWRT on it, and booted the ACEMAGICIAN T8 PLUS 8GB 256GB from the USB stick.

  • You have another computer, maybe a laptop, maybe a desktop (I'm guessing a laptop) with a working Internet connection.

  • This other computer also has an Ethernet socket, and you have already run an Ethernet cable between the two computers.

  • You are unable to connect to 192.168.1.1 from the other computer, whether by SSH or HTTP.

Is the above summary correct? Is any of it incorrect?

If the above summary is correct, then consider this:

  • You need an Internet connection to download the relevant packages to get the wireless interface working.

  • You cannot use the Internet unless you get the wireless interface working

Is that, in turn, an accurate summary of the challenge you are facing?

If so, then consider using the other computer to give temporary Internet access to your ACEMAGICIAN T8 PLUS 8GB 256GB; turn the other computer into an upstream router (or maybe a proxy server) for the ACEMAGICIAN T8 PLUS 8GB 256GB.

For this to happen, both computers need to be able to establish a working network connection to each other.

When you connect the Ethernet cable between the two computers, if your other computer is configured for DHCP then what IP address does your other computer pick up?

Does it pick up an address in the 192.168.1.0/24 range, or does it autoconfigure itself with a 169.254.x.x address?

Does this same behaviour persist after you move the Ethernet cable to the other port on your ACEMAGICIAN T8 PLUS 8GB 256GB?

If your other computer runs Windows, then your Google search term to start you off is "windows internet connection sharing".

If your other computer is a Mac, then your Google search term to start you off is "mac internet connection sharing".

If your other computer runs Linux, then your Google search term to start you off is "linux internet connection sharing".

Be careful with this approach; turning an endpoint computer into a router does come with some security considerations, so ensure you take precautions not to expose the other computer to unwanted inbound traffic.

The other approach - a proxy server - might also work (I haven't tested opkg through a proxy; I know that curl respects http_proxy and https_proxy environment variables, so I assume that opkg should work through a proxy, but I have never tried it in earnest, so this suggestion may require some thought on your part.

For this approach, you would need to run some software which behaves as a proxy server, then point your ACEMAGICIAN T8 PLUS 8GB 256GB to the proxy server for any downloads. It might be possible to achieve this by setting http_proxy and https_proxy environment variables before running opkg.

Dont know why but, yes, it is too large. Tried to logread -f >> /dev/sdc/logread-f.txt but im getting cant create 'file.txt' nonexistent directory but it exists... as you can see here:

Im trying to do this https://openwrt.org/docs/guide-user/installation/openwrt_x86

but i cannot do dd because im getting cd: cant cd to /dev/sdc/: Not a directory is where i have the .img to dd from sdc to sda...

Try mounting the partition first, to e.g. /mnt/sdc1, and not trying to perform filesystem operations directly with the parent /dev/sdc device - you would benefit from learning how Linux storage devices and partitions are named.

A reminder: dd is absolutely destructive. If you get dd to write anything to /dev/sda then you will probably lose your Windows installation. Do you have a backup, in case you ever decide you want to run Windows on it again?

All correct, but i only cannot access LuCI with 192.168.1.1 with the custom img, if i flash a normal .img it let me access...

Right too

Do you mean bridging wifi with Ethernet, connect ethernet cable to AGEMAGICIAN and it should have Internet Access, right

2 Ethernet ports, same problem

Will do all of this thing and comment the result...

I've just ordered one of those things from Amazon; it should arrive later this week. I've been looking for a cheap dual-NIC mini PC that I can turn into a router/firewall/VPN/whatever, so I'm going to attempt to do what you're trying to do, and get OpenWRT working on it.

I'll then be able to give you assistance directly based on my own experience, instead of guessing what might work. Hopefully I haven't just wasted a hundred and fifty quid... :wink:

Dont mind about W11 installation, no problem about that

Did command: mount /dev/sdc1 /mnt/sdc1 and got mount: mounting /dev/sdc1 on /mnt/sdc1 failed: No such file or directory :man_facepalming:

Did you create /mnt/sdc1 first? One entertaining idiosyncrasy of HFS is that the target directory has to exist before it can be used to mount a storage device.

Its Amazon, you have 30 days to do tests :crazy_face:

1 Like

Yes. That's what I had in mind. The exact mechanism to do so will depend on what your other computer is capable of doing, but that's the general principle.

For my own tests, I have laptops with both Wi-Fi and Ethernet sockets, which dual-boot between Linux and Windows, and I shall be using one of them to attempt what I suggested. I could connect the new toy directly to my network via Ethernet, but your problem is that you don't have that option available to you, so I'll pretend that I have the same restriction.

I didnt, but when i create it...

Im getting really angry rn....

/dev/sdc is the device

/dev/sdc1 is the partition

mount /dev/sdc1 /mnt/sdc1 ought to work... if automatic filesystem detection is working. It might be necessary to add additional parameters.

As I mentioned earlier, you would benefit from learning about Linux device naming conventions.

mount /dev/sdc1 /mnt would work, since there's no dir called /mnt/sdc1

1 Like

frollic is right. The target folder is not required to have the same name as the partition mounted to it. But the /dev/xxx identifier absolutely must be accurate.

Same error that image above....