Image Builder issues


#1

Hi,
I'm trying to set up IB according to this guide:
Quick Image Building Guide

First thing
git clone https://git.openwrt.org/openwrt/openwrt.git/
stucks for not reaching target.

I managed to get IB tar from Supplementary Files

but then
./scripts/feeds update -a

fails with error
Unable to open feeds configuration at ./scripts/feeds line 48.

What am I doing wrong?


#2

HI dont konw

but

git clone https://git.openwrt.org/openwrt/openwrt.git

worked for me 2hours ago


#3

You are mixing the full toolchain based build environment to the "image builder". The page that you linked above has advice for the full toolchain, but it contains also the link to the image builder advice:

Alternative guides to achieving the same goal: Using the Image Builder https://openwrt.org/docs/guide-user/additional-software/imagebuilder

Whole "git clone" stuff in unnecessary if you use the imagebuilder.

And you apparently downloaded IB for the ar71xx-tiny target. Was that your intention? That ar71xx-tiny only supports a small selection of old small routers. You need to first find and download the correct IB for your router (which you didn't mention, so we can't point you to the correct one).


#4

@hnyman My router is TP Link TL740n if it counts somehow but the thing is that downloaded IB doesn't work out of the box - I'm not sure if that was intended.
I visited linl you provided and in Obtaining the Image Builder section it suggests to do exactly what I did - to download IB from "the same download page where you find the firmware image for your device"

@Pippo I don't know either but it doesn't now


#5

Why is not working? What errors do you receive?


#6

Which OS and version are you using?


#7

are you able to see

https://git.openwrt.org/openwrt/openwrt.git/

with your browser?


#8

@Pippo, nope - waiting timeout.
Tried right now latest Cromium and FF - on Ubuntu Mate 18.04

console brings the same:

git clone https://git.openwrt.org/openwrt/openwrt.git
Cloning to «openwrt»…
fatal: unable to access 'https://git.openwrt.org/openwrt/openwrt.git/': Failed to connect to git.openwrt.org port 443: Connection timeout

Tried two different providers, BTW.


#9

@jow
Please see above + after I created feeds.conf.default manually (downloaded from here) and finally updated feeds (gave some errors - like lucy was'n found therefore there is /feeds/luci.tmp/ with one file and no /feeds/luci with plenty of them as I guess it supposed to be), I get

~/openwrt.18.06$ ./scripts/feeds install -a
make: *** No rule to make target  «prepare-tmpinfo».  Stop.
Cannot open './tmp/.packageinfo': No such file or directory
Can't open file './tmp/.targetinfo': No such file or directory
Ignoring feed 'luci' - index missing
Ignoring feed 'telephony' - index missing
Installing all packages from feed packages.
Installing all packages from feed luci.
Ignoring feed 'luci' - index missing
Installing all packages from feed routing.
Installing all packages from feed telephony.
Ignoring feed 'telephony' - index missing
Installing all packages from feed management.

#10

You don't use feeds with the imagebuilder, everything is already precompiled and the IB uses opkg repositories directly. Just run make image.


#11

This way it works! Thank you.
Seems that I messed up with Quick start howto somehow, but these two dev tutors are very diferent. I was attracted by menuconfig there - which doesn't exist in second howto
.
One more question: how can I find packages descriptions?
My goal is to exclude unnecessary packages (ipv6 i.e.) in favor of needed ones (DDNS to name first) - since Flash in this router is only 4MB..


#12

e.g. via the packages table: https://openwrt.org/packages/table/start


#13

Thank you. Sorry for no being more specific, I mean - packages list included in default image build, what can be removed. Probably I was looking for wrong keywords, but couldn't find such list yet


#14

https://openwrt.org/docs/guide-user/additional-software/saving-space


#15

Thank you VERY much!


#16

Sorry for disturbing again guys, but new isues(

Steps taken:

  1. make image PROFILE=tl-wr740n-v4 works but doesn't let include/exclude packages: once I add in command PACKAGES="..." variable it throws plenty of errorors for every package mentioned there like "luci-app-ddns not being a target" and therefore compiles nothing
  2. Ok, I found workaround of editing my router profile in .targetinfo, now entry looks like
Target-Profile: DEVICE_tl-wr740n-v4
Target-Profile-Name: TP-LINK TL-WR740N/ND v4
Target-Profile-Packages: luci-app-ddns ddns-scripts -opkg uhttpd uhttpd-mod-ubus libiwinfo-lua luci-base luci-app-firewall luci-mod-admin-full luci-theme-bootstrap -ppp -ppp-mod-pppoe -ip6tables -odhcp6c -kmod-ipv6 -kmod-ip6tables
Target-Profile-Description:
Build firmware images for TP-LINK TL-WR740N/ND v4
@@

This way it works and I can flash compiled sysupgrade to router via luci

  1. But when I get in luci to Services/DDNS I get in browser this error:

Failed to execute cbi dispatcher target for entry '/admin/services/ddns'.
The called action terminated with an exception:
/usr/lib/lua/luci/controller/ddns.lua:107: attempt to index field '?' (a nil value)
stack traceback:
	/usr/lib/lua/luci/controller/ddns.lua:107: in function 'service_version'
	/usr/lib/lua/luci/controller/ddns.lua:117: in function 'service_ok'
	/usr/lib/lua/luci/model/cbi/ddns/overview.lua:20: in function 'func'
	/usr/lib/lua/luci/cbi.lua:66: in function 'load'
	/usr/lib/lua/luci/dispatcher.lua:838: in function </usr/lib/lua/luci/dispatcher.lua:832>

My router is TL-WR740N v4.27, so according to its page 18.06.1 is working version - and I'm using IB 18.06.1 too.
The only thing I can suspect is that mention here:

**Inside OpenWrt two package versions are available:**
up to Barrier Breaker 14.07 it's  *ddns-scripts*  version 1.x
since Chaos Calmer 15.05 it's  *ddns-scripts*  version 2.x with IPv6 support and many other extensions
the corresponding LuCI application  *luci-app-ddns*  is also available.

May it be that IB pulls wrong version (latest and greatest 2.x CC one instead of needed BB 1.x)?
Thank you in advance for any help


#17

I suggest you try to figure out why you can't connect to https://git.openwrt.org/openwrt/openwrt.git/. The same problem may cause other issues as well, and I think it is more likely that it will work if you can follow the usual recipe for building. Alternatively, please post the errors you get when you run make image PROFILE.


#18

The thing is that my Ubuntu is localized so all errors in Russian - I have to translate them to paste here and there are many of them
I googled a lot around and finally found topic (sorry, it's in Russian too) describing the same issue - folks from Russia can't access git.openwrt. Seems that it's consequesnce of damned Telegram war..((
I'll try TOR and let you know results, thank you


#19

You can also use github:
https://github.com/openwrt/openwrt.git


#20

But like I said to you above, the discussion here is mixed between the

  • use the simple "image builder" to cook up the firmware from ready compiled packages.
  • full toolchain, where you need git clone and feeds etc.

You can't mix 18.06 firmware and packages from four years older BB14.07
A 18.06 IB should pull 18.06 packages.