Image Builder issues


#21

That was my intention and that's what I did (AFAIU) - downloaded IB and tried to follow howto.
But met those issues:

  1. PACKAGES var didn't work (no idea why)
  2. ddns added to image by workaround above didn't work on device - while image compiled with no errors

#22

I think using a VPN would be the only choice for OP in this case because censorship firewalls. Then OP can use everything as a normal person who has access to Openwrt git repo.


#23

Guys, TOR brings no good - ddns service in luci still shows the same error as above.
Here is building console output
.
But at least I found the root of issue with adding PACKAGES var to command:
in saving space howto var example uses these quotation marks - “ (look like italic ones), I pasted example in Pluma (default text editor in Mate), then edited and copypasted to console - they stay kinda italic, hard to notice..
Once I replaced them to usual "vertical" ones - it works. Please let know this issue to page mantainer, probably someone else will bump in the same stuff...

But main issue isn't resolved - why ddns doesn't work in image giving this error in luci?

Failed to execute cbi dispatcher target for entry '/admin/services/ddns'. The called action terminated with an exception: /usr/lib/lua/luci/controller/ddns.lua:107: attempt to index field '?' (a nil value) stack traceback: /usr/lib/lua/luci/controller/ddns.lua:107: in function 'service_version' /usr/lib/lua/luci/controller/ddns.lua:117: in function 'service_ok' /usr/lib/lua/luci/model/cbi/ddns/overview.lua:20: in function 'func' /usr/lib/lua/luci/cbi.lua:66: in function 'load' /usr/lib/lua/luci/dispatcher.lua:838: in function </usr/lib/lua/luci/dispatcher.lua:832>

Thank you in advance for any tips.


#24

The luci app based on 18.06 dies here:

ddns

To fix that, please do not remove opkg in your image.


#25

@dibdot, THANK you!
Keeping opkg resolved the issue.
.
Why then opkg isn't listed as dependency of ddns?
And in "Saving firmware space" no mentions that it is needed for image buiding...
Thank you again!


#26

You can always edit documentation to update it. It may be that no one came to this point yet so there's no mention of anything.