How to properly install OpenWrt on Asus RT-AC58U?

Hello, I am an absolute beginner so i beg your pardon.
I want to install OpenWRT on my Asus RT-AC58U.

I was reading the instructions as described here:

I was looking under the "Easy Installation" section and i found that it gives a warning to backup calibration data, which i can understand as that i have to backup something from my router first. But when i open up the link to the article mentioned (AC58U no wireless option in network after installing 18.06.1) I have no idea about what is going on here, and what should i do to backup my router's data.

The at most thing which i could figure out was that i have to backup two partitions, named Factory 1 and Factory 2. But I have no idea on how to do so.

Please can someone explain to me what i need to do, to back those up and then later how do i restore them back if i face the same problem as discussed in the topic linked.


Be aware of If you can still return it for something with sufficient amounts of RAM (ipq40xx is fine, but it just needs at least 256 MB RAM), I'd recommend doing that.


It's over a year old and I can't return it.

Hello Sksar,

I'm also total newbie who plans to install OpenWRT on Asus RT-AC58U. I hope you installed OpenWRT successfully. If yes, can you tell me please, how did you "backup calibration data first", as I've the same doubts/questions as you had :slight_smile:

Best regards,

Any update?
I am an owner of new RT-AC1300UHP (RT-AC58U), who struggled to find guide on how to back Fatory1, Factory2 partition from NAND. Still running stock ASUS firmware with buggy QoS function, wish to be able upgrade to OpenWRT after backup.

  • Enable SSH access on original firmware's web interface
  • Login via SSH (I used PuTTY on Windows), use the same login credentials as for the web interface
  • Make a copy of ubi0_1: cp /dev/ubi0_1 /tmp
  • Make a copy of ubi0_2: cp /dev/ubi0_2 /tmp
  • Copy those two files (/tmp/ubi0_1 and /tmp/ubi0_1) to your PC via SCP (I used WinSCP on Windows)
  • The two files are/must be identical in content, the first is your calibration data, the second is a backup copy
  • Go to Zyxmon's AC58U builds page ( and download the XXX-squashfs-flash-factory.trx file.
  • Get the latest OpenWrt release (XXX-squashfs-sysupgrade.bin)
  • On the router's web interface, go to Administration -> Firmware Upgrade
  • Upload the .trx file (Zyxmon) and wait until the router has rebooted into OpenWrt
  • Delete jffs2 partition by using SSH on, login as root/no password and enter: umount /mnt/ubi0_5 (in case the partition is mounted) and then: ubirmvol /dev/ubi0 -N jffs2
  • Go back to the browser on, login (without a password) and proceed to System -> Flash Firmware
  • Flash the latest OpenWrt release (XXX-squashfs-sysupgrade.bin). Make sure to uncheck 'Keep settings.'
  • You now have the latest OpenWrt on your router.

From what I understand, it is best to always do a software reboot (System -> Reboot) after changing any settings before pulling the power cord. (A power loss without reboot might corrupt data)

1 Like

Thank you for the clear instructions! I just followed these instructions on a newly-purchased ASUS RT-ACRH13. Seems to be working fine. My first time trying out OpenWrt.

I will give an update if it stops working for some reason :slight_smile:

Looking for some help putting openWrt on my RT-ACRH13. I'm having a hard time copying the 2 wifi files ubi0_1 and ubi0_2 to my local computer. I couldn't figure out how to do it on my chromebook or mac so I took a chance and just skipped that step. Everything else went well but as was warned the wifi did not work at all. I was able to flash back to the Asus firmware following the directions.

I can follow directions well but do not know code at all. Can someone explain a good way to get those files to my chromebook, macbook, or even a usb stick. The directions recommend using WinSCP and a windows machine is the one thing I don't have access too. I tried filezilla on a mac but it would not connect to the router using sftp. If I can figure a way to save those I'm sure I can get it to work.

@jasesun23 I could successfully flash my RT-ACRH13 using above steps from my mac. Thanks @LittleJohn.

Scp works just fine on mac. Shown below is the exact syntax. 1212 is the port on which I opened the SSH service on router before beginning the process.

~ % scp -P 1212 admin@ ~/Downloads/
admin@'s password:
ubi0_1                                                                                                                                        100%  124KB   3.2MB/s   00:00
~ % scp -P 1212 admin@ ~/Downloads/
admin@'s password:
ubi0_2                                                                                                                                        100%  124KB   3.1MB/s   00:00
~ %

Also, please note that the Wifi interfaces won't work immediately after flashing openwrt, but you will have to login on the WebUI and enable them (preferably after setting up the security keys).

Thank you for replying to me. I tried doing exactly what you posted but couldn't get it to work. However thanks to giving me something to work with I was able to copy the files doing it the following way. I kept it default port 22 and I just type
scp admin@ ~/Downloads/

that allowed me to copy the file. But then I read your comment on enabling the wifi. I'm new to openwrt, I have used dd-wrt before though. I think I might have been fine the first time I did it if I just enabled the wifi, which was stupid of me. I might not of even needed to save those files.

Which brings me to another question for anyone who sees this. What do you do with those saved files (ubi0_1 and ubi0_2)? Do they need to be uploaded back to the router now? Currently in the wireless overview the router list a Generic radio 0 and radio 1 and the 2 wifi ssid that I created for the 2.4 channel and 5.0 channel. Everything seems to be working so I'm wondering what I should do with the 2 files I saved to my Mac.

Again thank you for your help

You are welcome! Glad that you are are able to get it working :slight_smile:

I have not used/uploaded those files anywhere, have just kept them saved in my system if ever they are needed. Openwrt is working fine without them. Probably, they would be needed in case we brick the router or something. Not sure on that.

Have a great time!

1 Like

I actually flash back to the Asus firmware when I couldn't get it working the first time because I didn't realize wifi had to be enabled and set up. Those files are not need to revert back to original firmware.

Like you I'll save them in the chance I might need them. Need them for what I'm not sure but I'll have them.

I am trying to install openwrt on a new Asus RT-AC58U, but it fails. The Asus web admin panel "Firmware Upgrade" function refuses to flash the file given in instructions ( ). The web admin panel says:

"Invalid Firmware Upload
Firmware upgrade unsuccessful. This might result from incorrect image or error transmission, please check the model name RT-AC58U_V3 and version of firmware from support site and try again."

Perhaps I have missed a step or something?

Before trying to install the file, I ssh'd into the router, and looked around in /dev directory. I could not find there, or anywhere else, the ubi0* files. So, I ignored it and tried to install openwrt, but didn't succeed.

The firmware version is [] .

Hi. As your error message suggests, your device is an "RT-AC58U v3" which is distinct from the version this topic is about - v1. It may seem insignificant, but v1 and v3 have completely different hardware. You can't expect an image for one to work with another. v3 is very similar to v2 though. We're working on adding support for it, but we expect big problems with 2.4 GHz Wi-Fi so can't promise full support. If you're still interested, you can monitor the progress in this topic: Adding OpenWrt support for Asus RT-AC57U v2
Note: "RT-AC58U v3" is almost the same as "RT-AC58U v2" which is identical to "RT-AC57U v2".

Thanks, Alex! I'll follow v2 / v3 thread.

Hi! I just noticed that zyxmons website is partly not reachable with firefox as it states: ssl_no_cyper_overlap seems ssl for the given downloads is corrupted. I wonder if if i find the named files at another host?
well no offense but the whole website is in cyrillic and well with the recent viacom router hacks in februar this year i am a bit upset here, no blame to any involved, but i think its just that extra caution that might trigger me. anyway, download broken for me.

I had the same problem but just switched to HTTP rather than https and it worked fine. It seems that his webserver or certificate doesn't support the latest encryption standards.

FYI. I have an RT-AC58U v1 and after installing the 22.03 version using the above instructions I have managed to build a snapshot of DSA using kernel 5.15 and installed successfully.

Not tested it in anger yet but it all seems to be working fine including wifi without having to restore any of the files I backed up during the original install.

Are there still people working on the v3 version of this router?

I dont know if it helps, but i there is a GPL version of the v3 available on Asus now.