ASUS RT-AC58U crashes under heavy load/ after a while


I want to use the router as a bridge to my neighbours AIO-Cable Modem.

So i´am bridging in 5ghz. It works perfectly until my router crashes after a few minutes of heavy load. I tried different firmwares like last stable 18.06.2 and snapshot. Also i tried to change the ATH10k firmwares/kmod. On "stock snapshot" the memory was hitting about 20% free Ram after just a few minutes.

On 18.06.2 stable build it took a few minutes more to crash the router.
Strange thing is that the radio is still active after the crash.
I think the small 128Mb memory is the problem, but i read some more posts where the people have absolutely no problems with this router.

My install method was the zyxmon-method. Maybe that cause the problem?
Sorry if the questions are noobish, i´am far away to be a network/programming guru.

1 Like

This is not a problem. The memory can be occupied by buffers and cache, which will be released immediately upon demand. Run the command free to check by yourself. The key here is the second line:
-/+ buffers/cache:
There you can see the actual used and available memory.

If you verified the sha256sum of the image, I don't see why that could be a problem. Still, you can try to reflash it, verifying that the image is not corrupted after it is copied on the router.

It is not a small amount of memory and if you have not installed anything since the flashing of the image it won't be the issue.

Check on the logs for anything weird. Leave an SSH window (or console) with the command logread -f and wait until it crashes again. See if there is anything interesting there and paste it here.


I have read from those knowledgable about the IPQ40xx platform that dual ath10k radios can be a challenge with "only" 128 MB of RAM. As one example

That said, 20% free shortly after boot seems low. Are you connected to LuCI? What else are you running on the device?

1 Like

Thank you for your support trendy and jeff.
It is easy to provocate the crash, so i will try later today to put the router under full load (about 550 Mbit through 5Ghz) and do the logread -f command.

Just LuCI and SQM with LuCI support. No USB device or any special software.

Yesterday i put SQM to a maximum of 170Mbit down and 17Mbit upload. I was monitoring the Ram under full load and it stays about 38-41% free all the time. For now i have about 10 hours of uptime without any crash.

But the idea was full speed, so i will test at the evening.

After 20 hours of a stable router i was deactivating 170/17Mbit sqm and switch to full speed.
The command logread -f shows absolutely nothing before and after the crash except the login from root into LuCI that i did.

OpenWrt 18.06.2, r7676-cddd7b4c77

root@OpenWrt:~# logread -f
Tue Mar 12 16:57:23 2019 daemon.err uhttpd[1278]: luci: accepted login on /admin for root from

The command free shows the same behaviour of the ram like the status site in LuCI.
The command -/+ buffers/cache shows : -ash: -/+: not found

What i discovered was a few seconds before the crashing when i switch the site in LuCI that something like "access not possible - not enough memory" showed up - immediately after that the crash follows.

Maybe the best solution for now is to figure out how much speed i can allocate in SQM without crashing the Router.

It seems like the RAM behaviour is not like it have to be.

1 Like

It sounds like if you want to run the APs and SQM, that getting comfortable with command-line management and disabling LuCI (uhttpd or nginx, as appropriate) might be the path forward.

$ fgrep -ri "not enough memory" feeds
feeds/packages/net/xtables-addons/patches/200-add-lua-packetscript.patch:+#define MEMERRMSG	"not enough memory"

also suggests that the error message comes from LuCI use.

1 Like

It sounds very interesting i love doing stuff @the command line, but i have abolutely no clue about the command line in openwrt/linux. But you are right... the best thing would be to know what you are acctualy doing (command line).

Absolutely possible.
Just tell me, if i disable LUCI , are the settings gone or still alive?
(I think they are still active because LuCI is just a GUI)

LuCI "edits" the config files, generally in /etc/config/, so nothing should be lost.

There are wiki pages for most of the configuration. I've tried to make them searchable with "/etc/config/..." when I've needed to find them myself.

vi is probably the biggest hurdle, if you're not used to its way of editing. nano can be installed as a package and many people find it a little easier to use.

1 Like

Thank you again I appreciate it!

Hello, did you found A way to use this asus router without crash?
I will buy this model and i'm looking some info about ac58u and openwrt.

recently more and more guys here claim such nonsense. either there are memory leaks, or something wrong is going on with ath10k driver. outdoor ubiquiti devices with proprietary driver do ~500Mbps with only 64MB of RAM


It is not nonsense. Fact is that the router is crashing sooner or later because of the Ram.
Maybe it is a memory leak. But the handling of memory is triggering the issue for sure.

1 Like

No, atm it is not possible to operate the router without a crash. It heavily depends on the load you are putting on the router. With htop i can monitor how the free ram is disappearing until it crashes. Maybe the method without luci would be successfull, but i have not time atm for learning openwrt without a gui...

But The problem is only with 5ghz or on LAN large load to?

@shaka_re Did you manage to identify the root cause ? I´m planning to also upgrade my router to openwrt but I want to avoid this issue. BTW how did you backup the calibration data that is advised for this method ?

Sorry no, i brick the router (the first one in my whole career). Obviously it was running out of memory during update to openwrt to 18.04 - absolutely bricked - not even possible to recovery with asus recovery tool. I think the problem is " ubirmvol /dev/ubi0 -N linux2 " - can´t delete the volume

sorry Ryrzy - i haven´t see your post. The problem appear only under 5Ghz Wifi load

So I went ahead and pluged an USB and using dd command backup all mounts. Afterthat I used the 2 step easy method described at openwrt router page. So far is working fine, dont notice any crash but still have to do a stress test over 5G.

Cant you unbrick using the internal tx/rx pins ?


Maybe, some day if i have too much time...

hm this is strange. i have similar issues but under a custom Gargoyle build. no matter if I use P2P or download via Steam if the hardware reach the max download speed or get a big load it will easily crash then restart. weaker than my previous 1 core 400mhz custom router with less RAM...