Dynalink DL-WRX36 Askey RT5010W IPQ8072A technical discussion

I feel that the router is otherwise good, but the weak point is the ath11k radio driver, especially its closed-source firmware blob, which crashes occasionally. (a bit surprisingly, the weak point seems to be wifi clients disconnecting, which may trigger the crash.)

I have uptime varying from weeks to just a few hours.

That is actually interesting, because it would point out that newer firmware versions might be more crash-happy than the early ones. Or you just have a wifi config that just happens to be crash-proof. (I use WPA3 and 802.11r WPA2. And I noticed those crashes already in April/May with 2.9.0.1 blob versions )

2 Likes

I use 11r with WPA2, no WPA3.

2 Likes

Only WPA2 + CCMP 128 using 23.05 with 2.9.0.1 driver but stayed on 1835 not tested the new 1890

1 Like

5 posts were split to a new topic: Ash: /usr/libexec/sftp-server: not found

IMHO turn on multicast to unicast mapping on both interfaces and see if that fixes it. There are bugs in the proprietary driver blob which can cause this.

Hi mate,

Looking at utilizing VLAN on this router. Do you know if the most recent snapshot requires any patching still to enable VLAN usage? Why was the patch required? I had trouble digging info on that.

I am coming from 1900ACS which does have a dedicated switch for VLAN tagging. VLAN tagging is new to me without the use of a dedicated switch in the router.

I already have 6 VLANS deployed here at the home with 5 smart switches. I plan on continuing to use WRT1900ACS as the main. Dynalinks as AP. Really, I am just looking to segregate WiFi on the dynalink and I am not quite sure how to do that because the internal switch component is not there.

Like to get Kids Zon, Office and Guest WiFi networks up and going

@Frollic? your doing something similar I believe?

This is what I'm looking at

Defining an untagged network is as simple as using eth0 (or whichever port).
A tagged network (VLAN) is eth0.x where x is the VLAN ID. So eth0.10 would be VLAN 10 tagged on eth0.

Is it really this easy?Openwrt kernel knows to direct my vlan ID just by doing this alone?

1 Like

The patch is only important if you want to use multiple VLANs on one wifi interface as with WPA2 Enterprise for example. You can use normal VLANs with the ethernet ports just fine without it.

1 Like

Thanks mate, yes, this is what I need.
Can you suggest where I can find .ore info regarding the patch or where I can follow its progression upstream?

I was hoping to deploy a wifi network for guest, IoT and work

If your three SSIDs are all different, then they're not VLANs on a WiFi interface/network.

To use a trunk to deliver VLANs to an AP, you just configure the trunk port with eg. lan.1001, lan.1002 etc and then put each wireless network into the corresponding firewall zone with the VLAN.

I'll grab my config in a bit when I'm at a keyboard.

@cantenna here you go.

On the router:

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config bridge-vlan
	option device 'br-lan'
	option vlan '1001'
	list ports 'lan1:u*'
	list ports 'lan2:t'
	list ports 'lan3:u*'
	list ports 'lan4:u*'

config bridge-vlan
	option device 'br-lan'
	option vlan '1002'
	list ports 'lan1:t'
	list ports 'lan2:t'
	list ports 'lan3:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '1003'
	list ports 'lan1:t'
	list ports 'lan2:t'
	list ports 'lan3:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '1004'
	list ports 'lan1:t'
	list ports 'lan2:t'
	list ports 'lan3:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '1005'
	list ports 'lan1:t'
	list ports 'lan2:t'
	list ports 'lan3:t'
...
config interface 'lan'
	option proto 'static'
	option device 'br-lan.1001'
...
config interface 'GUEST'
	option proto 'static'
	option device 'br-lan.1002'
...
config interface 'iot'
	option proto 'static'
	option device 'br-lan.1003'
...etc etc...

so in this case, port lan2 is the trunk port carrying VLAN tags 1001, 1002, 1003, 1004 and 1005 down CAT6 cable to another WRX36 which has the following config:

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'wan'

config bridge-vlan
	option device 'br-lan'
	option vlan '1001'
	list ports 'lan1:t'
	list ports 'lan2:u*'
	list ports 'lan3:u*'
	list ports 'wan:u*'

config bridge-vlan
	option device 'br-lan'
	option vlan '1002'
	list ports 'lan1:t'
	list ports 'lan4:u*'

config bridge-vlan
	option device 'br-lan'
	option vlan '1003'
	list ports 'lan1:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '1004'
	list ports 'lan1:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '1005'
	list ports 'lan1:t'

config interface 'lan'
	option device 'br-lan.1001'
	option proto 'static'
...
config interface 'GUEST'
	option proto 'static'
	option device 'br-lan.1002'
...
config interface 'iot'
	option proto 'static'
	option device 'br-lan.1003'
...etc etc...

Then in /etc/config/wireless we have similar setups at both ends, thus:

config wifi-iface 'default_radio1'
	option network 'lan'
...
config wifi-iface 'wifinet3'
	option network 'GUEST'
...
config wifi-iface 'wifinet4'
	option network 'lan'
...
config wifi-iface 'wifinet6'
	option network 'iot'
...etc etc...

I hope that helps!

1 Like

I'm also getting stuck here.

Instructions say "Do a ubiformat to both rootfs partitions...", but that fails with "please, first detach mtd18..:"
When I try ubidetach:

admin@DL-WRX36:~# ubidetach -m 18
ubidetach: error!: cannot detach mtd18
           error 16 (Resource busy)

So I'm getting nowhere atm.

Any sound advice to get past this?

Searched this thread?
And are you sure you booted openwrt ?

I did search this thread (and www) thoroughly for the errors I'm getting, yes.

I also completed Part 1, Option A ending in the reboot, seemingly ok (twice, double-checked). But I do see that the original web config page is active, so perhaps I didn't boot initramfs image from usb after all.

Edit: after additional FAT32 format, I managed to boot into initramfs image from usb.

Most definitely not...

Getting my USB stick FAT32 formatted was also the most time consuming step when I did it. Windows 11 seems to offer only ExFAT and NTFS (but this might also depend on the size of the USB stick). I finally used MacOS to get it formatted properly.

Thanks to @frollic the instructions are now also quite clear and straight forward. It only took me around half an hour to get OpenWrt up and running on my DL-WRX36.

Agreed. The steps could also be updated to be specific that SSH user once on OpenWrt factory is "root" with no password. It might not be clear to everyone, as you start off with admin/askey1234.

Thank you, really appreciate itπŸ™

Your example got VLAN up an running for me on this router.

Spent alot of time on this the last 48hrs.

I've only had experience with routers that have an internal switch, which I'm still using now as my main in my setup WRT1900ACS.

Locked myself out of the router a number of times trying to set this up,... tgf for the usb recovery method.

I'm trying to get the network up as quickly as possible.

Then I'll get into to making my own builds which surprisingly I'm quite good at and looking forward to it!

Thanks again mate.

1 Like

vi /etc/init.d/LEDoff

#!/bin/sh /etc/rc.common

START=99

start() {
    sleep 2
    echo none > /sys/class/leds/blue:system/trigger
    echo 0 > /sys/class/leds/blue:system/brightness
}

chmod +x /etc/init.d/LEDoff

ln -s /etc/init.d/LEDoff /etc/rc.d/S99LEDoff

/etc/init.d/LEDoff enable

Wife was complaining... its a nice light don't get me wrong, but under the TV...

could just do it once, in /etc/rc.local ?

I tried that, didn't work for me. I suspect because of timing issue