Dumb Access Point has no internet

I didn't suggest specifically eth0.1.

That is the default for my device. I have no idea if that is the default for your device...

It's possible that eth0.1 might not be the correct one for your device. One way to know for sure is to take a copy of your existing configuration, then perform a factory reset. Once the router comes back up with the basic OpenWRT configuration, you can compare that with yours.

Thinking about your problems, a question: what is the exact OpenWrt version running in your WRT32x? Is it a master snapshot or a 19.07.x build?

The network switch config has changed for the mvebu routers like wrt3200acm and wrt32x in master, and that might be part of your problems if you blindly follow a guide.

I has a master WRT3200ACM as a dumb AP with the following:

 OpenWrt SNAPSHOT, r15980-cc2d61edc3
 -----------------------------------------------------
root@router3:/etc/config# cat /etc/config/network

...
config interface 'lan'
        option type 'bridge'
        option ifname 'lan1 lan2 lan3 lan4'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.3'
        option ip6ifaceid '::3'
        option gateway '192.168.1.1'
        option dns '192.168.1.1'

As the switch config has been changed from swconfig to DSA, the ifname line specifies the 4 LAN ports as lan1, lan2, lan3, lan4
That is right for up-to-date OpenWrt master WT3200ACM and WRT32X and is the default for a normal router there.

I do not have my wrt3200acm config for 19.07 still available, but there it would still be just one interface, eth0.1 (and wan is eth1.2)

So, the correct way would depend on the OpenWrt version.

But the quite easiest thing might be to revert to defaults, reset the router, and start reconfiguring from sractch.


Just to highlight the easiness of dumb AP, this is a script in my router that converts it from a full router to a dumb AP:

root@router3:/# cat /etc/lan-repeater.sh
#!/bin/sh
uci set system.@system[0].hostname=router3
uci set network.lan.ipaddr=192.168.1.3
uci set network.lan.gateway=192.168.1.1
uci set network.lan.dns=192.168.1.1
uci set network.lan.ip6ifaceid='::3'
uci set network.lan6=interface
uci set network.lan6.ifname=@lan
uci set network.lan6.proto=dhcpv6
uci set network.lan6.reqprefix=no
uci set wireless.@wifi-device[0].channel=48
uci set wireless.@wifi-device[1].channel=9
uci set dhcp.lan.ignore=1
uci delete dhcp.lan.dhcpv6
uci delete dhcp.lan.ra
uci delete dhcp.lan.ndp
uci commit dhcp
uci commit network
uci commit wireless
uci commit system
/etc/init.d/dnsmasq disable

Half of that is ipv6 related, but the core is just to set fixed IP, provide gateway and DNS, and turn DHCP off, (and change wifi channels and router name).

1 Like

Obviously you don't have a wired connection to the main router.
When you enter through the wireless network, try to ping 192.168.1.1, not openwrt.org.
The error bad address is returned because of the missing connection to the DNS server, also 192.168.1.1.
I believe that the problem is in the complicated configuration with VLANs included.
It's a dumb AP, try to blidge all ports as simple as possible.

Edit the network file to:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd18:c1e1:1d8d::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option gateway '192.168.1.1'
	option ifname 'eth0 eth1'
	list dns '192.168.1.1'
	option broadcast '192.168.1.255'
	option ipaddr '192.168.1.2'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '0'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 4 5 6'

and restart the network.

This is a network loop between eth0 and eth1. Don't do that.

Initial steps to get a dumb AP with wired backhaul running are:

  • Start from default configuration
  • change LAN IP to be in the same subnet but not conflict with main router, and configure LAN gateway and DNS to be the main router.
  • Disable the DHCP server on lan in DHCP configuration, both v4 and v6 (*)
  • Create wifi AP attached to lan
  • Connect a LAN port to the main router.

Once you have seen that work, then you can proceed to try to break it. The most obvious mod is to re-purpose the now unusable WAN port to be an additional LAN port. Generally that would be done with switch configuration.

  • A lot of guides say to stop and disable the dnsmasq service. I don't agree with that, because at some point you're likely to want to expand beyond a dumb AP and would need infrastructure in place-- dnsmasq process, VLAN based switching, and firewall. There's no need to destroy those setups, leave them up for later even though they don't do anything in a pure dumb AP.
3 Likes

Surely, I will want my dump AP being a Smart LAN Switch - so that I can assign any vacant RJ45 ports to any VLANs defined in the Main Router.

That would involve trunking and VLAN tagging. I've not investigated doing it with OpenWRT but, as long as the software and hardware supports it, I don't see why that shouldn't be possible.

1 Like

I have done trunking between OpenWrt and a Linux host without issues.

I expect doing so between two OpenWrt device will also work.

It does, it's just one complexity level more.

2 Likes

So I decided after reading all the replies, to factory reset the Access Point, and start again. @iplaywithtoys I checked the basic configuration after reset, and it showed eth0.1 as the interface, so I assume that means I should also use that for the Access Point?

I set up IP address, gateway, DNS etc like I did before, 192.168.1.2 for the access point, 192.168.1.1 to point to the main router etc...and again once I plugged the ethernet cable into the LAN port on the main router, I am left with the same problem as before, no internet access on the AP, and I can only access the AP if I select IP address manually, otherwise it just shows both for ethernet and WiFi that it has a self assigned IP and cannot connect. I will paste in the new configs in another reply...

I wish I knew what was causing this issue...one thought I had, I don't think it's relevant...but I ran the ethernet cable and installed the plugs myself, and I set this cable up as a straight cable not crossover...it's working perfectly to connect directly to my computer to config, and I assume this cable/setup should also be fine for connecting the main router to the AP?

Thanks all for your help!

New Network Config on AP:


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd4d:d6ef:8974::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.2'
        option ip6ifaceid '::2'
        option gateway '192.168.1.1'
        option dns '192.168.1.1'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'

New DHCP Config on AP:


config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'disabled'
	option ra 'disabled'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

New Firewall config on AP:

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option drop_invalid '1'

config include
        option path '/etc/firewall.user'

New Wireless config on AP:


config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option htmode 'VHT80'
	option country 'FR'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option encryption 'none'
	option macaddr '62:38:e0:c3:74:da'
	option ssid 'OpenWrt 5G'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option htmode 'HT20'
	option country 'FR'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option encryption 'none'
	option macaddr '62:38:e0:c3:74:d9'
	option ssid 'OpenWrt 2G'

config wifi-device 'radio2'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

The Lan section in DHCP config file is missing the ignore 1 line, and thus you likely have there an active DHCP server without proper info, and that may confuse clients.

You should also divide your debug to two parts:

  • Can you reach internet from the SSH console of the ap itself?
  • Can you reach internet from clients connected to ap?
2 Likes

Sorry excuse my ignorance, I know how to get in via terminal and send SSH commands, how would I test the internet connection from there?

No, nothing has access to internet from the AP, neither ethernet or wifi devices...

I added the ignore '1' line to the lan in the DHCP file and rebooted...

I am still having the issue with self assigned IP and having to manually access the AP via IP

In another thread, I posted a diagram to illustrate the concept of introducing a dumb AP to the network: Ping fail, okpg update fail, but wlan and AP works - #7 by iplaywithtoys - it's the first of the two diagrams in that post.

The principle is:

  • a dumb AP connects to the local network using its own LAN interface, not its WAN interface
  • the WAN interface isn't used
  • the LAN interface is configured with an address in the same subnet as the network it's connected to
  • the LAN interface should have DNS and a default gateway configured if the dumb AP also needs to talk to the Internet (e.g. to get updates) or if the dumb AP needs to be managed from another subnet. Otherwise, an IP address and subnet mask is sufficient for locally-connected management
  • be aware that the default OpenWRT out-of-the-box configuration has an active DHCP server on its LAN interface
  • the network administrator should ensure that only one DHCP server is active on the network, to reduce the risk of conflicts

If you terminated your own cable, double-check your work. It's very easy to get the pins mixed up. I've lost count of the number of times I terminated a cable incorrectly. These days I happily spend extra money to get ready-made cables to avoid that headache.

I don't know if the WRT3200acm and the WRT32x support Auto MDI-X or not. It's entirely possible that your cable might be causing problems. If at all possible, I would suggest buying one ready-made straight-through cable, and one ready-made crossover cable, and testing them both.

Thanks for the info and the thread, I am going to go and read that all carefully and make sure I'm doing things correctly.

I totally agree with the cables, and I am entirely sure there could be something I messed up on the cable, as it took me a few goes to get the cable to work...my only thought is that it works perfectly for connecting the AP to my computer for configuring but it is only when I unplug the cable and plug it into the LAN on my main router that things goes wrong, would it be expected that the cable would work ok for computer to AP access but not for router to AP?

I would have preferred to have run premade cabling but I needed 45 meters of cable to get from the router to the AP and also had to drill holes for routing which was easier without plugs on the cable...but I am now wondering if it might be the fact that it isn't a crossover cable that is causing the lack of internet on the AP?

It just seems like an Access Point shouldn't be this hard to configure and nothing I am trying is working...is there a way to test the cable from the AP or from the main router?

Ps. The fact that I can only access the AP when I switch to manual IP from DHCP on my computer, would this be related to the lack of internet? Or would this mean that I actually have 2 issues on the AP?

Really appreciate all yours guy's help, this is driving me crazy that it won't work!

If your main router is the DHCP server, but the cable (for example) is causing a problem, then that could be one reason why your computer doesn't pick up an IP address via DHCP when connected through the dumb AP.

If you're able to test the dumb AP in the same room as the router, that should at least help you identify whether you need a straight-through cable or a crossover cable, and you could then plan your 45m cable run accordingly. It would also let you check the behaviour of your computer when connected to the main router and when connected to the dumb AP.

1 Like

I give it about a 99.97% chance that crossover vs straight doesn't matter. almost all hardware auto-negotiates these days. But if the cable is improperly wired, that could be it.

Oh my goodness I can't believe I didn't think of this, thank you so much for suggesting this!

I found a 1m ethernet cable I had, and tried the AP and it is working fine! So turns out it was the cable, and clearly something I have done on the plugs at either end...it's so weird that the cable is working fine for connecting directly to my computer though.

Thank you all for the input and help getting this sorted!

Now that the AP is working, I am trying to work out if I should go with the same SSID as the main router, and try and setup fast roaming (802.11r) or if it's better to go with different SSIDs? The main router is in the office, and the AP will go in the living room, the wifi networks just overlap, so fast roaming might be good?

1 Like

I would put them in the same SSID, even without fast roaming

1 Like