DLink DIR-853 A3

sir ,as you know A3 version each device have unique admin & wifi passwords, so no admin access :frowning:

thank you for detail replies @psherman @kar200 ,let me read that link for serial console access ,i try my best to understand technicalities of console access, maybe need your further guidelines. :slight_smile:

Hi @kar200

I m trying to go from Padavan to OpenWrt using:

openwrt-23.05.0-ramips-mt7621-dlink_dir-853-a3-squashfs-factory

But it is giving me an error in padavan interface error log, which is:

Dec 26 21:47:24 httpd[568]: Firmware update: Incorrect image ProductID: OpenWrt L! Expected is DIR-853-A3.

Please provide me any solution or commands if it can be done through ssh.

Thank you.

The recommended method for OpenWrt installation is to start with stock firmware. OpenWrt isn't tested against other firmware (such as Padavan) for the installation images.

That said, I'd recommend that you should theoretically be able to follow the instructions in the git commit:

https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=6639623e75b84de5cf4a657be7a80383309e290d

My DLINK DIR-853 A3, not working properly, while using local cable net, i try to upgrade the firmware but open wrt firmware not upgrade, upgrading fail Msg is appearing please some one help to resolve the issue

My DLINK DIR-853 A3, not working properly, while using local cable net, i try to upgrade the firmware but open wrt firmware not upgrade, upgrading fail need assistance in this issue

Hi @muhsah007

Have a read through this (the padavan section). You will need some basic skills with SSH.

Use the firmware that you linked (as I checked it's not ecrypted).

K.


How do I correctly set up Ipv6 in openwrt? I have configured it, but only my dir 853 router gets an public Ipv6 address. The rest of the devices don't receive public ipv6, my dir 853 only provide a local lann IPv6. Is there any way to fix this issue?

IPv6 address comes from the LAN interface. Do you use more than 1 subnet in your network?

As long as you have the correct wan settings (which seems to be the case from the screenshot) the lan interface with the default settings should get an IPv6 /64 subnet and automatically assigns ip addresses to the LAN hosts.

EDIT: Just realised you have a 172.16.0.x IP on your host which is not the default IP from openwrt. Did you change it (which shouldnt matter for IPv6) or are you using a different AP?

If you have an AP which is not connected in bridge mode then the IPV6 address won't go through to the host and the wan interface of the AP will get the IPv6 (not sure if it makes sense)

You can set up IPv6 Relay: just set designated master and relay for all three options on the WAN interface. On LAN interface, you need to again set relay for the three options.

But without SLAAC, Android and Chromebooks don't work, so I followed this guide and IPv6 has been working fine since:

1 Like

Thank you, finally it got work

8 posts were merged into an existing topic: Router Bootlooping

Is there anyone that can help me unbrick dlink dir 853

i am using cp2102 to unbrick the router and still unsuccesful after trying every video and tutorial on the internet. its been 2 months and still router is in bootloop

when i try with cp2102 getting gibberish in the putty terminal

plzz help if anyone can help

set the port to 57600, 8N1
if still not working show a picture of the adaptor your have
I'm thinking you are some how inverting something

it looks like a plain ttl cable
what did setting the port speed to 57600 do ?

1 Like

thanks brother

it worked.

but i dont know what to do next to load the firmware. is there any tutorial or video you can refer me to.

i have decrypted stock firmware. but how will i load it to router

no i don't have a direct link for this device in your exact caes

you need to setup a tftp server with the file on it
I use "SolarWinds-TFTP-Server" for windows
remember to disable your firewall if it fails

you will need to install tftp server
will need to setup pc's ip fixed address matching in router
add factory image to flash into it's share folder
you may change it's name to make it easier on the router end
get router to use option 2 by hitting 2 keep while booting
follow prompts

2 Likes