DLink DIR-853 A3

Could you please guid me with the steps?

When I try from CLI of router no commands were working. It says command not found ( eg apt-get)

Hi,

have a look at this post. Make sure you use the correct file as there is no check/safeguard in this process.

Please make sure you use the correct file. This process does not have any check and will just flash whatever you provide in the command line.

The file you want to use is this one:

https://downloads.openwrt.org/releases/23.05.0-rc4/targets/ramips/mt7621/openwrt-23.05.0-rc4-ramips-mt7621-dlink_dir-853-a3-squashfs-factory.bin

That worked.. you are the best @kar200

One suggestion I would like to see in the future is when we do upgrading, WiFi radios are disabled status. Also not sure which one is 2.4 and 5 Ghz. Good someone fix it in the future

Glad to see it worked.

That's just because you flashed from Padavan which stores the settings differently from Openwrt. Next time you upgrade you will use the nomral sysupgrade file and if you choose to keep the config your router will upgrade the firmware and keep the same config

@kar200
i am using OpenWrt 23.05.0-rc4 on dlink-dir-853-a3 i am facing Internet speed issue on 2GHZ wifi... but on 5GHZ working full speed internet.... before this OpenWrt i was using stock FW and its give me full speed on 2 GHz.... Do you have any solution or can you give me a stock FW so i can go back on stock FW

I missed your we.tl upload every time and I finally got to execute your instructions in this post, but I'm getting Input File openwrt-dir-853-enc.bin could not be opened. errors.

$ ./dlink-sge-image ~/Downloads/openwrt-23.05.0-ramips-mt7621-dlink_dir-853-a3-squashfs-factory.bin openwrt-dir-853-enc.bin
Input File openwrt-dir-853-enc.bin could not be opened.

Any insight wh that might be the case? Just in case this might be some sort of dir permission error or something, I tried with sudo to the same results.

Did you try to upgrade to the latest version of 23.05 (non RC) I don't think it'll make a big difference but it might be worth a shot.

Also look for devices with similar wireless card (MT7615DN) and see what kind of settings other people are using that might be working for them.

What kind of speed are you getting on 2Ghz and what were you expecting?

It seems I posted and incorrect command line. I forgot to add the device model.

This is with the latest stable openwrt for DIR-853. You can skip the build part. I will update the other post as well.

git clone https://github.com/s-2/firmware-utils.git
cd firmware-utils
git checkout dlink-sge-image_2k23
cmake .
make dlink-sge-image
wget https://downloads.openwrt.org/releases/23.05.0/targets/ramips/mt7621/openwrt-23.05.0-ramips-mt7621-dlink_dir-853-a3-squashfs-factory.bin
./dlink-sge-image DIR-853 openwrt-23.05.0-ramips-mt7621-dlink_dir-853-a3-squashfs-factory.bin openwrt-dir-853-enc.bin
2 Likes

Thank you for the correction. After the encryption, the flashing finished without any incident. I'll check it out more extensively later but for now, everything seems to be working fine.

I also want to reiterate, the YouTube video posted a while back is misleading because it skips over encrypting the squashfs-factory firmware. Without doing this, the stock frmware updating page will just error out with upgrade failure message. The download link he provides is also the regular builds available on OpenWrt, which are of course not encrypted. Since he redirected a comment about the error to this thread, to anyone coming from there: the last post is the solution, you need to follow the instructions to build the tool to encrypt the factory flashing image.

Here are the encrypted file to use on the factory D-Link web UI directly: MediaFire (I think link is live for 14 days?) and Anonym File (they say it's indefinite, but who knows)

How I generated it, using factory image on firmware selector and s-2's tool:

$ ./dlink-sge-image DIR-853 ~/Downloads/openwrt-23.05.0-ramips-mt7621-dlink_dir-853-a3-squashfs-factory.bin ../openwrt-23.05.0-ramips-mt7621-dlink_dir-853-a3-squashfs-factory_enc.bin

vendor_key: c05fbf1936c99429ce2a0781f08d6ad8
payload_length_before: 9568256

digest_before: bd56cd7db4b3c8cae52eed13f0a63168eb5fc0796c51d3564a7bb4525cafff42f152081047ae9bdc46f5d5784f41cca5d7971f94229b2af1af93b54b007f2bdb
digest_vendor: 8aee6af703f63414a5487b94999298f7d6bc14200b755213619d3255890d73591aa1348d320b92aef306059168e5d7dfcac4be601d364efadc0c430d98c274f1
digest_post: 5b52bb826b6146450f8747b59fac34ec72924a80ef7f0365c0e73ddab49fd5b1ca5f98cc21d5ce566aebb28b2d3686a06342d72bc1449fb648650be3aa0b2818
signed before:
0d364db64c62d4241035b0ad74a864e45bb211a0980deb2022784c3f2676ff11ab09365996b92b494b7fa9d24c93b905d57e39c3cd37901a3e43fbd43ed77186b51605be57bd73fbcb03e7b4c898990a48644d25f501410053af517debb44b6d7d66927168d68a54ad20d137eeb3f84f9a9ad889f45be1bc1fbf503adf510c67040d0f1036521710748dc252b1463de9b572628ccd59055347e0e10709dfcabae993e6adfcc85164f91a18ac2aaece9f58aa2f6473eb2a9986d9e16aaefd62fb68d4c2ffacddcedcf73cd340c4be900616b1a2de700cc08d46f4045a1e780b7d1b6eab054c75ff182159280c5fe56ea914aba8b2757c698af72ac928a3afbff8075b3fcefec963d5b6c09b85c9089b073bf39a5680c3e01e1c589f353ff408447201a19f759624a519438884cf78088c78ead8eb9545c7e70d5604e35d281fe7a0ebcd8abd738e9f84d711c768e96845f30bb38d15713349efa2a30057b4cd9ffb52aa3e4e014e3961253b935ed3a111e07b5aa33b6804edfff931425a88cfcb8389ed0c6e57d1526ed697e4bf6fda8bb68e05ea65c598225e000fc5881b4237dd91e09d5c3069255f85d2e45e779904d5822a127e42b95c58c084e72c1dd200f0784e71bf9da24ecf6a2a0c743828d2168ff5be82270a18a1623d3f9670075cade0dfc49a71ae5388af22612559190475b97976f685de4c62353cbd66b413ac
signed post:
224a82c8183bb3feedd06335271f9d5fecfcde00a700c9b95c0e1d4e0ce0b0b0441d1238e80fb13b67ea32ff68e0b977b8ab9d52bb85c4fdedcadfd5890f2fbd4af49431843d80209dac732294c4568423c115427df1c46d7c77e7c0cb75d89aa5473243e3fc4285aedc836dbc35e5d1243ca477b5890dca77ceb3f0409c112194d9ab60f69298a2e7cceab9c585e1c9e005dc063742d25506918ac054341153248c151b3414eb7262d19e8a3103477394660f8b0bfa968bd7cd95f6be4f4ebc6a1c1f027e5eb35c73df8771a6258104dd55a2b2f974fbcd09eb70e2b876a1e57ca37abe364dc2c69ae753f1b7f17394dfe62e5389fb06db7f7fd62d7d222bf2a68285079f8ff12f0e40b0199a9ad9470a2f034e9d4062ba396288fdf047dd95912df23c62650ab70f6473b617ea6abe1720053b88eaac957d46c258ac863abce3288b3fd0710435f7034e05187e94eb04750dd8f31e71abc366e3e78a85d7f93e22156c09d6a846804512ac40ddb39ed9349c02bdb9407a34af180f4b026174afa3a59211150bd34e6817796532acb73610f2ec58fe5a2ee6ba62a287b4c4b3ac6792f695e617a2e3fb2c4e78e306b8da7c80d2a808ae969f4fbeb137a9affbcc4ead69a646a7623aa9ba7da3c952f4efac2db1fe87a29141c777d5e783b628260decd67355b840b3c43e324099151480403c1bde148009404184907fb57ccd

Apparently s-2's patch to the firmware-utils got merged, so maybe the images on firmware selector will already be available in its encrypted form. But until then, you can use the links here to get it without having to build the tools yourself.

Hi kar200
should I try and include the DIR-853-A3 in my PR with the NOR flash devices ?
ill need someone else to test this one

1 Like

Hi @Lucky1 ,

Sorry for the late reply I was away. I saw that it was merged already. Thanks for including the A3 it would make it much easier now for everyone to just download the factory image and flash it directly from the web interface.

I am not sure I understand your question but I don't think there is an A3 version with NOR flash (they are all NAND).

K.

1 Like

This is great news. But is there a way to easily tell when the images on firmware selector is going to be built encrypted?

I just added it
it's the only NAND one
tho I didn't get feedback on if it worked ?
all the other NAND ones need a private key

from the next version the
Recovery images are for the recover interface and
Factory images are for the D-link web interface
lots of the NAND ones will now just have a Recovery file
I'm hoping that recovery comes up in the firmware selector

Unfortunately I don't have the device to test it although it seems it worked before with the tool provided by @s_2.

I guess we will find out. The good news is that it either woks or does not (it should not brick any device).

Tanks again!

1 Like

The new snapshots seems to now build both images. From what I see there is an extra image file (recovery) being built.

Hopefully someone can test this image to confirm that it is indeed working

Firmware selector also seems to work.
Recovery = non encrypted
Factory = encrypted

hexdump -C openwrt-1f84c006b7d2-ramips-mt7621-dlink_dir-853-a3-squashfs-factory.bin| head
00000000  53 48 52 53 00 96 00 00  00 96 00 10 67 c6 69 73  |SHRS........g.is|
00000010  51 ff 4a ec 29 cd ba ab  f2 fb e3 46 2d ba 9d a7  |Q.J.)......F-...|
00000020  36 21 0c 05 30 83 db bf  2f 03 db a5 b7 50 b3 31  |6!..0.../....P.1|
00000030  b8 bb 26 5c b9 3a 17 82  9b fa 19 4c 3f 91 34 43  |..&\.:.....L?.4C|
00000040  a3 fe 74 8d af 5b 77 28  20 a3 cf 6a db 4a 4d c6  |..t..[w( ..j.JM.|
00000050  67 5b c8 e7 1b 2b 95 31  91 35 f9 60 4e 4b 89 d3  |g[...+.1.5.`NK..|
00000060  40 2e fb 5c f5 a0 a3 a9  98 e7 b7 1d b3 26 7d e8  |@..\.........&}.|
00000070  5b c8 52 84 80 21 4b 10  43 7b 23 7e 0d e2 9e 37  |[.R..!K.C{#~...7|
00000080  60 93 76 e5 c3 5a ff 42  73 80 46 78 e5 f4 3e da  |`.v..Z.Bs.Fx..>.|
00000090  a0 5d 4d 93 17 59 58 f9  ae 0e 0f 42 86 4a 09 1e  |.]M..YX....B.J..|
2 Likes

i am facing problem to admin login & wifi DIR853-A3 stock FW , as i lost/missing my router Device info Label (Sticker). i am beginner so any easy way to recover it ? thanks

If you have admin access to the device from the web interface then you can install openwrt - login as admin - download the partition that contains the password (sorry cant recall which one) and then use a Hex editor to read the password.

If you lost admin access then no easy way. You will need to use the console access.

1 Like

The flashing instructions can be found in the git commit -- it involves connecting the serial console referenced by @kar200, and it doesn't require the stock firmware's password. Then you can install OpenWrt and you'll be in known territory for the default state (username root, no password, wifi disabled -- connect via ethernet).

You won't be able to login to the stock firmware if you don't have that password, so unless it is known by the person from whom you got the device, you cannot do anything other than consider flashing to OpenWrt or e-cycling the device.

https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=6639623e75b84de5cf4a657be7a80383309e290d

1 Like