CANT USE A MediaTek Ralink RT5370 dongle

Hello Everyone! I have been trying to use OpenWrt on my Raspberry Pi 3, following this tutorial: https://www.youtube.com/watch?v=jlHWnKVpygw&t=1419s. But when trying to "activate" my wifi dongle, it doesnt recognize it apparently.

Drivers installed:
opkg install kmod-rt2800-lib kmod-rt2800-usb kmod-rt2x00-lib kmod-rt2x00-usb kmod-usb-core kmod-usb-u
hci kmod-usb-ohci kmod-usb2 usbutils openvpn-openssl luci-app-openvpn

When i type "lsusb":
Bus 001 Device 004: ID 148f:7601 MediaTek 802.11 n WLAN
Bus 001 Device 003: ID 0424:ec00
Bus 001 Device 002: ID 0424:9514
Bus 001 Device 001: ID 1d6b:0002 Linux 5.10.138 dwc_otg_hcd DWC OTG Controller

When i type " dmesg":
[ 842.989301] usb 1-1.2: new high-speed USB device number 4 using dwc_otg
[ 843.130486] usb 1-1.2: New USB device found, idVendor=148f, idProduct=7601, bcdDevice= 0.00
[ 843.143954] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 843.154041] usb 1-1.2: Product: 802.11 n WLAN
[ 843.161103] usb 1-1.2: Manufacturer: MediaTek
[ 843.168047] usb 1-1.2: SerialNumber: 1.0

Error:
root@OpenWrt:~# ifconfig wlan1 up
ifconfig: SIOCGIFFLAGS: No such device

I havent found any solution. Many said that this is a drivers issue, but if im not mistaken, the drivers i installed are the proper ones. Has anyone encountered this problem? Or may have some idea of what can be the solution?

I would really appreciate the help! Thank you all in advance.

Thanks for the fast response! I installed the kmod-mt7601u and mt7601u-firmware, rebooted and reconnected my dongle, but there is no changes. i type "ifconfig wlan1 up" and i get the same error:

root@OpenWrt:~# opkg install kernel kmod-mac80211 kmod-usb-core mt7601u-firmware
Package kernel (5.10.138-1-61f39ce703e70e6060e1b0be43bb7300) installed in root is up to date.
Package kmod-mac80211 (5.10.138+5.15.58-1-1) installed in root is up to date.
Package kmod-usb-core (5.10.138-1) installed in root is up to date.
Package mt7601u-firmware (20220411-1) installed in root is up to date.

root@OpenWrt:~# lsusb
Bus 001 Device 005: ID 148f:7601 MediaTek 802.11 n WLAN
Bus 001 Device 003: ID 0424:ec00
Bus 001 Device 002: ID 0424:9514
Bus 001 Device 001: ID 1d6b:0002 Linux 5.10.138 dwc_otg_hcd DWC OTG Controller

root@OpenWrt:~# ifconfig wlan1 up
ifconfig: SIOCGIFFLAGS: No such device

Are you sure the interface is called wlan1?

1 Like

Good question! Following the tutorial, the wireless and network configurations are these:

config/wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/3f300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option channel '7'
        option band '2g'
        option htmode 'HT20'
        option disabled '0'
        option short_gi_40 '0'
        option cell_density '0'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'
        option ssid '<<My network>>'
        option encryption 'psk2'
        option key '<<my network password>>'

config/network:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix '<<sensitive?>>'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '<<a private ip i set>>'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option force_link '1'

config interface 'wwan'
        option proto 'dhcp'
        option peerdns 'o'
        option dns '1.1.1.1 8.8.8.8'

config interface 'vpnclient'
        option proto 'none'
        option device 'tun0'

Im so sorry if i am not able to give much info, i am new to openwrt! Do i have to create a wlan1 interface in the network/wireless config?

is this installed? rt2800-usb-firmware

1 Like

Hello! How are you? It seems that it is!

root@OpenWrt:~# opkg install kmod-rt2800-lib kmod-rt2800-usb kmod-rt2x00-lib kmod-rt2x00-usb kmod-usb-core kmod-usb-uhci kmod-usb-ohci kmod-usb2 usbutils openvpn-openssl luci-app-openvpn nano
Package kmod-rt2800-lib (5.10.138+5.15.58-1-1) installed in root is up to date.
Package kmod-rt2800-usb (5.10.138+5.15.58-1-1) installed in root is up to date.
Package kmod-rt2x00-lib (5.10.138+5.15.58-1-1) installed in root is up to date.
Package kmod-rt2x00-usb (5.10.138+5.15.58-1-1) installed in root is up to date.
Package kmod-usb-core (5.10.138-1) installed in root is up to date.
Package kmod-usb-uhci (5.10.138-1) installed in root is up to date.
Package kmod-usb-ohci (5.10.138-1) installed in root is up to date.
Package kmod-usb2 (5.10.138-1) installed in root is up to date.
Package usbutils (014-1) installed in root is up to date.
Package openvpn-openssl (2.5.5-1) installed in root is up to date.
Package luci-app-openvpn (git-22.025.78197-18b1130) installed in root is up to date.
Package nano (6.4-1) installed in root is up to date.

opkg update
opkg install rt2800-usb-firmware

Firmaware installed, but no changes :frowning:

root@OpenWrt:/# opkg install rt2800-usb-firmware
Package rt2800-usb-firmware (20220411-1) installed in root is up to date.

root@OpenWrt:/# lsusb
Bus 001 Device 005: ID 148f:7601 MediaTek 802.11 n WLAN
Bus 001 Device 003: ID 0424:ec00
Bus 001 Device 002: ID 0424:9514
Bus 001 Device 001: ID 1d6b:0002 Linux 5.10.138 dwc_otg_hcd DWC OTG Controller

root@OpenWrt:/# ifconfig wlan1 up
ifconfig: SIOCGIFFLAGS: No such device

As posted in the other thread, rt2800 has nothing to do with this wifi dongle.

(the wifi interface name appears to be wifinet1)

Did you generate the config file yourself?
the content should have been generated by openwrt, once the wifi stick had been discovered.

It says in the thread linked to in the other thread, 7601 doesn't appear to support AP mode.

kmod-mt7601u

After installing the 7601u kmod and firmware, reboot with the dongle plugged in and you should get an additional device added to /etc/config/wireless.

1 Like

No, the configuration file was created by openwrt! If im not mistaken radio0 and the wifinet 1 are related to the wifi adapter from the pasberry pi itself, but not the dongle (since i put in the dongle, none of the configuration files has changed). The primary purpose of the dongle is to act as an access point. Im sorry for my lack of knowledge, but does "doesn't appear to support sta mode" mean that this cannot be done?

Correct, but the info might be outdated, trial and error.

1 Like

It did! I show you:

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/3f300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option channel '7'
        option band '2g'
        option htmode 'HT20'
        option disabled '0'
        option short_gi_40 '0'
        option cell_density '0'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'
        option ssid '<<My network>>'
        option encryption 'psk2'
        option key '<<my network password>>'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/3f980000.usb/usb1/1-1/1-1.2/1-1.2:1.0'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio1'
        option device 'radio1'

so that would be it? Or do i have to type "ifconfig wlan1 up"?

So thanks @frollic and @mk24 I solved your same problem with the same dongle, but I'm noticing that it doesn't work as an AP it can't generate the network to connect.

That is excatly what it is happening to me now. I maneg to configure it in some way, but it is not appearing:

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/3f980000.usb/usb1/1-1/1-1.2/1-1.2:1.0'
        option channel '11'
        option band '11g'
        option htmode 'HT20'
        option disabled '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'Hogwarts'
        option encryption 'psk2'
        option key 'harry2022'

In gui:

Does this mean that this dongle cant be use a an access point? If so, what other chipsets are 100% guaranteed that will work?

it appears to me, have you tried to go down with the arrows?

after ifconfig I notice something strange in the list:

root@OpenWrt:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr B8:27:EB:06:41:B7
          inet addr:10.19.11.1  Bcast:10.19.11.255  Mask:255.255.255.0
          inet6 addr: fd58:a8dd:c035::1/60 Scope:Global
          inet6 addr: fe80::ba27:ebff:fe06:41b7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:14710 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14021 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2439663 (2.3 MiB)  TX bytes:7736623 (7.3 MiB)

eth0      Link encap:Ethernet  HWaddr B8:27:EB:06:41:B7
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:14721 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14024 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2440578 (2.3 MiB)  TX bytes:7881713 (7.5 MiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2709 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2709 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:215747 (210.6 KiB)  TX bytes:215747 (210.6 KiB)

wlan1     Link encap:Ethernet  HWaddr B8:27:EB:53:14:E2
          inet addr:192.168.178.39  Bcast:192.168.178.255  Mask:255.255.255.0
          inet6 addr: fe80::ba27:ebff:fe53:14e2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7389 errors:0 dropped:2090 overruns:0 frame:0
          TX packets:4158 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2939431 (2.8 MiB)  TX bytes:859119 (838.9 KiB)

instead of 'lo' there should be wlan0 and then I don't understand this 'loopback'

in gui: