RPi 3 + Mediatek RT5370 USB wifi adapter

Hello everyone, ask for your help. I have already read various posts in this forum but unfortunately without success.
The RPi3 does not see my Mediatek RT5370 wifi adapter I have manually installed various drives also from the kmod-rt2800-usb family but without success.
Can you help me? Thanks

what does lsusb list it as ?

Thank you frollic,

here is the list:
root@OpenWrt:/etc/config# lsusb
Bus 001 Device 004: ID 148f:7601 MediaTek 802.11 n WLAN
Bus 001 Device 003: ID 0424:ec00
Bus 001 Device 002: ID 0424:9514
Bus 001 Device 001: ID 1d6b:0002 Linux 5.10.138 dwc_otg_hcd DWC OTG Controller

type or paste code here

That is not a RT5370, it is an MT7601u chip. Use kmod-mt7601u and mt7601u-firmware.

Thank you, I also saw frollic's link,
I tried to install kmod-mt7601u and mt7601u-firmware, but it gives me an error.

Unknown package 'kmod-mt7601u'.
Collected errors:
 * opkg_install_cmd: Cannot install package kmod-mt7601u.

maybe I am doing something wrong in the installation string?

Sorry, but I am a beginner

The list of available packages is in RAM, so you have to run opkg update to download a new list after any reboot. Then you can use opkg install.

The other reason might be that you are using a version from before MT7601 support was added.

Perfect it worked, thank you very much @frollic and @mk24

I will continue with the configuration.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.