Can't access to LuCi router configuration page

Hello guys, first of all i have to say that im pretty new to all this stuff, i just managed to install Lede with a LuCi interface on my TP-Link Archer MR200 using Heinz configuration from this topic: https://forum.archive.openwrt.org/viewtopic.php?id=64293&p=2#p342280 I was able to do that by tftp server recovery or something like this. I wanted to do that mainly to fight with bufferbloat so after installing it i wanted to access to the LuCi configuration to install luci-app-sqm but im not able to that cuz it says "This site can't be reached" . I have also noticed that it is only caused by connecting WAN cable, without it ofc i don't have an internet but i can access LuCi configuration. Also i noticed that sometimes my internet is gone for like 15 seconds and in this 15 seconds i can also access 192.168.1.1 site but after 10-15 seconds, site is blocked again. All i want is to install SQM on my OpenWrt but i can't do that without internet connection, if you have any suggestions please tell me.

It is possible that another device in the network is grabbing 192.168.1.1 nuking the interface. Try changing the IP to something else that's unlikely to be taken and try again. You can do this through Interfaces > LAN

1 Like

You mean in LuCi panel or somewhere in Windows? If you mean LuCi panel, i already changed it to 192.168.2.1 but it's still not working. It is something like, as longest as i don't have an internet access panel is working.

Please post here the output of the following command, all in one line
cat /etc/config/network; cat /etc/config/firewall; cat /etc/config/wireless ; cat /etc/config/dhcp ; ip -4 addr ; ip -4 ro ; ip -4 ru

I will have really dumb question, where the hell do i put all of this commands? Cuz i see lot of posts about commands but for real im not sure where should i put that..

https://openwrt.org/docs/guide-quick-start/sshadministration

3 Likes

So first of all i tried to access both ssh root@192.168.2.1 and ssh root@192.168.1.1 like in guide but this is what i get:

So i tried to put your command instead and this is what i get:

Nope, first you'll have to connect to the device. Before connection it will ask you for password. After you connect you can issue the commands. Otherwise it is like running them on your windows, which is not compatible.

If necessary unplug the WAN cable first.

Finally use copy-paste on the window to show us the output, don't use screenshots.

4 Likes

Could you remove the internet cable (the one coming form the wall or the modem) off the router and see if you have access?

I suspect that you plugged the internet cable in a LAN port or something.

2 Likes

You can also try to connect using IPv6-address.
And even if DHCP-server is down, you can use IPv6 LLA:
https://en.wikipedia.org/wiki/Link-local_address#IPv6

1 Like

Yeah that was because of the WAN cable connected, btw cuz i didn't mentioned it eariler, i have 4 ports in my router, 3 LAN and 1 WAN/LAN(that i normal i guess) and i also have something like POE adapter which is connecting cable from antenna (i have radial internet) to the router and there is LAN cable coming from this adapter and im not sure if it's normal so i just wanted to give you that info. Back to ssh, this is the output from your command:

root@lede:~# cat /etc/config/network; cat /etc/config/firewall; cat /etc/config/wireless ; cat /etc/config/dhcp ; ip -4

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd3a:ee54:b362::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr 'c0:25:e9:7e:c1:81'

config interface 'wan'
        option ifname 'usb0'
        option proto 'dhcp'

config device 'wan_dev'
        option name 'usb0'
        option macaddr 'c0:25:e9:7e:c1:82'

config interface 'wan6'
        option ifname 'usb0'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 6t'

config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option src_ip           fc00::/6
        option dest_ip          fc00::/6
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# include a file with users custom iptables rules
config include
        option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  00:11:22:33:44:66
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        80
#       option dest                     lan
#       option dest_ip          192.168.16.235
#       option dest_port        80
#       option proto            tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#       option src              wan
#       option src_dport        22001
#       option dest             lan
#       option dest_port        22
#       option proto            tcp

# allow IPsec/ESP and ISAKMP passthrough
config rule
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT

### FULL CONFIG SECTIONS
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port 80
#       option dest             wan
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp
#       option target   REJECT

#config redirect
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port         1024
#       option src_dport        80
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp
config wifi-device  radio0
        option type     mac80211
        option channel  11
        option hwmode   11g
        option path     'platform/10180000.wmac'
        option htmode   HT20
        # REMOVE THIS LINE TO ENABLE WIFI:
        option disabled 1

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     LEDE
        option encryption none


config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
3: usb0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN qlen 1000
    inet 192.168.225.198/24 brd 192.168.225.255 scope global usb0
       valid_lft forever preferred_lft forever
5: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.2.1/24 brd 192.168.2.255 scope global br-lan
       valid_lft forever preferred_lft forever
default via 192.168.225.1 dev usb0  src 192.168.225.198
192.168.2.0/24 dev br-lan  src 192.168.2.1
192.168.225.0/24 dev usb0  src 192.168.225.198
192.168.225.1 dev usb0  src 192.168.225.198
0:      from all lookup local
32766:  from all lookup main
32767:  from all lookup default
root@lede:~#

`

Please edit your post and place the output in a codebox using the </> icon.

Also, have you flashed an official sysupgrade to version 18.06.2 at this point?

The thread you refer to is over 3 years old

1 Like

Does it changed anything actuallyXD?

Ummmm...

  • If you're referring to the codeboxes, yes, as Post No. 12 is huge, un-formatted and doesn't show comment marks properly.
  • If you're referring to the sysupgrade, yes again, as a custom build is not supported - nor can we guarantee it actually has LuCI.
1 Like

That might be good idea cuz no, i haven't.

Be sure not to save settings when making an upgrade between versions.

1 Like

Btw i've done that and imo nothing changed but maybe im doing something wrong

Or something changed and im just blind :slight_smile:

What have you done?

Screenshot%20from%202019-04-09%2008-16-01

  • or upgraded the device to version 18
1 Like

Emm i mean i've put this in this thing: </> and it's still huge