Can use OpenWrt as a managed Switch?

As in the tittle : Can use OpenWrt box as a managed Switch ?

2 vlan and 2 switches for multicast TV

Yes, it can.

3 Likes

Assuming you're talking about a device with an integrated switch, yes. I've done things like this. Recommend that all your switches enable STP, including on the OpenWRT devices.

If you're talking about a device with a bunch of separate NICs, such as an x86 with a network adapter or four, OpenWRT will do this as well (as will any Linux) but using bridge-utils, and the result has some hairy edge cases, e.g. at boot and init time, that you probably want to avoid.

So yes if it's a consumer router with a switch, maybe not not advised otherwise.

1 Like

Thanks Cheddoleum & Trendy
*
Some informations:
LiveBox 5 is France Orange BOX with fiber directly connected inside
All the boxes in France will therefore all be without ONT in anticipation of 10 Gbits
So I can have 2 download links of 1 Gbits to 2 computers connected to two different LAN sockets as well as the telephone and television. For upload i have 650 Mbits.
The problem is to have internet and multicast television at the end of a very long single cable embedded in the walls.
The box TV HD+ has also WIFI but it is too far away and even with a repeater it works very poorly
the only solution is therefore that of the image
For the moment I use for TV a long cable of more than 50 meters which runs through the house in a garland and my wife is not very happy.
*
I am expecting in a few days three NETGEAR Plus GS108Ev3 managed switches which should solve the problem but i'm 75, retired and have a lot of time to spare.
With COVID in France we are almost prisoners at our home with confinement, authorizations so as not to be able to travel very far at home under penalty of a fine of 135 euros, ... !!!!

As I have 2 * XIAOMI R3G, 2 * WR1200JS & 2 * MiWifi D2 I thought to use them with OpenWrt (that would do in addition to WIFI)

You are aware that the rather new realtek target in OpenWrt supports a couple of managed switches?

Be also aware that the ARX5308 has been EOL for about four years now and is in rather desperate need of replacing with something that still has active security support.

2 Likes

Last configuration, run fine with TV Orange:

WR1200JS as a master managed switch with WIFI
A Netgear GS108EV2 with 6 * Lan for PC

Also as this: WR1200JS = router + managed switch

I'm interested in this - I'd love using OpenWRT on a managed switch. Do you know if the specific supported Realtek hardware targets are documented on the supported hardware page?

The target is still very new, so documentation is lagging behind.

Supported devices:
https://downloads.openwrt.org/snapshots/targets/realtek/generic/
(careful with the D-Link devices, for those the exact h/w revision matters, as they've used Marvell, Broadcom or Realtek depending on that)

https://biot.com/switches/
provides some more generic overview of potentially supportable devices - not all of them are already supported, some of them never will be (not enough flash/ RAM).

4 Likes

my network file`


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd44:0fde:a8b4::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.0.1'
	option gateway '192.168.0.1'
	option delegate '0'
	list dns '192.168.1.1'
	list dns '8.8.8.8'

config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr 'd4:5f:25:eb:09:84'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'static'
	option ipaddr '192.168.1.2'
	option gateway '192.168.1.1'
	option delegate '0'
	list dns '192.168.1.1'
	list dns '8.8.8.8'
	option netmask '255.255.255.0'

config device 'wan_eth0_2_dev'
	option name 'eth0.2'
	option macaddr 'd4:5f:25:eb:09:85'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '6t 2t 3t 4'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '6t 0'
	option vid '2'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '100'
	option ports '1 2t 3t'

config interface 'TV'
	option proto 'none'
	option ifname 'eth0.100'


Tested also with a XIAOMI R3G V2 used with a spi 8 pins flash 16M & WR1200JS firmware

Only 3 ports ... but sufficient