Help getting Telenor T-we IPTV working with WRT3200ACM

I've been on this for a few days now, trying out different solutions in the forum. I've still had no luck.
Short story is we finally got Fiber access in the middle of nowhere and as such IPTV followed with the package to get the cable in the house.
From the information from Telenor IPTV requires multicast-IGMPv3 and UPnP-IGD to work, UPnP is for fancy stuff like watch from the beginning and week-progam archive etc. The T-we service doesn't run with separate VLAN id.
First order of business should be to get Multicast working and i should receive live tv image, then work on UPnP to get all stuff working.

Now the setup on my WRT is pretty plain, I've not made many changes to the default. I'm hoping more experienced users can help me figure this out. OpenWRT version is 21.02.1

here is my network conf

>  GNU nano 6.0                          /etc/config/network                                     
> 
> config interface 'loopback'
>         option device 'lo'
>         option proto 'static'
>         option ipaddr '127.0.0.1'
>         option netmask '255.0.0.0'
> 
> config globals 'globals'
>         option ula_prefix 'fd10:8645:aed4::/48'
> 
> config interface 'lan'
>         option device 'br-lan'
>         option proto 'static'
>         option netmask '255.255.255.0'
>         option ip6assign '60'
>         option ipaddr '192.168.0.1'
> 
> config interface 'wan'
>         option device 'wan'
>         option proto 'dhcp'
> 
> config interface 'wan6'
>         option device 'wan'
>         option proto 'dhcpv6'
> 
> config device
>         option name 'br-lan'
>         option type 'bridge'
>         option multicast '1'
>         list ports 'lan1'
>         list ports 'lan2'
>         list ports 'lan3'
>         list ports 'lan4'
> 
> config device
>         option name 'lan1'
>         option multicast '1'
> 
> config device
>         option name 'eth0'
>         option multicast '1'
> 
> config device
>         option name 'lan2'
>         option multicast '1'
> 
> config device
>         option name 'lan3'
>         option multicast '1'
> 
> config 
> option name 'lan4'
>         option multicast '1'
> 
> config device
>         option name 'wan'
>         option multicast '1'
> 
> config device
>         option name 'wlan0'
>         option multicast '0'
> 
> config device
>         option name 'wlan1'
>         option multicast '0'

My igmpproxy conf file


config igmpproxy
        option quickleave 1

config phyint
        option network wan
        option zone wan
        option direction upstream
        list altnet 0.0.0.0/0

config phyint
        option network lan
        option zone lan
        option direction downstream

From the basic guide https://openwrt.org/docs/guide-user/network/wan/udp_multicast this should work, but so far I've not been able to run IPTV trough my WRT3200ACM.

Look my old post: but without DSA

After convert / use vlan for DSA

Requiert a managed switch or it can also be another OpenWrt 2 used as a managed switch

@anon69880279 Thanks for your reply. I migth try this solution at some point, but it does seem a bit overkill for my use to split up into vlans. Also Telenor IPTV dosnt use vlan and should work fine without.

I migth however have a new hint as to what can be the issue here. from a difrent thread i decided to run a debug and recived this result.

root@Gnaa:~# igmpproxy -d -v /etc/igmpproxy.conf 
MC-Router API already in use; Errno(98): Address in use

also i previusly only focused on live-tv i have noticed that its only live tv thats not working. watching from archive an everyting works.
It's only the Live-TV broadcast thats not comming trough.

For me also Direct TV thats not working

TV Provider Box request the DHCP from the Internet Box
Unfortunately it is not possible to configure with a non-automatic address

It will be necessary like me to use a VLAN dedicated to the TV

Thanks, that's absolutely something i can look into if it's tha same here :ok_hand:

Adding some tcpdump info in case it migth help as im atleast a week away from trying to set up a propper vlan to see if that helps.

This is the interface where my IPTV box is connected.

root@Gnaa:~# tcpdump -i lan1 igmp
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on lan1, link-type EN10MB (Ethernet), capture size 262144 bytes
23:29:41.628824 IP 192.168.0.175 > 233.184.49.39: igmp v2 report 233.184.49.39
23:29:41.926820 IP 192.168.0.175 > all-routers.mcast.net: igmp leave 233.184.48.212
23:29:41.926836 IP 0.0.0.0 > all-systems.mcast.net: igmp query v2 [max resp time 10] [gaddr 233.184.48.212]
23:29:43.965586 IP 0.0.0.0 > all-systems.mcast.net: igmp query v2
23:29:47.094928 IP 192.168.0.175 > 233.184.48.49: igmp v2 report 233.184.48.49
23:29:48.446927 IP 192.168.0.175 > 233.184.49.39: igmp v2 report 233.184.49.39
23:29:48.910980 IP 192.168.0.175 > 233.184.48.94: igmp v2 report 233.184.48.94
23:29:49.967001 IP 192.168.0.175 > 239.255.255.250: igmp v2 report 239.255.255.250
23:30:07.176362 IP Mystervegen-51.lan > igmp.mcast.net: igmp v3 report, 1 group record(s)
23:30:07.226329 IP Mystervegen-51.lan > igmp.mcast.net: igmp v3 report, 1 group record(s)

Also what happens on the wan

root@Gnaa:~# tcpdump -i wan igmp
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on wan, link-type EN10MB (Ethernet), capture size 262144 bytes
23:36:45.237454 IP 148.122.7.125 > all-systems.mcast.net: igmp query v3
23:38:50.237664 IP 148.122.7.125 > all-systems.mcast.net: igmp query v3

I migth try to vlan the multicast iptv tomorrow, if it dosnt work with just my router iI must wait. I have a managed switch in order but its a atleast a week away from delivery.

I've noticed theres a updated version of igmpproxy (0.3) over the one suplied by opkg (0.2).
It wwould be nice to see if igmpproxy 0.3 works better.

I've located igmp traffic with tcpdump and running igmpproxy in verbose mode, but for some reason i cannot fathom it dosnt seem to propperly pass multicast pacages from wan to lan and lan to wan.