Better connection between my DSL modem and my Linksys

I have a 100/20 fiber VDSL2...I use a Linksys router cascaded on a DSL modem (WAN router with LAN 1 modem)...to have a better quality connection it's better to make the connection on the dsl modem or a passthrough PPPoE on the modem and a PPPoE connection on the router? In the parameters of my fiber connection it is also necessary to insert the VLAN ID 835

What is the difference between PPPoE and PPPoATM?

Easy man :crazy_face: too much meat on the plate !!!
My questions:

1- is Vdsl fiber ?

2- vlan 835 is a standard or a ISP related parameter ? See:

https://www.linksys.com/no/support-article?articleNum=187899

3- modem pass through is it something easy to find on oem routers? Does openwrt supports it ? How ?

Thanks anybody kind of new to vdsl ! Would like to have fiber.

1 Like

It is always better to use the modem exclusively as (bridged) modem and to handle the PPPoE session on your actual router instead (avoids double-NAT, which could be a source of a lot of grieve - and the router is usually faster and in a better position to deal with port forwards et al).

1 Like

Here found something:

https://openwrt.org/docs/guide-user/network/wan/bridge-mode

  1. yes, a vdsl fiber
  2. isp parameter...I live in Italy
  3. I dont know :roll_eyes:

But where can I put the id VLAN on PPPoE connection?

If your router has an eth port dedicated to the WAN port, you would just change eth1 to eth1.835 in the wan physical settings.

If there is a switch chip involved you also have to set up the VLAN in the switch chip.

Very-high-bit-rate digital subscriber line ( VDSL )[1]and very-high-bit-rate digital subscriber line 2 ( VDSL2 )[2] are digital subscriber line (DSL) technologies providing data transmission faster than asymmetric digital subscriber line (ADSL).

VDSL offers speeds of up to 52 Mbit/s downstreamand 16 Mbit/s upstream,[3] over a single flat untwisted or twisted pair of copper wires using the frequency band from 25 kHz to 12 MHz.[4] These rates mean that VDSL is capable of supporting applications such as high-definition television, as well as telephone services (voice over IP) and general Internet access, over a single connection. VDSL is deployed over existing wiring used for analog telephone service and lower-speed DSL connections. This standard was approved by the International Telecommunication Union (ITU) in November 2001.

Second-generation systems ( VDSL2 ; ITU-T G.993.2 approved in February 2006)[5] use frequencies of up to 30 MHz to provide data rates exceeding 100 Mbit/s simultaneously in both the upstream and downstream directions. The maximum available bit rate is achieved at a range of about 300 metres (980 ft); performance degrades as the local loop attenuation
Increases.

If you pay for fiber you should get fiber !!!

I did not understand this...what should I do?

...and I cannot put eth1.835 in the "custom interface"...it does not let me select this configuration :roll_eyes:

Edit: I solved this but when I put "eth1.835" no connection...instead with interface eth1.2 (wan) I have internet connection.

I'm not able to configure the switch on eth1.835
Immagine5

Can you post the output of /etc/config/network.
i think i know what is the problem, i will change a few lines then you should have internet!

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxxxxxxxxx/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '10.10.10.1'
	option ifname 'eth0.1'

config interface 'wan'
	option proto 'pppoe'
	option password 'xxxxxx'
	option username 'xxxxxxx'
	option ipv6 '0'
	option delegate '0'
	option ifname 'eth1.2'

config interface 'wan6'
	option ifname 'eth1.2'
	option proto 'dhcpv6'
	option auto '0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'xxxxxxxxxx/48'

config interface 'lan'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option ipaddr '10.10.10.1'
option ifname 'eth0.1'

config interface 'wan'
option proto 'pppoe'
option password 'xxxxxx'
option username 'xxxxxxx'
option ipv6 '0'
option delegate '0'
option ifname 'eth1.835'

config interface 'wan6'
option ifname 'eth1.835'
option proto 'dhcpv6'
option auto '0'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan 'eth0_1'
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 5t'

config switch_vlan 'eth1_835'
option device 'switch0'
option vlan '2'
option vid '835'
option ports '4t 6t'

just copy and paste, then add your username and password!, don't forget to do:
/etc/init.d/network restart

This is assuming the modem really requires tagged packets. If you have internet using the config posted and eth1.2, you're actually emitting untagged packets on port 4.
option ports '4 6t'
Does this result in a public WAN IP?

As for what @hisham2630 posted, you may need to set vlan 2 and vid 835. Switch chips use a table of VLANs which only holds 16 or 128 entries. To use a VLAN number higher than that, vlan is the index in the table, and vid is the IEEE 802.1Q tag number actually injected into the packets.

Thanks for clarifying this, i thought that it's support up to 1024 entries.
Now i corrected the settings.

It depends on the chip. OP never identified his/her router model so who knows?

Anyway i changed it back vlan to 2, i think he/she need a tagged vlan to be sent!

Not working...I have alway and only switch1.2

try to reboot your with the new settings, also i think you have to use PPPOA instead of PPPOE!
Also, you should post your connection parameters/router model so we can help.

No internet connection now...maybe it's a bug...look here