Need help with vlan tagging

i changed my router today and since then im no longer able to connect over pppoe, i asked in the forum of my provider (deutsche telekom) and i got told to set vlan7. im a bit suprised, because i never had to set it... so i tried the first time to set a vlan and im confused.

i tried to set it like this:

i also tried LAN1 and both LAN1 and eth0 on vlan7, but this also doesnt work.

whatever i try, i cant connect.

Your particular router does not control the WAN interface via the switch. Revert to default settings, head to network -> interface -> wan and change eth1 to custom eth1.7 in the physical settings tab.

FYI, always leave CPU(0) as tagged....

( see your pic for VLAN 1 row... it's what locked you out. )

If you tag the CPU through the switch, you have to go to the LAN physical settings and change from eth0 to eth0.1.

The default setup of one VLAN untagged can be left in place, if you continue to use all 4 ports of the switch for LAN.

As @jow said, you do not need to reconfigure the switch at all to get tagged packets to the modem, since the WAN port is separate and doesn't go through the switch.

hey, im back from testing. i reverted the "switch" settings and set eth1.7 for both wan and wan6.

still no connection


i get still the same error as before

Fri Jan 18 18:02:18 2019 daemon.warn pppd[6525]: Timeout waiting for PADO packets
Fri Jan 18 18:02:18 2019 daemon.err pppd[6525]: Unable to complete PPPoE Discovery
Fri Jan 18 18:02:18 2019 pppd[6525]: Exit.

after trying for hours yesterday and also spending a few hours today, i deciced to connect my old router (tp-link wdr3600 with OpenWrt 18.06.1) and set it up like this

and pppoe started to work on FIRST try.

so i wonder why im not able to get it to work on my zyxel nbg6617... i also wonder why WAN is missing on the switch on the zyxel.

i found this thread: VLAN configuration for Telekom
which brought me to the idea, to try another router, because my zyxel and this one are very similar.

On some devices, WAN is not a switch port but a dedicated nic, that is why it is missing there.

If you can spare a LAN port, let's say LAN 4, you can use it for the uplink as follows:
Remove LAN 4 from VLAN 1, create VLAN 7, add both CPU and LAN 4 to VLAN 7 in tagged mode.
Set the the physical interface for WAN to eth0.7, just as with your previous router.


thx. i will try this on monday

thank you very much, this solution works :slight_smile: is this a know bug, that vlan on eth1 doesnt work?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.