Belkin RT3200/Linksys E8450 WiFi AX discussion

I got the solution to that: disable Generate PMK Locally/option ft_psk_generate_local 0. It was a whole thing I made a thread for, but ultimately my issue wasn't fixed.

1 Like

I tried that, but I couldn't make it work. Will try to use the python script to generate the R0 and R1 keys to see if it helps.



Didn't work with generate locally set to 0. I'll stay with WPA2

That's too bad. It worked for me, with only those two things, roaming enabled and generate PMK disabled. Everything else blank, on both APs.

But I'm no expert, so I'll keep my traps shut.

Same here, no issues with latest 23.05.2. I have changed my setup a bit: my network setup now includes 3 AX networks (AP mode, 80MHz, autochannel, 20dBm - 100mW, disabled IPv6, SAE-mixed, 3 fixed MAC addresses, beamforming, and BSS coloring, one AP has client isolation). 2.4GHz is not used and turned off.

No issues!

Just my two ¢ on things confirmed working. In my setup on 23.05 with focus on WiFi
I have 4 rt3200 running, one router and three APs connected via Ethernet cables.

rock solid, stable (*)

  • AX (80MHz)
  • beam forming (5GHz only)
  • roaming with DAWN (802.11r, 802.11k, 802.11v)
    • between APs
    • between 5GHz and 2.4GHz
  • WPA2

not stable:

  • WED on AP (but not tested on 23.05)
    I had APs which caused trouble after some uptime/some number of authentications. After a few hours/days, in particular when more devices were active in the wifi, devices reported connection to wifi but no internet access. Restarting network/rebooting the AP solved that issue.
    In order to use WED on APs bridger is required and that might be the root cause of my trouble.
    I had these problems with

    • with various SNAPSHOTs picked during the last months
    • with self build image using kernel 6.1 and latest mt76 (fcc2f3d82b at the time)

    I think bridger might be the culprit because I had these issues with
    both WED enabled and WED disabled

    Since I use 23.05 I didn't try to use WED and did not install bridger. Everything mentioned in the stable section is now stable.
    Note that I did not try WED on the router where no bridger would be required.


  • VLANs (using different ESSIDs) / OWE, SAE (802.11w)
    There are reports that SAE is stable with different ESSIDs for SAE and WPA2, mixed mode is reported unstable. I have just recently opened a second ESSID for SAE. I had issues with roaming on that 2nd ESSID with 23.05.0, and in addition the phone actually switched to the wpa2 ESSID sometimes. For 23.05.2 it is too early to say.
  • usteer (might work as well as DAWN)
  • SW and HW flow offloading
    • checked on APs, but no routing/NAT active so probably unused
    • unchecked on router because I use SQM
  • AX 160MHz

(*) The above list reflects what I use. 23.05 is running since Oct 18.
There is a Windows 10 Laptop (Lenovo) with realtek 8822ce chip which has severe issues, but that might be a Windows driver issue. @zsolto1 is your Lenovo notebook running Windows 10, too?

WPA3 sae is rock solid and stable, too. As is WPA2.

What is not 100% stable: WPA2/WPA3 sae-mixed mode:
Mixed mode wpa2 / wpa3 sae issues on ipq4029

The work around is easy, at least for vap capable hardware like our E8450/RT3200: create one SSID for pure WPA2 and another SSID for WPA3 sae only. No mixed mode. It's also possible to keep devices that are not WPA3 capable on the 2.4 GHz interface and reserve 5 GHz for WPA3.

I'm also running 1 RT3200 with a realtek 2288ce card in my Lenovo notebook.
I had initially many troubles with driver installed by default by Lenovo.
I had to manually switch to a more stable driver:
8822ce_2024.10.227.2 was working fine for me (W10)

I'm currently running driver 2024.10.228.5 (oct 2023) on W11
It seems quite stable.

1 Like

I am having the same questions as i flashed my RT3200 nearly two years ago. Does it make sense to update U-Boot without having specific problems?

1 Like

If you have no bad blocks currently in the early boot chain area, and the normal firmware loads ok, there is no reason to take risk and write into those early flash blocks. New bad blocks might surface...

The risk has been taken already once, when the installer overwrote the original feature-crippled OEM bootchain.

Similarly, upgrading the OpenWrt recovery instance can be done (without needing to use the installer), but is rarely necessary. It was once necessary, in summer 2021, when the flash driver with ECC correction was implemented...

I have done upgraded my recovery to 23.05.0 just for fun, like I wrote in


How can one tell whether one has a sufficiently recent version to capture that implementation?

Well, if your 5GHz radio works currently, you are ok.
(unless you have manually fixed the ECC data in mtd2 without using the installer...)

The UBI installer script that read and wrote the ECC data to the wifi calibration data, also installed (or re-installed) the recovery instance at the same time.

Discussion near this message in Aug 2021:


Lately I've been experiencing slow internet on Apple devices, somehow it went away after disabling AQL :thinking:

# Disable AQL
echo 0 > /sys/kernel/debug/ieee80211/wl0/aql_enable
echo 0 > /sys/kernel/debug/ieee80211/wl1/aql_enable

What kind of slowness? We have iPhone 15 and iPhone 11 and fairly recent iPad and 3x RT3200's in 802.11r / WDS arrangement with both br-lan and br-guest networks and all seems fine in terms of roaming, WDS and internet in general. For long enough there was a problem with our Apple devices and periodic loss of connectivity - requiring manual reconnection to WiFi on the Apple device(s) (confirmed by many on this forum), but I think whatever that issue was that was fixed already by at least 22.03.5 and all is still well in 23.05.02 at my end.

It seems to happen when I have my iPhone on the pocket and start working on the Mac, either one of them experience speed fluctuations (iperf3 results show spikes of 600-700mbps and then it drops to sub 100mbps).

I also experienced this problem but seems it's caused by WED (the logs say something about a timer deauth), tried lots of things like disabling disconnect on low ACK but only disabling WED did the trick for me.

In that case please discount my positive report because I am on sub-100 Mbits/s LTE and haven't tested with iperf3. I can test with iperf3 if you like, however? Is there an iOS app that supports that?

I don't use/own Apple but IIRC, that OneMarc YouTube guy's video on roaming showed an iOS iperf app. You should be able to find it on the Store with "iperf" string, not sure if it's paid though.

Besides that, anybody else have issues with IPv6 using this RT3200 as the router? Have been facing this from day one, some clients have no problem, other's just won't do IPv6, no matter what:

Same ISP, same settings on previous OpenWrt device (Archer C7 v5), never faced this issue.

iperf3 for ios:

Sure, I use this one

I removed WAN6 due to the terrible latency I get over IPv6 with my ISP, however I’ve not had any problems with devices getting a public address from the RT3200.

No, in this case, devices get IPv6 addresses as expected, but no traffic goes through to the Internet. Can't even ping the damn router.

1 Like

Turned off one of my belkin RT3200s in anticipation of moing it to another room, plugged it back in, and the lighw ould not come on. I took it apart hooked up a serial termina to it and found this

F0: 102B 0000
F6: 0000 0000
V0: 0000 0000 [0001]
00: 0000 0000
BP: 0400 0041 [0000]
G0: 1190 0000
T0: 0000 02D4 [000F]
Jump to BL

NOTICE:  BL2: v2.9(release):OpenWrt v2023-07-24-00ac6db3-2 (mt7622-snand-1ddr)
NOTICE:  BL2: Built : 21:45:35, Oct  9 2023
NOTICE:  WDT: Cold boot
NOTICE:  WDT: disabled
ERROR:   BL2: Failed to load image id 5 (-2)

I'm not even getting the boot loader. Not sure the next step here?
I know if i had a bootloader i would do the TFTP server and reload the image. but with no loader i am unsure what to do.

Edit. There are no LED's, holding the reset button during "boot" or other wise does not change the outcome. Always the same message in the serial terminal