Mixed mode wpa2 / wpa3 sae issues on ipq4029

Hi I have iisues with wpa3 on the ipq402x chipset with a wallystech dr4029.

if I enable wpa3 it works for a while then all devices loose conectibility, you can still join the network etc but it is almost like the firewall is blocking everything from then on
I'm using wpad-openssl and i have tried various ath10k firmware ct no ct full etc... i have even tried enabling 802.11r k etc but all seems dead end.

How would i diag futher as into a cause of failure?

Rebooting fixes the issue but it comes back and seems relativly random.

There are many clients that don't like WPA2/ WPA3 mixed mode, with various failure modes - including the one you're raising. As mentioned, this is a client-side issue and unfixable on the AP side (qca401x should (does-) not have problems with WPA3 or mixed mode itself). The only real options is to separate the two, either by only offering WPA2(-only) or by offering separate networks for WPA2-only and WPA3-only (can be bridged to the same br-lan, as long as they are distinct BSSIDs).