Belkin RT3200/Linksys E8450 WiFi AX discussion

From which version of OpenWRT did you upgrade from?
Looks like you have to redo your wireless configuration.

And also, how did you do the upgrade? ASU or auc or basic img or ???

Did you keep your configs?

Several posts above address various issues with 22.03 -> 23.05 via auc, also keeping configs can cause issues with the radios. A quick once over:

  1. Edit /etc/config/wireless and change the option path on each of the wifi-device entries to option phy 'wl0' for radio0 and option phy 'wl1' for radio1.
  2. opkg update && opkg install kmod-mt7915-firmware

Can anyone help me work out what's happened. Last time I used my Belkin RT3200 a few months ago it was on OpenWRT 22 Ubi, so how when I've just booted it has it booted the stock firmware, which I thought wasn't possible on ubi, and where's my OpenWRT gone? How can I reflash it given the installer says to only use it once.

And it's bricked, I flashed the temp recovery and it said I was on ubi like I thought, so how was it on the stock firmware? Anyway, becuase the guide says don't use the installer again, especialy if on ubi already. I flashed the latest sysupgrade from the temp recovery. It hung on updating for half an hour, after that I gave up and powered it off. Now it's just got a flashing power LED and the PC doesn't detect a network connection.

I have a PL2303TA and a (red) FT232 which should I use to wire this up.

Any ideas?

22.03 > 23.05, I did the sysupgrade for the UBI package, and the first time keeping settings, then the second clearing them.

I'll give what you said here a run

Have you been able to make any progress with this? I have an RT3200 in the same state that I would like to bring back to life but my Google skills aren't good enough to find a guide or help anywhere.

I'll probably be trying this, maybe this weekend but might need to be the one after depending on time.

Hello, I'm attempting to restore the original firmware on the linksys e8450, reading the guide https://github.com/dangowrt/owrt-ubi-installer#backup-stockvendor-bootchain I realize that don't have the MTD backup, is there any other method without this files?

I have a problem now. Adding another SSID on the 5GHz radio, doesn't give IP address.

I had a second SSID for my 5GHz WLAN with WPA3 (SAE) only to connect to my laptop and the main SSID with WPA2 (CCMP).

I did an attended sysupgrade to refresh the packages (I saw that wpad-mbedtls, hostapd and many other packages had updates, so I rebuild an image with these updates built-in) and now the second SSID doesn't assign IP addresses.

The clients connect, but I don't get an IP and thus, no network access. I had everything working before, no changes on my config.

Here's my wireless:

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/18000000.wmac'
        option band '2g'
        option country 'VE'
        option cell_density '0'
        option noscan '1'
        option htmode 'HT40'
        option channel '11'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'CharlieNet'
        option encryption 'psk2+ccmp'
        option key '[redacted]'
        option ieee80211r '1'
        option nasid '8fde'
        option mobility_domain '4f57'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        option ieee80211k '1'
        option time_advertisement '2'
        option time_zone 'GMT-4'
        option wnm_sleep_mode '1'
        option bss_transition '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '5g'
        option country 'VE'
        option cell_density '0'
        option he_su_beamformee '1'
        option he_su_beamformer '1'
        option he_mu_beamformer '1'
        option he_bss_color '7'
        option htmode 'HE80'
        option channel '36'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'CharlieNetHD'
        option key '[redacted]'
        option ieee80211r '1'
        option mobility_domain '4f58'
        option ft_over_ds '0'
        option dtim_period '3'
        option ieee80211k '1'
        option time_advertisement '2'
        option time_zone 'GMT-4'
        option wnm_sleep_mode '1'
        option bss_transition '1'
        option encryption 'psk2+ccmp'
        option nasid '7bb398'
        option ft_psk_generate_local '1'

config wifi-iface 'wifinet2'
        option device 'radio1'
        option mode 'ap'
        option ssid 'CharlieNetAX'
        option encryption 'sae'
        option dtim_period '3'
        option key '[redacted]'
        option network 'lan'

Network config:

/etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd94:b25d:ab73::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'
        option peerdns '0'
        list dns '1.1.1.1'
        list dns '1.0.0.1'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'
        option peerdns '0'
        list dns '2606:4700:4700::1111'
        list dns '2606:4700:4700::1001'

config device
        option name 'wan'

config interface 'modem'
        option proto 'static'
        option device '@wan'
        option ipaddr '192.168.100.2'
        option netmask '255.255.255.0'

Firewall:

 /etc/config/firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'
        option flow_offloading '1'
        option flow_offloading_hw '1'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

DNS:

/etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config domain
        option name 'charlienet.lan'
        option ip '192.168.1.1'

config domain
        option name 'charlienetplus.lan'
        option ip '192.168.1.2'

config domain
        option name 'modem.lan'
        option ip '192.168.100.1'

Thoughts???

I had the same setup and was able to connect just fine to my WPA3 SSID, now I don't get an IP.

I'm running a custom build off the stable branch and I'm seeing similar behavior of 5Ghz WPA3 not getting IPs. In my case, my RT3200 is just a dumb AP, so I'm taking that as it's not passing any packets.

I have a build I made on Oct 1st with whatever packages and build that were on stable on that day are fine, but I tired to make an updated build in the past week or so and ran into this problem. (When I had a fail, I just refreshed my build from 10/1.)

I haven't had a chance to do some git bisects to build and narrow down where things went wrong as that's a long cycle of build -> install -> fail, try again.

I wish I could narrow the gap down further, but I haven't had time, but some update in the last month and a half seemed to break this.

I have exactly the same issue. Two SSIDs on 5 GHz, main SSID works, guest SSID is up but clients get no IP. Restarting the guest interface helps.

My build from Nov 2nd does not have this issue. I started noticing this with a build from Nov 10th.
(I use the online Firmware Selector and customize with my needed packages.)

Edit: Ok i got it. Used my old working image and upgraded netifd, reboot and then i get the error.

This is the commit:

Edit2: Probably fixed here:

So could be fixed in 23.05.1 or when packages get rebuild next time. Unfortunately two days ago the "old" netifd version netifd_2023-11-07 got build, see here. So it could take a few days.

1 Like

It’s almost 2024 and this router still rocks!

Just tested with WED enabled on 23.05 from iPhone 15 Pro :fire:

I had both of those in my tree on my build of the 23.05 stable branch and was seeing the issue. I reverted both of them and was still having the, so it's something before those commits.

Weird, I just build my own image of 23.05.1 (including those commits) and my issue is fixed.
So should be fixed, when 23.05.1 is released.

I noticed this pop up on the stable branch last night: https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=842932a63d8993150ff339f11f0cd0d5dc45e6cc

I wonder if I’m running into that edge case. I’ll have time to test tomorrow.

I just noticed that i was only getting 100mbit on my 500/500 internet connection, when i check dmesg i'm seeing [ 14.438368] mt7530 mdio-bus:00 wan: Link is Up - 100Mbps/Full - flow control rx/tx in dmesg.... what could be causing this it's a new ethernet cable, ONT seems to be working fine, if i do ethtool eth0 on the unit, it shows 2500mbit-X which really confuses me.

ethtool wan would give you the info you are looking for on that port.
eth0 is used to connect to the built-in switch with 2500Mbps/Full.

Up on latest stable (actually newly tagged 23.05.2) and I'm running great.

1 Like

Anybody have issues with roaming?

Only on a Leonovo notebook with Realtek 8822ce wifi card, but with that, I got serious problems. Every other device works fine, as far as I know.

Updated just fine with Attended Sysupgrade to 23.05.2

No issues with roaming between the RT3200 and a WDR4300 with my Pixel 4a. I have the SSID with WPA2 CCMP, I can't make it work with WPA3.

Cheers!