Askey RAC2V1K / RT4230W REV6 Support

I just had an Askey RAC2V1K installed via Spectrum in Southern California. If anyone is interested in collaborating on adding support for it via it's IPQ8065 I am interested in working together on it.

I got root on it which was fairly easy to do. I can contribute dumps or .config or whatever needed.

2 Likes

Just checked out the specs.
Looks really good,similar to R7800.
But even better,triple the flash and double the RAM.

I have not yet worked on IPQ806X series,only IPQ40XX but the difference should not be so big.

i just got it installed, how did you get root on it? is there a tutorial? im interested.

1 Like

Same here. Been trying to figure out how to get into the root menu for configuring it as an AP. A relative noob here.

Default password in the manual I found online doesnt seem to work on Spectrum devices.
root / MmvGB^RY3#

Factory Manual (mentions root login and AP mode)

Spectrum Manual (many sections removed, no AP mode, no mention of root)

I encountered a setup where a business had several of them installed, I think they had more than 1 gigabit connection. They had moved them out into the building as access points, but unbeknownst to them the devices were all in router mode, so they ended up with a segmented network. I called Spectrum and told them what was going on, they couldnt access the devices because they were behind the customers router.. plus.. they claimed no knowledge that they could be put into access point mode, that they didnt know about a "root" account, that the manual talks about, and that they werent aware of any installers delivering the devices configured as AP's..

So if theres a way to get these into AP mode, Id like to know how as well.. because the password I found doesnt work.

I haven't hacked on the device in quite a while. To get root go to the Web UI and backup the configuration. I think it makes a tarball. Open it up and poke through it, you will find root access and lots of other neat things.

Good Luck! :slight_smile:

I'm curious if anyone has made any progress with this router. I just received it from Spectrum. The specs seem pretty great. I'd love to install a custom firmware on it or otherwise get better access than is currently available from the standard backend. I've been unable to access an expert or root mode, if there is one available and the .CFG file that is generated when saving the routers configuration is encrypted.

Just for the records: Specs of the RAC2V1K
https://wikidevi.com/wiki/Askey_RAC2V1K

I've played with this router a little through UART.
Quite interesting device, but it’s not clear how to flash it without root GUI access.

xvortex - any progress wiht this device?

i have the serial boot log from this device.
https://pastebin.com/1ZPL7xnd
i was NOT able to break into the boot sequence from the serial console!

i could break into failsafe mode by pushing the wps button as the 'press f' prompt appeared on the terminal.
however, the console was disabled in failsafe mode, and 192.168.1.1 was not active.
i'm stumped....

I looked in Google Chrome through "CTRL + U" the source code of the Advanced > Admin > System page and found commented out lines regarding the password change for the root user. I tried to uncomment these lines in the console, after which it became possible to change the root password. However, when saving changes, an error occurs and the root password is not saved. I think I'm on the right track, but unfortunately my knowledge of HTML is not enough to move on :frowning:

<!--root login-->
<!--<tr>-->
<!--<td class="info-item">-->
<!--<label for="loginName" data-lang-tx="tx_loginName"></label>-->
<!--</td>-->
<!--<td class="info-content">-->
<!--<input disabled id="rootName" value="root" type="text">-->
<!--</td>-->
<!--</tr>-->
<!--<tr>-->
<!--<td class="info-item">-->
<!--<label for="sysPwd" data-lang-tx="tx_newPwd"></label>-->
<!--</td>-->
<!--<td class="info-content"><input id="sysRootPwd" type="password"></td>-->
<!--</tr>-->
<!--<tr>-->
<!--<td class="info-item">-->
<!--<label for="repeatPwd" data-lang-tx="tx_rePwd"></label>-->
<!--</td>-->
<!--<td class="info-content">-->
<!--<input id="repeatRootPwd" type="password">-->
<!--<input type="checkbox" id="showRootPwd">-->
<!--<label for="showRootPwd" data-lang-tx="tx_showPwd">Show password</label>-->
<!--</td>-->
<!--</tr>-->

Im not fluent in html either, but will give this a try over the weekend. thanks!

if the FW Version <=1.0.11
you can try this login info to shh
user:4230w
password:admin
or try this way
ADVANCED-Admin-Configuration-save to file
download and edit the “Config.cfg” file
the "Config.cfg" change the file extension name to zip file
open and edit it
and restore from flie to update the Config.cfg file

the info from
https://www.right.com.cn/forum/thread-4018486-1-1.html

I have the same router but the variant that can only be managed through the spectrum app(listed as SAC2V1K but hardware is identical from what I can see. has no web interface, just a page with basic info about the router like ip, qr code on the back that's for the app) and it has a password-less account with root (username is operator) on the serial console. I can interrupt uboot and I can even boot initramfs images for routers with the same cpu, but the most interesting thing is that it's almost completely stock openwrt 15.05. Spectrum partnered with plume so it has their modifications and packages. Any way I can help? I'll upload a boot log later.

Edit: if you want remote root access on this router you can put a script in /www/cgi-bin/ that runs telnetd when you go to that specific url. there's also some very interesting files there but they have some copyright on them so I won't upload them. One more thing, the stock firmware has no support for the usb port but other initramfs images do

hey
I crack it (backup/restore)

1 Like

Many thanks!
It really works!
I logged in as root under SSH on firmware 1.1.16.

Teardown
2.0MM cable DuPont connect TTL
Boot
F+Enter to safefail
mount rootfs

Edit /etc/config/dropbear
Edit shadow, group, passwd replace root user 4230W (replace user. adduser cannot connect to reboot)

Reboot.
Login web backup configuration

I got root-console without disassembling the router and without connecting via TTL. I restored Config.cfg from the folder 1.1.16. Then I connected to the router via SSH on the LAN- port using the PuTTY utility.
SSH login: 4230w, password: linuxbox
File transfer also works with the SCP-protocol (WinSCP utility). Only first you need to exit the SSH console.
Login and password for WEB-interface: admin / linuxbox
efsg, thanks again for your work!

SSH-console