Belkin RT3200/Linksys E8450 WiFi AX discussion

The difference here is that previous sysupgrade images were generated by the installer script as well -- the original idea was to include LuCI (which isn't part of snapshot images on downloads.openwrt.org), but then I decided to include a more complete set of packages useful for this specific device.

Now that the 22.03 release is getting closer and there are now sysupgrade images on downloads.openwrt.org for this device which do include LuCI, I decided to just ship that instead, so we get to test what is going to be in the official release images. This is because I never intended to provide a community build or anything like that, I just wanted normal users to be able to try OpenWrt on the device and find themselves with a Web-UI.

If you want auc or luci-app-attendedsysupgrade you can simply install it after installation:

opkg update
opkg install auc luci-app-attendedsysupgrade

will install both.

Similarly, if you need the full variants of hostapd/wpa_supplicant for 802.11s mesh mode, you can replace the included wpad-basic-wolfssl with something more advanced which does support that, such as wpad-wolfssl or wpad-openssl (which was included in the sysupgrade images previously generated by the installer script).

Alternatively you can as well just use chef.libremesh.org to generate an image with exactly the packages you like and use that instead.

4 Likes

Thanks for clearing that up @daniel - I built images for my devices with the current packages I use against SNAPSHOT and 22.03 SNAPSHOT. This way, I can easily switch between the two versions.

In additon to replacing wpad-basic-wolfssl with wpad-openssl, I also replaced libustream-wolfssl with libustream-openssl.

Thanks @ktgeek and @nkef for your replies. Glad your RT3200 are so stable with the two workaround. Maybe the cron job is easier as I can make the adjustment directly in Luci. :slight_smile: On my upgrade woes, I went from SNAPSHOT r19138-4ecf8346c0 to SHOTSHOT r19355-80f79beb95 a few days ago. No issues thus far. Thanks again.

Has anyone had any luck getting this device set up into a mesh network where multiple devices are connected to ethernet? I've had a relatively easy time getting a mesh network w/ batman-adv setup where only a single device is connected to my gateway (running OPNsense), but as soon as I connect a second device to the same gateway (directly over Ethernet), my devices become periodically unresponsive, and I get a lot of this type of message in my logs:

kern.warn kernel: br-lan: received packet on bat0 with own address as source address (addr:xx:xx:xx:xx:xx:xx, vlan:0)
kern.warn kernel: br-lan: received packet on bat0 with own address as source address (addr:xx:xx:xx:xx:xx:xx, vlan:0)
kern.warn kernel: br-lan: received packet on bat0 with own address as source address (addr:xx:xx:xx:xx:xx:xx, vlan:0)
...
kern.warn kernel: net_ratelimit: 75430 callbacks suppressed
...

(This occurs despite having both stp enabled in the bridges, and bridge_loop_avoidance enabled for the batman-adv interface

This is unfortunate because it works great in isolation, but I would like to have some redundancy in the mesh network.

Can you share your setup/config? My MacBook jumps constantly from 80 mhz to 160 mhz back and forth and a therefore speed deteriorates, when HE160 is enabled.

If you're located in the US, take a look at the Askey RAC2V1K / RT4230W REV6 Support (almost the same hardware as r7800 or nbg6817), which starts around 20 USD on the used markets.

1 Like

Hi,

I'm running an RT3200 with 22.03-SNAPSHOT r19206-6e7bf6ad95, things has been fine since the first load of the UBI, thanks for the great job done.

Everything works fine unless a strange issue with a single WiFi device (Xiaomi Redmi 5 Plus). It connects to the WiFi network and works fine for sometime, then even if it keeps connected to the WiFi it does no longer access internet. Unless the Redmi WiFi gets disconnected and reconnected.

What I've seen when the device is no longer able to access internet is:

  • The Redmi "IP neighbor" show the router in DELAY
  • The router "IP neighbor" show the Redmi in INCOMPLETE

At that stage, even if the WiFi is still connected on the Redmi, there is no communication on the local link and I see no packets in the tcpdump done at router level.

I've seen that forcing an ARP discovery of the network using the "Fing" app on the Redmi somehow trigger the device to communicate at local link level, so that "IP neighbor" goes back to REACHABLE and I can get communication at IPv4 level (private or public ones). The Redmi is still not able to browse the internet, as for some reason its TCP stack does send DNS requests (or at least I cannot see any in the tcpdump).
Nice thing, if I send a direct DNS UDP packet on port 53 using "Ping & Net" app, the address get resolved, but this doesn't trigger the device to access the internet.

Is clear that this is not an OpenWrt bug, but is my Redmi that doesn't behave correctly for some reason (it was working fine before with a WNDR3700v4 running some 19.x from 2021) but I would love to hear some feedback or guidance on what to look next.

As further details, running on IPv4 only on OpenWrt with the 5 GHz radio in AX mode (the Redmi is not AX), not sure if using only the 2.4 GHz radio gives the same behavior, but I've now temporally disabled the 5 GHz one. The Redmi has also an IPv6 address and I cannot disable it, I haven't root access.

Not sure, but likely the problem is trigged by the Battery Saver (that goes in when battery is less than 60%) because I've not been able to get the device in stuck while on powercord and generally the problem appears only after a while with screen off.

I would like to get till the problem cause, but a dirty trick would be to have the WiFi disconnected on screen off, switching to LTE network.

Thanks anyone would help on this.

Sadness,i dont live in US.
I might end up with ng6817 (it’s available in my area )

How about EA8500 or R7500 ?
now i’m looking for ap (for mesh 802.11s with my main router) used ea8500 price is 35 usd and used r7500 price is 60 usd.
Or stick with ea7500v2 (but i found problem with wifi speed in openwrt official build)

Skip the r7500, it has only 256 MB RAM and comes in two h/w revisions, the ubiquituous r7500v1 with unsupported/ unusable 5 GHz wireless (quantenna topaz), only the rare r7500v2 had two qca9980 wireless cards.

r7500 and ea8500 are also the older ipq8064 SOC, the ea8500 is also right at the limit of its kernel partition.

1 Like

It is straightforward. The 160MHz channel works fine with the Intel AX201 wifi adapter of my laptop. Most new laptops come with it these days. Old Wifi 5 devices work fine too, using 80MHz channels. This is my wireless config:

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/18000000.wmac'
        option channel '1'
        option band '2g'
        option htmode 'HT40'
        option country 'US'
        option cell_density '0'
        option noscan '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'sae-mixed'
        option key '************'
        option ssid 'Wifi-2.4GHz'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '5g'
        option htmode 'HE160'
        option country 'US'
        option cell_density '0'
        option channel '36'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option encryption 'sae-mixed'
        option key '************'
        option ssid 'Wifi-5GHz'
1 Like

This device keeps on getting better support, especially if you are using cryptographic algorithms: https://github.com/openwrt/openwrt/commit/c9c2b01b8441195807e8b492c7d3e385e6c6afdc

7 Likes

Does that mean faster OpenVPN!? :grinning:

I wish OpenVPN to be faster too, but unfortunately it doesn't. Those are kernel modules. OpenVPN uses OpenSSL, which is a user land binary. If OpenVPN is using the DCO module (which is still under development) it would benefit OpenVPN then, as DCO will likely use the kernel AES crpyto modules.

1 Like

Ok, unfortunately I've bricked my unit, I can see led flashing white ....

I have to buy a Jtag or serial cable, can anyone provide some help ?

This always makes me sad to read. I wish these could be better prevented. How did you do it?

Once the device is converted to UBI layout you should always manage to boot into recovery image, or in case even that got wiped or damaged the router will request it via TFTP.
However, the power LED flashing can also be the stock/vendor original loader failing to load anything. In that case you have to connect to the serial port :crying_cat_face:

So first of all, in order to know what to do, please share how it happened, ie. what was the last known state the device was in and what has been done which brought it into that rather unfortunate state.

2 Likes

I've tried to restore original firmware with minimal backup following https://github.com/dangowrt/owrt-ubi-installer#restoring-the-vendorofficial-firmware

No errors , but after the reboot ...

As you were using the minimal backup, did you also upload the firmware blob downloaded from Belkin/Linksys? Because LED flashing can indicate that this simply is missing.
In any case, you will have to connect the serial cable at this point...

1 Like

Yes I did and I've also issued the command :slight_smile:

# On Belkin RT3200
mtd -p 0x200000 write /tmp/FW_RT3200_1.0.01.101415_prod.img /dev/mtd3

That looks correct. However, in case your flash had some bad blocks (not unlikely, since it's NAND), this is known to not work well, unfortunately. You can still recover quite easily using the serial cable.

1 Like