Archer C7 v4 support

No, not soon. But it is better than never, which is where things stood just a few days ago.

anyone using the latest Snapshot on V4?? Jan 4.. I been using them just fine then installing Luci with SSH. but it seems like the latest snapshot fails with a error. about dependences I can use the --Force command but still ends with a error. gets luci installed but many things do not work.. is it because packages haven't been built for this snapshot yet?

Hello sorenstoutner,
Here are my answers:

  1. I am doing my tests only over wifi (mainly because I am interested in wifi speed, since my old router had slow wifi). The 290Mbps I got was by doing a speedtest[.]net test with my computer connected to the 5Ghz band on stock firmware. I then installed Lede, and did the same test, but the max I could get is 160Mbps. I connected my computer using an ethernet cable, and I can reach the 290Mbps, so the issue seems to be in Wifi.
  2. The settings are : Mode AC, Channel 36 (5180Mhz), Width 80Mhz, auto transmit power. I did play with these but nothing changed, so I reverted back to them.
  3. My computer has 2 internal antennas.
  4. Here's a screenshot during testing (last line), Strangely, the bitrate shown next to the 5Ghz radio (radio0) is always 6Mbit/s, I guess it's just a bug ?
  5. Here are iperf results, from my computer (5Ghz radio) to another computer connected to lan port.
  6. The same speedtest on the 2.4Ghz radio shows about 80Mbit/s (same computer, 2 antennas).

Edit: I noticed that on the 5Ghz radio config page, the wan network wasn't selected, only lan was (I haven't changed the defaults). I selected it and did the speedtest, I could reach 250Mbit/s ! but the strange thing is, I could no longer access luci while connected to 5Ghz, and on 2.4Ghz I could access luci but it didn't have internet access. What are the settings I should keep ?

Thanks a lot for your help.
Best regards,

1 Like


Thank you for the detailed answers.

Before hooking up an Archer C7 v4 I did some testing on my Archer C2600. It is configured only as an access point, so there is no WAN. But I wanted to see what was the maximum bandwidth I could push from a cabled host on LAN to a Wi-Fi client.

The Archer C2600 has 4 antennas (AC Wave-2). The client has a TP-LInk TL-WDN4800 (3 antenna, N, up to 450 Mbps).

The most I was able to push through it was just under 180 Mbps. That is significantly less that it should be. the systems are in adjoining rooms with no interference, although the signal is -70 dBm (no beamforming for older N client :disappointed_relieved:). When I get a moment I am going to setup a client with a TP-Link Archer T9E AC1900 and see what kind of bandwidth I can get on my Archer C2600 and on an Archer C7 v4. However, based on your experiences and what I have seen so far, it appears that there is some type of limit (probably in the driver or the kernel network management) that is capping Wi-Fi performance at 160 Mbps for the Archer C7 and 180 Mbps for the C2600.

It is interesting that when you connected your Wi-Fi to the WAN you had increased speed. Obviously, there is some processing you were bypassing. I just can't think of what that would be that wouldn't also be bypassed by connected from Wi-Fi to the LAN.

Regarding the general question of which network the 5GHz Wi-Fi should be connected to, you want it to be on the LAN. That way, it has to go through the system and pass through NAT before it crosses over to the WAN. When you connected it directly to the WAN, you allowed your wireless client to get an IP address directly from your ISP. It would be similar to if you had plugged your wireless client directly into the ethernet cable from the ISP. They probably only want to give you one IP address, which is why your router ended up disconnected from the internet. It is also why you couldn't access LuCI, because by default the firewall blocks access from the WAN (otherwise the entire internet could access your device after brute forcing your password).

It does look like you are correct that there is a bug preventing the TX bitrate from being updated on the status page. 2.4GHz always shows 1.0 Mbit/s, 20MHz and 5GHz always shows 6.0 Mbit/s, 20MHz regardless of how much data is actually being transmitted. My memory is that in the past this worked correctly, but I am not sure exactly how long ago that was.


Thanks a lot for your help.

I'm glad I'm not the only one having reduced wifi speeds with my router :smiley:

Actually, my router is connected to the ISP supplied modem/router (which is has same subnetwork address as my router, 192.168.1.x, if that's of any importance) via wan port. The ISP modem has other clients connected directly to it either via wifi or ethernet. Since that is possible, then adding the wan network to the 5Ghz radio should not disconnect me from internet, as that is like having my client connected to the ISP modem ? I don't see how is my ISP not allowing me to have more than one IP address ?

1 Like


I apologize. I made assumptions about your network that were not correct.

So you have an ISP supplies modem that is also a router. I'm assuming it does not have Wi-Fi capabilities or if it does you are not using them. The WAN port on the Archer C7 is plugged into a LAN port on the ISP router. Because both routers are performing NAT, this is what is known as a double NAT. Double NATs do work, but in your case nothing of value is being added by that configuration and it makes some things more complicated. In addition, you have the same subnet range on both sides of the Archer C7 ( This can cause lots of really weird problems, and at a minimum I would recommend changing the Archer C7 LAN subnet to something different, like

I am guessing the reason why you had problems when you attached the Wi-Fi to the WAN port previously is because you left it attached to the LAN port as well. Which means you were bridging two zones with the same subnet range that also had a NAT router connection between them (with two DHCP servers). My brain hurts just trying to think about what that was doing to the packets as they tried to navigate through the Archer C7.

My recommendation for how you should configure the Archer C7 is to remove all the routing functionality and configure it as an access point. This is a configuration I use frequently with many of my clients.

  1. Assign the Archer C7 a static IP address other than that is outside the DHCP range on your ISP modem. For example, if the ISP modem has a DHCP range of - you could use for the Archer C7.

  2. Turn off DHCP on the Archer C7's LAN. This is very important or you will have two DHCP servers operating on the same subnet and things will get hairy.

  3. Connect an ethernet cable from the LAN port on your Archer C7 to a LAN port on your ISP modem.

  4. On the Archer C7 LAN settings, set the IPv4 Gateway as This will tell the Archer C7 how to find the internet so it can do things like sync time using NTP.

  5. Delete the WAN interfaces.

  6. Under the firewall settings, delete the WAN zone.

  7. Extra Credit If you like, you can reconfigure the WAN port to be an additional LAN port. To do this, on the switch, delete the VLAN that is used by WAN. Then assign the WAN port to be untagged on the LAN VLAN, just like the other LAN ports.

If you need detailed instructions for any of these steps I can provide them. I will get back to you when I have done further speed testing, but it could be a while because there is a lot going on right now.


Thanks a lot for your time.

If I want to keep the routing functionality of the Archer C7, what would you recommend I do ?
The modem/router supplied by my ISP has good wifi actually, but it's nowhere near as customizable as Openwrt, so I don't want to use it.

Thanks again.
Best regards,


I can't imagine any reason why you would want to run two routers on a home network. There is a little bit of a performance hit every time you pass through the NAT of the router (you will see this in increased latency). But if you do want to do so, I would recommend changing the LAN subnet to be something different than So, for example, you could use As long as there is no overlap in IP addresses you should be fine.

At my house I use pfSense as my router (running on an old Athlon 64 X2) because I need some of the advanced capabilities of pfSense that aren't available in OpenWrt. I use OpenWrt to run an Archer C2600 as an access point configured as described in my last post.

I have many other client locations that use OpenWrt as a combination router/access point (this is the way it is configured out of the box, what is referred to as a Wi-Fi router). And I have also used OpenWrt as wired router with Wi-Fi disabled, especially when routing between internal subnets in large organizations (typically this configuration has NAT disabled, which makes routing faster).

1 Like

Has anyone prepared a stripped firmware and reverted successfully to stock? Last time I tried myself I bricked.

Use the following tutorial from the TP-Link forum...

Rename the stock firmware file archerC7v4_tp_recovery.bin

1 Like

Didn't work for me with stock firmware, but did work to recover to lede, which is why I think I need a stripped firmware.


So you started out by setting up a TFTP server on your attached computer. Gave it permissions through the firewall.

What part of the tutorial didn't work?

The router did grab the file stock file but it didn't unbrick. Didn't ever become connectable. Not a tftp issue because when it grabbed LEDE the same way I was able to ssh in and get back up.

Where was the router purchased (US, EU, etc.)?

What regional version of the stock firmware was used?

I also had an Archer C7 v4 EU which had lede on it but i flashed the stock firmware to give to my girlfriend. I flashed the latest firmware from the tplink website through tftp, the process worked fine, I ended up with the wifi leds on after reboot but the router was not accesible from ethernet or from wifi (no dhcp, no ping). I then held the reset button while the router was on, and after reboot everything worked. I didn't need to strip the firmware or anything, it just worked. Maybe you have a similar issue.

I fixed it with something really simple, pressing the reset button. I think the "Keep the settings" is corrupted somehow while updating the firmware.

Greetings to everyone in this thread.
I've recently bought an Archer C7 v4 EU modell. I read quite a lot about the hardware NAT feature of this router, which I'll lose by changing to the LEDE firmware. My question is: will this cause a noticeable speed drop or not too much? (Although my WAN connections is 120 Mbps, I would like to have high-speed link between internal devices.
(As you described also problems by reverting back to the stock firmware, therefore I didn't simply test.)

Not really.

Links between wired LAN devices are handled in the hardware switch chip. It will operate at full 1Gb without any attention from the CPU and firmware.

Using the v4 model on a 200/20 fiber line without any problems. If you have higher line speeds, you might want to include the fastpath patches, but since you mentioned 120mbps, you should be fine. LAN-LAN is not affected at all since there is no NAT involved.