Archer C7 v4 support

I tried now, still the same issue. I can't access it.
Sad, now how am I gonna flash it if I can't access it.

Set up a TFTP server on your computer, or use a serial connection.

TFTP tutorials…

http://bit.ly/2yNN9ej

@Lu5ck, I don't know if the current nightly snapshots still support it, but in the past they would accept a telnet connection until a password was set. It is worth trying that out to see if it works.

Otherwise, you can apply a modifed version of the TFTP method described in https://wiki.openwrt.org/toh/tp-link/archer-c5-c7-wdr7500#tftp_recovery_de-bricking.

So, I tried the jan 2 snapshot. Couple of comments.

SSH works for me. Not sure why it doesn't in your case.
Obviously, since it is a development release, there is no luci.

Recovery is a tad different as on v2. There is no system LED. When the box powers up, the power LED lights, then darkens, if you press the small WPS/WiFi button on the back when the power LED darkens the box the router will go to recovery, which you can see because the power LED starts blinking very fast.

When in recovery mode, SSH works password-less. Telnet got removed from the code completely a while back.

If you can't get SSH to work at all I'd try to make console work. Remember that you need to add resistors to make that work. (have not tried this yet)

Hope this helps,.

Hi tmomas! How you doing?

I have some questions:

1- How can i check the snapshot versions? Using checksum?

2- If i upgrade the snapshot firmware using the sysupgrade file, the Luci GUI packages will be removed?

3-Where can i find the repository page of snapshot versions for a device?

Thanks in advance.
Norberto.

List of all routers currently on snapshot...

https://lede-project.org/toh/views/toh_fwdownload?dataflt[LEDE+Supported+Current+Rel_releasepage*~]=snapshot

Enter your device in the Brand and Model columns to search within these results.

Hi jwoods! How you doing?

I already use snapshot, but i want to know:

1- How discover the file downloads versions (r5xxxx-zzzzz) ? (ex: OpenWrt SNAPSHOT r5638-0f72690 - my actual firmware)

2- If i upgrade the snapshot firmware using the sysupgrade file, the Luci GUI packages will be removed?

3-If exists, where can i find the page of all snapshot versions for archer c7 v4?

Thanks in advance.
Norberto.

Use a hex editor like HxD and search for snapshot.

Any package you add after installing will be removed.

The LEDE repository only contains the current snapshot...

https://downloads.lede-project.org/snapshots/targets/ar71xx/generic/

After upgrade to a new snapshot, can i restore a snapshot backup file from a older version, after install all packages (ex: Luci GUI) ?

1 Like

I don't use snapshots, but this statement in the LEDE snapshot documentation indicates a problem with that approach...

snapshots are built daily, and that sets time limits to installing new packages with opkg. Due to kernel version checksums, you can only install “kmod” kernel modules and other kernel version dependent modules from the exactly same snapshot build. So, a few hours after flashing the firmware you may not be able to install new modules with opkg any more (as the next snapshot has been built into the download repo and has different checksums).

@jwoods Ok, so which firmware do you use? Do you also have an Archer c7 v4?

Thank you so much for the explanation.

@norbertosimioni, when flashing the new snapshot, you can select the option in LuCI to keep the settings. This preserves all or a large section of the /etc directory and should have a similar effect to restoring these files from a backup. In most cases I have never had problems doing this, but there are some cases where enough of the underlying system has changed that the old /etc directory contains configuration options that are not compatible with the new OS.

Note that this really has nothing directly to do with installing additional packages. Just like the main OS, when they are reinstalled they will use the configuration files that are left over in /etc from the previous version.

Great!!! Thank you so much for the explanation.

I am still facing Wifi speed issues with my Archer C7 v4 EU using latest Openwrt/Lede (160Mpbs down vs 290Mpbs with stock firmware). Can you please tell me what speeds you're getting on the 5Ghz band ?

@elbarhoum The same speed as the stock firmware. I changed to OpenWrt (snapshot) because stock firmware usually freezes and I need to reboot...

Thanks for your answer. But what speed are you getting ? My fiber connection goes up to 300Mbps, so it's not the bottleneck here. If yours isn't that fast, maybe you didn't notice the difference between stock and openwrt ?

@elbarhoum i have only 25 Mbps (VDSL)...

@elbarhoum, it would take some effort on my part to setup a comparable configuration to test 300 Mbps on the WAN, but let me ask you a few questions to clarify the issue.

  1. Based on a previous comment, my understanding is that if you connect to a LAN port on the Archer C7 v4 you can transfer 290 Mbps through the WAN port but if you connect with the 5GHz radio you on get 160 Mbps. The older versions of the Archer C7 had a dedicated chip that accelerated WAN NAT (Network Address Translation). The stock firmware had drivers for this chip and could use it to saturate (or nearly saturate) a 1 Gbps NATed WAN connection. LEDE does not have drivers for this chip (closed source) and therefore maxed out at about 150 Mbps on the WAN. However, if you are able to transfer 290 Mbps from a LAN port through the WAN this isn't your problem and probably means the CPU on the v4 can natively handle up to 300 Mbps of NAT traffic.

  2. What are the settings on the 802.11ac radio? I am assuming the mode is AC and the channel is one that doesn't have interference. What is the width?

  3. How many antennas does your client device have?

  4. In LuCI, on the main status page, what does it show as the RX Rate / TX Rate of the client during testing. For example, on of my clients currently shows:

405.0 Mbit/s, 40MHz, MCS 22, Short GI
6.0 Mbit/s, 20MHz

Note that this rate will go up and down based on throughput, as the client will drop to a lower power mode when not much is being transferred.

  1. What happens if you try to transfer data from a computer connected to the LAN to a computer on the 5 GHz wireless chip? You can use a program like iperf to get good information on this, or you can simply try a large file transfer and see how fast it goes.

  2. What is the maximum throughput you get on the 2.4 GHz radio (and how many antennas does the client device have)?

Hopefully, with that information, the root cause of the problem will become more clear. I have mostly moved on to using the Archer C2600, but I can setup an Archer C7 V4 and do some testing on my end to see if what you are seeing affects all units or if there is something unique to just your hardware/configuration.

Speaking of hardware NAT acceleration support, it looks like someday it will be coming to LEDE.

Needs the qca8k driver + maybe ag71xx adjustments. Won't come soon.

1 Like