Archer C7 v4 support

Just bought a US version of Archer C7 v4 and was wondering what can be done to flash this hardware with LEDE.

1 Like

It should be supported by the v2 image. I saw posts where people tested it.
It is 100% that v3 is supported. And only one feedback about v4.

If I could have a boot log, I could tell it for sure.

I was wrong. I see that it has a 8MB flash. That means that the v2 image won't go.
The question is what switch is there... Everything else looks similar.

If this is correct, then the difference is only in flash size.

Is there a bin I can try for 8MB flash size ?

There is a very good chance that this will work.

It is for a Chinese version of this device. Hardware versions look to be one in front in China.

But with the US firmware may have a block for custom firmware. For Archer C7 v2-3 with 16MB flash there are images with the unblocking included. In your case you will need to build it yourself.

And there is no guarantee that Tp-link did not change the flash layout, but this is unlikely. Beware that you can brick the device. A serial cable will be needed to unbrick.

Another way is to solder a 16MB flash to get a C7 v3.

Doesn't look like Wikidev is currently correct for Archer C7 US v4.
The flash chip is 16MB.

Flash: gd25q128c
WI1 chip1: Qualcomm Atheros QCA9563
WI2 chip1: Qualcomm Atheros QCA9880
Switch: Atheros AR8337N

Part of the bootlog:

In this case there is a perfect chance that the V2 firmware should just work.

But ART looks to be in a different place.

v2 is QCA955x based and this one (v4), based on photos, is QCA956x, so image for v2 won't work.

Oops. I did not see it on the photo. It looks like Tp-Link is making a mess with these revisions. I get reports about different hardware on the same revisions. Maybe v4 for EU and US have it different. But it makes no sense.

I only have the US version board, but I've downloaded the EU source code and it seems to confirm that it is also based on the QCA956x.

config ATH79_MACH_ARCHER_C7_V4
bool "TP-LINK ARCHER C7 v4 support"
select SOC_QCA956X
select ATH79_DEV_SPI
select ATH79_DEV_USB
select ATH79_DEV_WMAC
select ATH79_DEV_ETH
select ATH79_DEV_M25P80
Say 'Y' here if you want your kernel to support the
Atheros AP152-Archer_C7_V4 reference board.

Where did you get this Kconfig?

Well you can add this config to target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt of LEDE source and build.
Also you will need to update for modules and probably the unlock.

I've tried writing new firmware with tft and oem webupgrade methods. (using US image)

  • Tft method result: wrong size

  • Oem webupgrade result: wrong filetype

I can read the serial output but cant write to the serial port. I think Rx may be physically disconnected.

Did you use

mktplinkfw factory -C US

I didnt use that command directly but I had defined an Archer C7 v4 device in and used the resulting firmware with US in the name.

I dont have the router right now . I cant do any more tests right now. I'm also new to the build system and probably dont know what im doing.
Has been updated with corrected information.

HI all,

I also get a new C7 v4.
According to this thread and checking the menuconfig, could I say the v4 is still not support so far?


Hi. I have Archer C7 V4 at hand and can help in making it working with LEDE.

So far I know it expects ArcherC7v4_tp_recovery.bin with TFTP. LEDE firmware for V2 doesn't work with this.

What can I do? Can I compile LEDE for it from source?