Archer C7 v4 support

Built, but not working yet. What I tried so far:

  • Adding TPLINK_HWID := 0xc7000004, loading with TFTP - didn't work
  • Building with region code US/EU in addition to hwid - didn't work

Seems like it's safeloader-based.
I could use a hand down here, cuz I'm working atm and any progress I do will be painfully slow.

Here's what I found so far:

fwup-ptn fs-uboot base 0x01000 size 0x0d987
fwup-ptn os-image base 0x0e987 size 0x108a61
fwup-ptn file-system base 0x1173e8 size 0xcffce6
fwup-ptn soft-version base 0xe170ce size 0x00059
fwup-ptn extra-para base 0xe17127 size 0x0000b
fwup-ptn support-list base 0xe17132 size 0x00095
fwup-ptn profile base 0xe171c7 size 0x02ad5
fwup-ptn default-config base 0xe19c9c size 0x0298a
fwup-ptn qos-db base 0xe1c626 size 0x32071
fwup-ptn partition-table base 0x00800 size 0x00800
partition factory-boot base 0x00000 size 0x20000
partition fs-uboot base 0x20000 size 0x20000
partition os-image base 0x40000 size 0x120000
partition file-system base 0x160000 size 0xda0000
partition default-mac base 0xf00000 size 0x00200
partition pin base 0xf00200 size 0x00200
partition device-id base 0xf00400 size 0x00100
partition product-info base 0xf00500 size 0x0fb00
partition soft-version base 0xf10000 size 0x01000
partition extra-para base 0xf11000 size 0x01000
partition support-list base 0xf12000 size 0x0a000
partition profile base 0xf1c000 size 0x04000
partition default-config base 0xf20000 size 0x10000
partition user-config base 0xf30000 size 0x40000
partition qos-db base 0xf70000 size 0x40000
partition certificate base 0xfb0000 size 0x10000
partition partition-table base 0xfc0000 size 0x10000
partition log base 0xfd0000 size 0x20000
partition radio base 0xff0000 size 0x10000

(firmware size should be exactly 14653K)

Did you tested 1Gbit support on Archer C7?
Does it run with 1Gbit/s when running LEDE?
I have netgear wnr3500l v1 and there is a bottleneck problem because of proprieraty drivers, 1Gbit ports never reaches this speed.
That is why I am asking if C7 is able to run with 1Gbit/s speed with LEDE.

Also interested in seeing this v4 supported, guessing that pretty soon, it will be the only choice in the US. Plus, with the way the channel works, we'll see a mix of v2/v3/v4 boxes with no way of knowing what one is getting.
The C7 is a nice workhorse and has been well supported by the community. If a proven Dev wants one to make it work, please PM me.

Bump, any dev interested in tackling this one?
Free C7 v4 to any proven Dev (with commits, etc.).

The community as a whole really needs this, I've found out the v4 is making its way into the channel now.

JonFo, I'd love to, but building GPL code for C7v4 from TP-Link makes only unflashable images that you can't use. Not sure where can I proceed with this, maybe anyone from LEDE team can shed some light on that.

Any updates to this yet/ I am not familiar with compiling LEDE and hoping some one has come up with something. I just purchased this today and would really like to expand this router's capabilities.

I think there no actual hardware on developer's hands.
Can anyone share fullflash dump and give some light about hardware changes in v4 (internal photos)? In our region i bought one about month ago and v2 was sent.

Is there any way to make a full-flash dump file without desoldering memory?
I have a v4, but I'm not dexterous enough to do something like that...

1 Like

Offer still stands, any Dev's?
I'll ship to any US address.

I was lucky enough to purchase a V4 as well, I hope someone can make this work.

Just disassembled my router (South Korean version) and I confirmed that there are Winbond 25Q128JVSQ 128Mbit Flash memory inside of mine, not GigaDevice GD25Q128CSIG as written on here. I'm not sure is it a regional difference.

I tried to solder some jump wires to the flash and make a dump (using Bus Pirate v3.6), but I failed (I'm suffering for a little hand tremor :frowning: ). I'll try later when I've got some test clips

Well should not really matter since both are generic 25Q128 SPI flash.

In the meanwhile I have three EU versions of the Archer C7 v4
If anything needs to be tested, please let me know

Has anyone had luck with this one yet? Just picked one up to play with not being able to tell the version until I got home only to discover it's a 4.0 not a 1 or a 2. Just wondering if I should wait or bring it back.

I tried to dump the ROM using my SPI to USB bridge for 7 times, and all the generated files are not exactly same (different hashes). So I compressed all of these into a single file; You can download these dumps here.


nanoui-iMac:~ nano$ binwalk ~/c7-dump/mungak-6.bin

15104         0x3B00          U-Boot version string, "U-Boot 1.1.4 (May 23 2017 - 14:55:39)"
15152         0x3B30          CRC32 polynomial table, big endian
16452         0x4044          uImage header, header size: 64 bytes, header CRC: 0x3ED6FE0B, created: 2017-05-23 06:55:40, image size: 64186 bytes, Data Address: 0x80010000, Entry Point: 0x80010000, data CRC: 0x51ACE4BF, OS: Linux, CPU: MIPS, image type: Firmware Image, compression type: lzma, image name: "u-boot image"
16516         0x4084          LZMA compressed data, properties: 0x5D, dictionary size: 8388608 bytes, uncompressed size: 168252 bytes
145200        0x23730         U-Boot version string, "U-Boot 1.1.4 (May 23 2017 - 14:55:20)"
145248        0x23760         CRC32 polynomial table, big endian
146540        0x23C6C         uImage header, header size: 64 bytes, header CRC: 0x2FF62EB5, created: 2017-05-23 06:55:21, image size: 40139 bytes, Data Address: 0x80010000, Entry Point: 0x80010000, data CRC: 0xA8028CB0, OS: Linux, CPU: MIPS, image type: Firmware Image, compression type: lzma, image name: "u-boot image"
146604        0x23CAC         LZMA compressed data, properties: 0x5D, dictionary size: 8388608 bytes, uncompressed size: 94956 bytes
262144        0x40000         uImage header, header size: 64 bytes, header CRC: 0x360E50EB, created: 2017-06-02 06:23:49, image size: 1084683 bytes, Data Address: 0x80060000, Entry Point: 0x80060000, data CRC: 0xD366AE23, OS: Linux, CPU: MIPS, image type: Multi-File Image, compression type: lzma, image name: "MIPS OpenWrt Linux-3.3.8"
262216        0x40048         LZMA compressed data, properties: 0x6D, dictionary size: 8388608 bytes, uncompressed size: 3155856 bytes
1441792       0x160000        Squashfs filesystem, little endian, version 4.0, compression:xz, size: 12029735 bytes, 2492 inodes, blocksize: 131072 bytes, created: 2017-06-02 06:24:23

Looks like DD-WRT guys have it already figured out.

Just sayin'

wow...only a little over a week after the request....boom...done!

anybody home?

Need this asap...hardly any other versions exist in retail

What can I do to help?? I would also like this router to be supported