Archer A7 v5 not able to revert to factory firmware using tftp

I tried the original firmware from 2019, and read all other the posts about this.

No matter what I try it once the tftp file is sent to the router. It goes back to the openwrt firmware I have already, and weird thing is that my settings aren’t even wiped.

Is it because the firmware needs to be stripped.

Did you follow the instructions here: https://openwrt.org/toh/tp-link/archer_a7_v5#back_to_stock_firmware

Yes I followed that guide first, but after the router receives the file it reboots back into openwrt.

Recover using the TFTP server method. Written for Windows users...but the concepts are the same for other OS.

Download the stock firmware...you may need to try more than one version.

or

The OpenWRT "factory" firmware can also be used if you don't want to go back to stock.

Download TFTP64.

Rename the downloaded firmware file to ArcherC7v5_tp_recovery.bin, and place it in the same folder as TFTPD64.

Open your network settings in Windows, and select the wired adapter (don't try this on a wireless connection).

Note: It's a good idea to use an unmanaged switch between the router and the computer. It avoids the link-down event, and link training.

Right-click and select Properties.

Select Internet Protocol Version 4 (TCP/IPv4) and click on the Properties button.

In the General tab, select the radio button for Use the Following IP Address.

Enter 192.168.0.66 for the IP address.

Should default to 255.255.255.0 for the Subnet Mask.

Turn the router off.

Make sure nothing else is connected to the router, it should be just the router and your computer.

Open TFTPD64. You may be asked to allow it through the firewall. Select Public.

Note: You may need to temporarily disable the firewall.

Go to Settings > Global, and uncheck everything except TFTP Server.

Go to Settings > TFTP. Select None for TFTP security. Uncheck Option negotiation, and enter 192.168.0.66 in the Bind to this IP address drop down.

Go back to the main window, and make sure the Current Directory dropdown is showing the path to the TFTPD64 folder, which should also contain your recovery firmware file ArcherC7v5_tp_recovery.bin

The IP address 192.168.0.66 should be displayed in the Server Interface dropdown. If not, select it.

Go to the router and press the power button and the reset button at the same time.

Release the power button...but continue to hold the reset button for about 4 or 5 seconds, then release.

You should see a progress bar going across the TFTPD64 screen (although it should only take a very short time).

View the log. It should show 100% transferred.

Go back to your wired network adapter, and change the radio button back to Obtain an IP Address Automatically.

Try to access the router GUI. The stock firmware IP address is 192.168.0.1 and admin/admin for the User Id and Password.

If you can see that you have Internet access in the Network icon, but can't access the GUI, open a Command prompt and run ipconfig /release and then ipconfig /renew.

Try to access the GUI again.

1 Like

It keeps rebooting into openwrt, and It is receiving the file through tftp. I can easily flash openwrt through tftp, but stock firmware is not working via tftp.

The transfer progress always succeeds, but the router is not flashing it though.

How long are you waiting before checking?

Give it 3 or 4 minutes.

Make sure you are using the firmware for the correct region.

Check on the sticker on the outside of the router.

I never lose my wifi settings basically after transfer progress is complete it reboots in 2 minutes, and I can tell because my phone auto connects to the Wi-Fi network with same password.

Are you doing the TFTP transfer on a wireless connection?

If so, it needs to be done wired.

The computer doing the transfer should be the only device connected to the router.

1 Like

No it’s through wired

Did you check the region of your device?

If it's EU, the stock firmware files linked to in the wiki will not work, since they are US.

I have us version.

Are you using an unmanaged switch between the router and the computer?

Is the computer's firewall temporarily disabled?

1 Like

I followed your guide, and tried that network switch thing, but it is still not successfully.

I can see on tfp windows that file is successfully transferred to the router, but it never flashes on the router.

I researched for a while trying to solve this. I had other tp-links routers, and managed to go between openwrt, and stock easily through tftp.

There is a revert stock firmware file that can be downloaded through the DD-WRT site.

The file does not need to be renamed...

See the section TFTP RECOVERY TO REVERT BACK TO STOCK

https://wiki.dd-wrt.com/wiki/index.php/TP_Link_Archer_A7v5

I attempted that, and still reboots right into openwrt

TpLink A7v5 unable to revert to stock firmware - Installing and Using OpenWrt - OpenWrt Forum

same issues as this thread

Sounds like the next step is a serial recovery.

make sure the cable is support 1gb i have c7 and the problem with tftpd was that cable only uses 100mbps not 1000mbps

and tftpd32 works for me tftpd64 doesn't work for me for some reason

100 Mbps Full Duplex and TFTP64D work for my C7 v2.

c7 version 5 doesn't work with 100 mbps